Subject: Re: [Ietf-languages] Errors in Registry

From: "Doug Ewell" <[email-masked]>
Date: Wed, 09 Jan 2019 14:48:54 -0700

Thanks to all for the support. Forms will be coming later this week.
 
I wondered if there was a conflict between Section 2.2.2, which says
extlangs MUST have a P-V identical to the Subtag field, and Section
3.1.7, which says P-Vs MUST be changed so as to avoid chaining.
 
I think we can litigate our way out of this: 3.1.7 describes what
happens when a P-V *changes*, but technically doesn't cover the case
where the P-V field is *removed*. If there is ever a revision to RFC
5646 (I'm not holding my breath), we need to make sure this possible
conflict is resolved.
 
--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 9 Jan 2019 22:02:27 +0000

Hi Doug,

I'm not seeing the requirement in 3.1.7 that you refer to? There are lots of cases in that section, so it may be simply that I'm overlooking the provision, but most of the cases are for specific record types. The extlang ones are consistent with the 2.2.2 requirement.

In this case we're making an errata correction, so I don't think there is any difficulty involved. The rules are slightly permissive for this reason. See for example 3.4 bullet 2, where we use SHOULD instead of MUST (for example):

   2.   Values in the fields 'Preferred-Value' and 'Deprecated' MAY be
        added, altered, or removed via the registration process.  These
        changes SHOULD be limited to changes necessary to mirror changes
        in one of the underlying standards (ISO 639, ISO 15924, ISO
        3166-1, or UN M.49) and typically alteration or removal of a
        'Preferred-Value' is limited specifically to region codes.

Addison

Addison Phillips
Sr. Principal SDE – I18N (Amazon)
Chair (W3C I18N WG)

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]]
> Sent: Wednesday, January 09, 2019 1:49 PM
> To: Phillips, Addison <[email-masked]>; Mark Davis ☕️
> <[email-masked]>; Martin Duerst <[email-masked]>; Arthur
> Reutenauer <[email-masked]>
> Cc: [email-masked]
> Subject: RE: [Ietf-languages] Errors in Registry
> 
> I wondered if there was a conflict between Section 2.2.2, which says extlangs
> MUST have a P-V identical to the Subtag field, and Section 3.1.7, which says
> P-Vs MUST be changed so as to avoid chaining.
> 
> I think we can litigate our way out of this: 3.1.7 describes what happens when
> a P-V *changes*, but technically doesn't cover the case where the P-V field is
> *removed*. If there is ever a revision to RFC
> 5646 (I'm not holding my breath), we need to make sure this possible conflict
> is resolved.
> 
> --