Subject: Re: [ietf-types] Registration of ttml+xml (Update)

From: Philippe Le Hegaret <[email-masked]>
Date: Tue, 14 Dec 2010 11:35:16 -0500

It has been pointed out that the media type registration template for
application/ttml+xml was missing the section "Applications that use this
media type".

Here is the updated template:

MIME media type name:
        
        application
        
MIME subtype name:
        
        ttml+xml
        
Required parameters:
        
        None.
        
Optional parameters:
charset
        
        Same as application/xml media type, as specified in [XML Media
        Types] or its successors.
        
profile
        
        The document profile of a TTML document may be specified using
        an optional profile parameter, which, if specified, the value of
        which must adhere to the syntax and semantics of ttp:profile
        parameter defined by Section 6.2.8 ttp:profile of the published
        specification.
        
Encoding considerations:
        
        Same for application/xml. See [XML Media], Section 3.2.
        
Restrictions on usage:
        
        None.
        
Security considerations:
        
        As with other XML types and as noted in [XML Media] Section 10,
        repeated expansion of maliciously constructed XML entities can
        be used to consume large amounts of memory, which may cause XML
        processors in constrained environments to fail.
        
        In addition, because of the extensibility features for TTML and
        of XML in general, it is possible that "application/ttml+xml"
        may describe content that has security implications beyond those
        described here. However, if the processor follows only the
        normative semantics of the published specification, this content
        will be outside TTML namespaces and may be ignored. Only in the
        case where the processor recognizes and processes the additional
        content, or where further processing of that content is
        dispatched to other processors, would security issues
        potentially arise. And in that case, they would fall outside the
        domain of this registration document.
        
Interoperability considerations:
        
        The published specification describes processing semantics that
        dictate behavior that must be followed when dealing with, among
        other things, unrecognized elements and attributes, both in TTML
        namespaces and in other namespaces.
        
        Because TTML is extensible, conformant "application/ttml+xml"
        processors must expect that content received is well-formed XML,
        but it cannot be guaranteed that the content is valid to a
        particular DTD or Schema or that the processor will recognize
        all of the elements and attributes in the document.
        
Published specification:
        
        This media type registration is extracted from Appendix C Media
        Type Registration of the Timed Text Markup Language (TTML) 1.0
        specification.
        
Applications that use this media type:
        
        TTML is used in the television industry for the purpose of
        authoring, transcoding and exchanging timed text information and
        for delivering captions for television material repurposed for
        the internet.
        
        There is partial and full support of TTML in components used by
        several Web browsers plugins, and in a number of caption
        authoring tools.
        
Additional information:
Magic number(s):
File extension(s):
        
        .ttml
        
Macintosh file type code(s):
        
        "TTML"
        
Macintosh Universal Type Identifier code:
        
        org.w3c.ttml conforms to public.xml
        
Windows Clipboard Name:
        
        "Timed Text Document"
        
Person & email address to contact for further information:
        
        Timed Text Working Group ([email-masked])
        
Intended usage:
        
        COMMON
        
Author/Change controller:
        
        The published specification is a work product of the World Wide
        Web Consortium's Timed Text (TT) Working Group. The W3C has
        change control over this specification.

-- 
Philippe

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Tue, 14 Dec 2010 17:59:37 +0100

>Here is the updated template:

I do note that the issues I pointed out last time are not actually fixed
in this update.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Philippe Le Hegaret <[email-masked]>
Date: Tue, 14 Dec 2010 12:55:29 -0500

> I do note that the issues I pointed out last time are not actually fixed

Weird. I addressed the full stop one and somehow ignored your other
points. I apologize about that and I certainly mean to address your
other points, especially since it would have saved me time now. I'll get
a new version within the next hour,

Philippe

---

From: Philippe Le Hegaret <[email-masked]>
Date: Tue, 14 Dec 2010 13:41:30 -0500

On Sat, 2010-08-28 at 19:16 +0200, Bjoern Hoehrmann wrote:
> >[[
> >MIME media type name:
> 
> This uses an outdated template, not the one from RFC 4288. Some of the
> field names have changed, and some fields have been split into separate
> fields.

I used the template at
 http://tools.ietf.org/html/rfc4288#section-10

> This should just reference the format specification.

I removed the reference to the subsection.

Here is the updated version:

Type name:
        
        application
        
Subtype name:
        
        ttml+xml
        
Required parameters:
        
        None.
        
Optional parameters:
charset

profile

Encoding considerations:

Security considerations:

        

        
Published specification:
        Timed Text Markup Language (TTML) 1.0.

        
        
Additional information:
Magic number(s):
File extension(s):
        
        .ttml

        "TTML"
        
Fragment identifiers:
        
        For documents labeled as application/ttml+xml, the fragment
        identifier notation is intended to be used with xml:id
        attributes, as described in section 7.2.1 of the Timed Text
        Markup Language (TTML) 1.0 specification.

        
Intended usage:
        
        COMMON
        
Restrictions on usage:
        
        None
        
Author:
        
        The published specification is a work product of the World Wide
        Web Consortium's Timed Text (TT) Working Group.
        
Change controller:
        
        The W3C has change control over this specification.

-- 
Philippe