Subject: Re: [ietf-types] Registration of media typeimage/svg+xml

From: Ned Freed <[email-masked]>
Date: Wed, 01 Dec 2010 11:25:47 -0800 (PST)

> OK, is there anything left to do?

The only remaining issue, which came up afer I sent this, is the bit about
fragment ids. I'm happy with Martin's proposal change on that front, but
others may not be.

> Or is this already on the way to IANA?

This is a standards tree registration so it goes to the IESG, not IANA.

				Ned

---

From: Chris Lilley <[email-masked]>
Date: Tue, 7 Dec 2010 15:52:19 +0100

On Thursday, November 25, 2010, 7:30:41 AM, Martin wrote:

MJD> What about:

MJD> Fragment Identifiers

MJD> For documents labeled as application/svg+xml, the fragment
MJD> identifier notation follows the XML Pointer Language (XPointer) 
MJD> Framework (see http://www.w3.org/TR/xptr-framework/). Fragment 
MJD> identifiers are either Shorthand Pointers (formerly called barenames) or
MJD> SVG view specifications. For details, please see Section 17.3.2 of the
MJD> SVG specification 
MJD> (http://www.w3.org/TR/SVG11/linking.html#SVGFragmentIdentifiers).

MJD> or some such. 

I looked into this. At first, I was going to normatively reference XPointer Framework as you suggested.

However, the SVG WG had made a decision not to reference XPointer (superceeded) and not to reference XPointer Framework either, partly because of concerns over the scope of the conformance criteria
http://www.w3.org/TR/xptr-framework/#conformance
and also because this is not in any case needed just to define barenames.

So I have added adapted wording:

    Fragment Identifiers

        For documents labeled as application/svg+xml, the 
        fragment identifier notation is either Shorthand Pointers
        (formerly called barenames) or the SVG-specific SVG Views
        syntax; 
        http://www.w3.org/TR/SVG/linking.html#LinksIntoSVG
        both described in the fragment identifiers section of the 
        SVG specification.
        http://www.w3.org/TR/SVG/linking.html#SVGFragmentIdentifiers

 >>> Published specification:

 >>> This media type registration is extracted from Appendix P of the
 >>> SVG 1.1 specification.
 >>> http://www.w3.org/TR/SVG/mimereg.html

MJD> First, we made some tweaks, and second, the published specification is
MJD> all of SVG 1.1, not just the mimereg part, as far as I understand.

Also fixed; both Appendix P and the spec as a whole are separately referenced.

Published specification:

    This media type registration is extracted from Appendix P 
    http://www.w3.org/TR/SVG/mimereg.html
    of the SVG 1.1 specification.
    http://www.w3.org/TR/SVG/

-- 
 Chris Lilley   Technical Director, Interaction Domain                 
 W3C Graphics Activity Lead, Fonts Activity Lead
 Co-Chair, W3C Hypertext CG
 Member, CSS, WebFonts, SVG Working Groups

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 08 Dec 2010 16:39:14 +0900

Hello Chris, others,

I'm glad to confirm that I'm extremely happy with your new wording.

And I strictly promise I won't find any new hair in the soup anymore.

Regards,    Martin.

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]