Subject: [Insipid] Is the requirements document now complete?

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 3 Jun 2013 19:45:34 +0000

(as WG cochair)

http://www.ietf.org/id/draft-ietf-insipid-session-id-reqts-06.txt 

has recently been posted.

The main open issue to resolve has been the terminology part of the document. This has now been substantially revised based on discussion.

I would therefore ask the working group to review the document, particularly section 3, and indicate in they have concerns such that more work is needed to close open issues before we begin working group last call.

Please respond before Monday 10th June if you think more development work is needed.

Regards

Keith

---

From: Robert Sparks <[email-masked]>
Date: Mon, 03 Jun 2013 15:51:34 -0500

I appreciate accepting the defining text I provided, but as I noted on 
list when we were discussing it, the text that was already in the 
document needs to be simplified and changed to be consistent with that 
definition.

Specifically, what is now section 3.2 needs to be significantly 
simplified to remove the confusion 3.1 tries to clarify.

Per 3.1, the session is a set of messages. It does not help for 3.2 to 
try to describe it as one or more SIP transactions (and later as SIP 
dialogs).

I strongly suggest reducing 3.2 to a very simple list of examples, 
stated in terms of _messages_ and remove the expository text completely.

RjS

On 6/3/13 2:45 PM, DRAGE, Keith (Keith) wrote:
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 4 Jun 2013 20:33:16 +0000

Section 3.1 uses "session" and "communication session" interchangeably. I think it should use one or the other, and the rest of the draft should align this that convention. 
Once you do that, you essentially provide the definition of the session/communication within section 3.1; consequently section 3.2 can go away or be truncated as Robert suggests. In any case, it and the rest of the draft needs to use the same term, be it "session" or "communication session", as defined in section 3.1. 

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Robert Sparks
> Sent: Monday, June 03, 2013 1:52 PM
> To: [email-masked]
> Subject: Re: [Insipid] Is the requirements document now complete?
> 
> > The main open issue to resolve has been the terminology part of the
> document. This has now been substantially revised based on discussion.
> >
> > I would therefore ask the working group to review the document, particularly
> section 3, and indicate in they have concerns such that more work is needed to
> close open issues before we begin working group last call.
> >