Subject: (IPng 7005) EGP routing in IPv6 ?

From: Manolis Sifalakis <[email-masked]>
Date: Tue, 05 Jan 1999 21:52:36 +0200

Hi, i wish to everybody Happy New Year !

 At first i 'd like to apologise if, for any reason, my question has not been sent to
the appropriate list. 
 Since i am new with IPv6, and i am currently reading every piece of information that
gets into my hands (or in front of my eyes!), i have read in several "old" documents
(considering how fast things evolve with the drafts and rfcs in IPv6), that IDRPv2
had been proposed as the newcoming EGP protocol for IPv6, that will replace BGP4. 
 Nevertheless the only draft i could find at the ISI draft-db, had expired. On the 
other hand BGP4 with multiprotocol extentions seems to be widely used, to achieve
EGP routing at the 6bone. My question is this.. "Has the idea of using IDRPv2, been 
abandoned, and BGP4+ is going to be used, instead ???"

Thanks in advance for tolerating my ignorance :-)

Regards 
Manolis

-- 
 +--------------------------------------------------------+
 |               Sifalakis Manolis  (WILLY)               | 
 |                <Network  Administrator>                |
 |  e-mail: [email-masked]                            |
 | nic-hdl: MS4469-RIPE          ARIADNE ACADEMIC NETWORK |
 |     tel: +3 01 6544279            NCSR  DEMOKRITOS     |
 |     tel: +3 01 6543615          15310, Ag. Paraskevi   |
 |     fax: +3 01 6532910              Athens,  GR        |
 +--------------------------------------------------------+
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Bob Hinden <[email-masked]>
Date: Tue, 05 Jan 1999 12:41:58 -0800

Manolis,

>abandoned, and BGP4+ is going to be used, instead ???"

Yes, that is my conclusion as well.

Bob

---

From: Francis Dupont <[email-masked]>
Date: Wed, 06 Jan 1999 09:58:56 +0100

In your previous mail you wrote:

    At first i 'd like to apologise if, for any reason, my question
   has not been sent to the appropriate list.

    Nevertheless the only draft i could find at the ISI draft-db, had
   expired. On the other hand BGP4 with multiprotocol extentions seems to
   be widely used, to achieve EGP routing at the 6bone. My question is
   this.. "Has the idea of using IDRPv2, been abandoned, and BGP4+ is
   going to be used, instead ???"

=> it is the case, near only BGP4+ is used as an EGP for IPv6 today
and there are many implementations of it...
BGP4+ is described in RFC 2283 and the IPv6 part is still in an I-D
(draft-ietf-idr-bgp4-ipv6-01.txt) which has been approved by the IESG
as a Proposed Standard (18 Feb 1998) but not yet published as a RFC
(it seems to be in the queue of the RFC editor with many other RFCs).

Regards

[email-masked]