Subject: RE: Issue 3: on link assumption considered harmful

From: Soliman Hesham <[email-masked]>
Date: Tue, 28 Oct 2003 22:50:37 -0500

> > To allow the scenario mentioned above to work, hosts would
 > > have to communicate using their link-local addresses. 
 > > 
 > > This seems like a reasonable suggestion, any objections?
 > 
 > yes.  I strenously object to any expectation that ordinary 
 > apps should
 > be able to use link-local addresses.  
 > 

=> I should clarify that this is the last resort, 
i.e. if no other addresses exist. So first the link
should be configured with a single prefix, if it were not,
there is nothing left but link-locals. Note that 
this is very much a corner case where hosts on
the link are all manually configured with addresses
and there is _no_ default router.

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Tue, 28 Oct 2003 23:35:46 -0500

>  > apps should be able to use link-local addresses.  
>  > 
> 
> there is nothing left but link-locals. 

it would be far better to have the hosts on the link elect a PUPI as a
prefix to use on that link than to expect apps to use link-locals,
because the transitions between global prefixes and PUPIs are far less
disruptive than the transitions between globals and link-locals.

in general the transitions between configured and unconfigured networks,
and between externally-connected and isolated networks, haven't been worked
out yet.  (or if they have, I've missed the document that describes this...)
they're neither simple nor easy to solve, and we must not treat them
as if they are simple.