Subject: RE: Issue 3: on link assumption considered harmful

From: Soliman Hesham <[email-masked]>
Date: Wed, 29 Oct 2003 19:43:18 -0500

> 
 > I quote yourself on a previous mail on this thread:
 > 
 > "The problems of this assumption are discussed in section 3
 > of Alain's draft. The draft suggests that this assumption
 > should be removed from ND specs. Here is the suggestion:
 > [snipped but it's read as..."remove" and "remove"...]
 > This seems like a reasonable suggestion, any objections?"
 > 
 > As I've already said, I think that on-link communications might
 > be a useful thing to have.

=> Please specify a scenario that would not work
if we remove this statement.

The only one I know that wouuld not work is the one
I mentioned earlier: one link, _no_ default router
and different hosts are _manually_ configured with different 
prefixes. If you want that to work then configure
the hosts with the same prefix. That way they all
know that they're on the same link. If you know
of something else that would break by removing this
statement please describe it.

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Juan Rodriguez Hervella <[email-masked]>
Date: Thu, 30 Oct 2003 12:53:17 +0100

> statement please describe it.

AFAIK, nothing else would break (fortunately).

I've already got an scenario, which is what you are
trying to break. Isn't that enough ?

Of course I can configure _manually_ the hosts , 
as well as configuring the IP address and the default route
(oops...why do people use DHCP ?)

IMO (and I'm not humble), I see that:

"Impact on destination address selection"

and

"Address resolution delays."

Are issues that could be fixed in other ways.

I will write a draft about how to solve these 2 issues without
killing the on-link assuption
(somethig like "draft-....-counter-onlinkassumption-00.txt"), though I can not
tell you when it will be ready.

Besides, if you know more issues, I will be glad to hear about them.

Regards.

-- 
JFRH