Subject: RE: IPv6 adoption behavior

From: Suresh Krishnan <[email-masked]>
Date: Tue, 21 Oct 2003 10:15:00 -0400 (EDT)

>You are wrong :) They tasted the filth of being behind NAT's
>and not being able to do a number of things including VoIP.

I am no NAT apologist but I do not think this is entirely true. Skype runs 
amazingly well behind NATs. As long as NAT is an option people will find 
ways to twist applications to work with it. It is the application 
developer who feels the pain. Not the end user. 

Regards
Suresh

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Ralph Droms <[email-masked]>
Date: Tue, 21 Oct 2003 10:20:00 -0400

How does Skype provide point-to-point connections through NAT without a
centralized intermediary?

- Ralph

---

From: "Jeroen Massar" <[email-masked]>
Date: Tue, 21 Oct 2003 16:27:10 +0200

-----BEGIN PGP SIGNED MESSAGE-----

Ralph Droms [mailto:[email-masked]] wrote:
> How does Skype provide point-to-point connections
> through NAT without a centralized intermediary?

See inline.

Suresh Krishnan [mailto:[email-masked]] wrote:

> I am no NAT apologist but I do not think this is entirely 
> true. Skype runs amazingly well behind NATs.
> As long as NAT is an option people will find 

Skype "works" because it acts like an end to end program.
It connects from a client to the server.
The server has a public un-NATted IP.

There are no IP's being passed in the packets apparently
like in FTP etc. Thus there is no problem either.

If both users are behind NAT's the packets get redirected
via other hosts 'close' to those hosts using a overlay
network above the internet.. named KaZaA in this case.
Same can be done with Teredo and other overlay methods.
Actually at the time of the start of the 6bone when
everything was tunneled IPv6 this actually was the case.

This is not end to end though, it is a workaround
around NAT. Do we want that every application developer
to start working around it? I don't want to. One is
also depending on, not your upstream, but on third parties
to route your packets inside the KaZaA network.

Greets,
 Jeroen

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 21 Oct 2003 10:24:43 -0400 (EDT)

>centralized intermediary?

There is no centralized intermediary. But skype uses other non-NATted 
non-firewalled peers to route calls between two NATted FWed endpoints.

Regards
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 21 Oct 2003 11:32:02 -0400 (EDT)

There is no centralized intermediary. But skype uses other non-NATted 
non-firewalled peers to route calls between two NATted FWed endpoints. 
There is no security concern as the traffic is e2e encrypted.

Regards
Suresh