Subject: RE: RFC 2461- issue list

From: Soliman Hesham <[email-masked]>
Date: Thu, 30 Oct 2003 19:54:27 -0500

Thnx, it's added to the list. Looks like 
a text clarification will do.

Hesham

 > -----Original Message-----
 > From: Pekka Savola [mailto:[email-masked]]
 > Sent: Thursday, October 30, 2003 6:39 PM
 > To: Soliman Hesham
 > Cc: [email-masked]
 > Subject: Re: RFC 2461- issue list
 > 
 > 
 > On Wed, 22 Oct 2003, Soliman Hesham wrote:
 > > This is what I found initially. Please let us know if 
 > > there are any issues that should be added to the list.
 > 
 > Oh, yes, I only now remembered one.  There was some 
 > confusion regarding 
 > redirects and how you can configure the nexthops.  See the 
 > thread I opened 
 > on "global/link-local nexthops and RFC2461" on 17 Jul 2003, also at:
 > 
 > http://www.atm.tut.fi/list-archive/ipng/msg09986.html
 > 
 > It may be that only a textual clarification is needed on the 
 > applicability 
 > of redirects in the presence of non-link-local nexthops, but 
 > if opted to 
 > do more, there could be some other work for to do as well 
 > (my gut feeling 
 > was that only the clarification was deemed necessary)
 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Greg Daley <[email-masked]>
Date: Fri, 31 Oct 2003 12:52:14 +1100

Hi Hesham and Pekka,

I'm not sure if this is the same issue
(looks somewhat related), but RFC2461
allows any source address for an RS message,
and only link-local response (doesn't match
scopes).

The difficulty comes when an RS comes from a global
source address which is not directly connected to
a router.

Based on RS processing rules, the host which sent
the RS is within a hop of the router, but has asked for
an RA from an address which doesn't exist locally.

Does the router reply to a message which has a source
address not believed to be on this link?

Does it only reply with a multicast destination?

What do current implementations do in this case?

I guess that unicast responses aren't appropriate
because I don't think it's valid to put ND entries
into the cache unless they're from the right
network/interface.

Please tell me if I'm going over old ground here..

Greg