Subject: RE: "RFC 2461bis" issue: DNS configuration

From: "Christian Huitema" <[email-masked]>
Date: Tue, 28 Oct 2003 09:59:20 -0800

> > This keeps popping up and we don't seem to be converging. Just
before
> > reading this thread I contacted some people about trying DHCPv6 on
the
> > MSP IETF network. I have no strong preference (yet) for either
DHCPv6
> > or RA. Let's just give DHCPv6 a try.
> >
> > What do you think of this idea?
> 
> It worked fine when we ran it at IETF51 in London.

You do mean DHCPv6 for DNS configuration, right? Many platforms do not
support address assignment via DHCPv6...

-- Christian Huitema

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Tim Chown <[email-masked]>
Date: Tue, 28 Oct 2003 18:49:09 +0000

> support address assignment via DHCPv6...

I think the idea is for DNS resolver discovery... but even less probably
support that?

Tim

---

From: Greg Daley <[email-masked]>
Date: Wed, 29 Oct 2003 10:08:25 +1100

Hi Tim,

> I think the idea is for DNS resolver discovery... but even less probably

I get your point about current implementation
support but think it's worth discussing some issues.

I think that one of the big things about
Router Discovery and Stateless address autoconfiguration
is that people assume that further configuration
mechanisms aren't needed, and that RA options
are the correct place for additional config
information.

While the addressing and routing are handled
in RA reception and subsequent SAA operations,
there's an entire bit ('O' Flag) in the RA header
which says consult your DHCP server for
further configuration.

This actually implies that implementations of
stateful addressing and other configuration
may be separate in some way.

Principally, if M=0, the other configuration
doesn't need to be handled statefully on a
server (or may be cached on the relay/router).

This means the implementation of DHC on routers
doesn't need to be terribly sophisticated, and
avoids lumping generic configuration into
a service which is addressing and routing oriented
(Router Advertisement).

Greg Daley