Subject: I-D ACTION:draft-bykim-ipv6-hpd-00.txt

From: [email-masked]
Date: Thu, 23 Oct 2003 11:32:58 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Hierarchical Prefix Delegation Protocol
	Author(s)	: B. Kim, K. Lee, J. Park, H. Kim
	Filename	: draft-bykim-ipv6-hpd-00.txt
	Pages		: 12
	Date		: 2003-10-23
	
Stateless Autoconfiguration enables IPv6 hosts to send a request for a prefix, a network identifier to a router on the subnet.  Using this  ability a host can configure its IPv6 address.  Likewise, by defining a way to request for a prefix to an upper level router, a router can get a prefix to be assigned to its subnet.

This document describes a protocol for prefix delegation between routers.  It allows routers get prefixes from its upstream routers, enabling the entire network and its belonging hosts autoconfigure their own addresses.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-bykim-ipv6-hpd-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-bykim-ipv6-hpd-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-bykim-ipv6-hpd-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Fri, 24 Oct 2003 00:02:30 +0800

Hi,

I think this is a very interesting document.

In fact, we have been working in something similar for some time, but still not drafted it.

Our case is a very good example, because we are working in a project (www.6power.org) that deploys IPv6 PLC networks. In our case,
we may have different network configurations, with routers, bridges (PLC repeaters) and CPEs.

The idea is to configure the OSS system, in some cases in a static way (with the subscriber parameters), some others automatically
(but keeping the security to avoid non registered users to use the service).

At this way, when the different devices are plugged into the power network, there is no need to do ANY configuration at the devices,
as they will learn (or "create") an adequate network structure, all the way, until the CPE (that can be also a router, of course).

The idea is to extend the auto-configuration capabilities for IPv6 to the complete network. Today we do an autoconfiguration at the
PLC level already. This could provide one very good reason to deploy IPv6, specially in new networks, as will save a lot of
resources in the setup and operation/maintenance.

I think is a very good example of the utility of this document, and for sure we will be interested in cooperate on it, and most
probably work on concrete implementations.

Regards,
Jordi

----- Original Message ----- 
From: <[email-masked]>
To: <IETF-Announce:>
Cc: <[email-masked]>
Sent: Thursday, October 23, 2003 11:32 PM
Subject: I-D ACTION:draft-bykim-ipv6-hpd-00.txt

> Stateless Autoconfiguration enables IPv6 hosts to send a request for a prefix, a network identifier to a router on the subnet.
Using this  ability a host can configure its IPv6 address.  Likewise, by defining a way to request for a prefix to an upper level
router, a router can get a prefix to be assigned to its subnet.
>
> This document describes a protocol for prefix delegation between routers.  It allows routers get prefixes from its upstream
routers, enabling the entire network and its belonging hosts autoconfigure their own addresses.
> implementation to automatically retrieve the ASCII version of the

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 24 Oct 2003 11:28:54 +0900

Hello 

Agreed with jordi's thought. It is a very valuable draft in the IPv6 WG.
As far as the implementation is concerned, it was well done.

Good job

Regards

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of JORDI PALET MARTINEZ
> Sent: Friday, October 24, 2003 1:03 AM
> To: [email-masked]
> Subject: Re: I-D ACTION:draft-bykim-ipv6-hpd-00.txt
> 
> 
> Hi,
> 
> Our case is a very good example, because we are working in a 
> project (www.6power.org) that deploys IPv6 PLC networks. In our case,
> The idea is to configure the OSS system, in some cases in a 
> static way (with the subscriber parameters), some others automatically
> At this way, when the different devices are plugged into the 
> power network, there is no need to do ANY configuration at 
> the devices,
> as they will learn (or "create") an adequate network 
> structure, all the way, until the CPE (that can be also a 
> router, of course).
> 
> The idea is to extend the auto-configuration capabilities for 
> IPv6 to the complete network. Today we do an autoconfiguration at the
> PLC level already. This could provide one very good reason to 
> deploy IPv6, specially in new networks, as will save a lot of
> I think is a very good example of the utility of this 
> document, and for sure we will be interested in cooperate on 
> it, and most
> > Stateless Autoconfiguration enables IPv6 hosts to send a 
> request for a prefix, a network identifier to a router on the subnet.
> Using this  ability a host can configure its IPv6 address.  
> Likewise, by defining a way to request for a prefix to an upper level
> > This document describes a protocol for prefix delegation 
> between routers.  It allows routers get prefixes from its upstream
> This electronic message contains information which may be 
> privileged or confidential. The information is intended to be 
> for the use of the individual(s) named above. If you are not 
> the intended recipient be aware that any disclosure, copying, 
> distribution or use of the contents of this information, 
> including attached files, is prohibited.
> 
> 
>

---

From: "Byung-Yeob Kim" <[email-masked]>
Date: Mon, 27 Oct 2003 13:55:04 +0900

Hi, all
Happy monday, begining of a new week.

I have just visited the project site (www.6power.org) 
and am very impressed.  I agree that PLC would be a good 
starting point for IPv6 deployment.

There are some domestic PLC manufacturers also here in Korea, 
but not yet interested in IPv6.  Anyway, I hope they would join us too.

Thank you for your comments.
We'd welcome any coorperation.

Regards,
Byung-Yeob.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Soohong Daniel Park
Sent: Friday, October 24, 2003 11:29 AM
To: 'JORDI PALET MARTINEZ'; [email-masked]
Subject: RE: I-D ACTION:draft-bykim-ipv6-hpd-00.txt

Hello 

Good job

Regards