Subject: RE: Why is MTU an issue? (RE: [Ipoverib] Please read - proposed W G termination)

From: Dror Goldenberg <[email-masked]>
Date: Fri, 2 Sep 2005 22:49:14 +0300

> From: Mark Townsley [mailto:[email-masked]]
> Sent: Friday, September 02, 2005 10:43 PM

> Dror Goldenberg wrote:
> 
> >
> >
> > > From: Mark Townsley [mailto:[email-masked]]
> > > Sent: Friday, September 02, 2005 4:21 PM
> > >
> > > Harald Tveit Alvestrand wrote:
> > >
> 
> > I think that the right approach is to have a per-neighbor 
> MTU in the 
> > L2 interface. And furthermore, MTU can be different between 
> multicast 
> > and unicast. We're actually trying to see whether a per 
> neighbor MTU 
> > can be added to Linux.
> >
> On the face of it, "per-neighbor" MTU sounds like a 
> management nightmare 
> for anything but a handful of hosts.
> 

You just need to configure for each one of your hosts an MTU for ipoib-cm,
or use the default one. When a connection is made, ipoib-cm chooses
MTU=min(local MTU, remote MTU) and you're done. 
Maybe you can elaborate more on why you think it's a nightmare ?
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Mark Townsley <[email-masked]>
Date: Fri, 02 Sep 2005 22:11:34 +0200

Dror Goldenberg wrote:

> You just need to configure for each one of your hosts an MTU for 
> ipoib-cm, or use the default one. When a connection is made, ipoib-cm 
> chooses MTU=min(local MTU, remote MTU) and you're done.
>
I probably (well, definitely) do not know enough about IB to be making 
such grand statements. But it seemed to me that if each host may have a 
different MTU, then all hosts which can talk to one another within a 
given subnet would have to know the MTU of every other host. So, a 
classic N^2 problem. Is IB natively point 2 point? Perhaps that would 
ease my fears.

- Mark