Subject: [Ipoverib] RE: IPoverIB Digest, Vol 16, Issue 21 [IBCA mib comments]

From: Ali Ayoub <[email-masked]>
Date: Thu, 15 Sep 2005 15:24:47 +0300

Hi all,

I am Ali Ayoub, and I work for Mellanox technologies.

I've started implementing the IBCA MIB module, and I would like to share a
few comments regarding the MIB definition as it appears in
draft-ietf-ipoib-channel-adapter-mib-07.txt:

1. The MIB definition was written according to tables 259 & 260 (Sections
17.2.1, 17.2.2) of the IB spec, v1 r1.1. However, it does not include
important info from section 11.2.1.2 such as: vendor specific information,
vendor ID, vendor part ID, HW/FW version. This information is important
(from network administrator's point of view).

2. The MIB is almost entirely static in the sense that all the info supplied
is determined at driver loading, and does not get changed until the next
reboot. An exception to this is "ibCaInterpacketDelayValue" which is dynamic
according to the current network topology. I suggest to remove this
attribute from the mib to keep it all static (this affects the
implementation data structure too and saves unnecessary queries).
Dynamic info (such as port state) should be moved to the SMA MIB, and the
IBCA MIB definition should become completely static.

3. What is the ibCaSupportsSubnetManager object? I couldn't find it in table
260 as mentioned there. It is by any chance the ibCa*Is*SubnetManager? Then
the right place for this object would also be in the SMA MIB.

Best regards,
Ali Ayoub

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, September 14, 2005 3:54 PM
To: [email-masked]
Subject: IPoverIB Digest, Vol 16, Issue 21

Send IPoverIB mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www1.ietf.org/mailman/listinfo/ipoverib
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of IPoverIB digest..."

Today's Topics:

   1. I-D ACTION:draft-ietf-ipoib-channel-adapter-mib-07.txt 
      ([email-masked])
   2. I-D ACTION:draft-ietf-ipoib-ibif-mib-08.txt 
      ([email-masked])
   3. I-D ACTION:draft-ietf-ipoib-subnet-mgmt-agent-mib-08.txt
      ([email-masked])
   4. I-D	ACTION:draft-ietf-ipoib-baseboard-mgmt-agent-mib-03.txt 
      ([email-masked])
   5. I-D ACTION:draft-ietf-ipoib-perf-mgmt-agent-mib-04.txt 
      ([email-masked])
   6. RE: Ecosystems cost of additional specs (RE: [Ipoverib]
      Please re	ad - proposed WG termination) (Vivek Kashyap)
   7. RE: Ecosystems cost of additional specs (RE: [Ipoverib]
      Please read -	proposed WG termination) (Sean Harnedy)

----------------------------------------------------------------------

Message: 1
Date: Tue, 13 Sep 2005 15:50:01 -0400
From: [email-masked]
Subject: [Ipoverib] I-D
	ACTION:draft-ietf-ipoib-channel-adapter-mib-07.txt 
To: [email-masked]
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects for InfiniBand
Channel Adapters (CA)
	Author(s)	: S. Harnedy
	Filename	: draft-ietf-ipoib-channel-adapter-mib-07.txt
	Pages		: 21
	Date		: 2005-9-13
	
InfiniBand Architecture (IBA) specifies a high speed, channel based, 
   switched fabric architecture that delivers scalable performance in 
   data centers.
        
   This memo defines a portion of the Management Information Base (MIB) 
   for use with network management protocols in the Internet community.  
   In particular, it defines objects for managing InfiniBand Channel 
   Adapters (CA).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-channel-adapter-mib-07.
txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-channel-adapter-mib-07.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ipoib-channel-adapter-mib-07.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-------------- next part --------------
Skipped content of type multipart/alternative

------------------------------

Message: 2
Date: Tue, 13 Sep 2005 15:50:01 -0400
From: [email-masked]
Subject: [Ipoverib] I-D ACTION:draft-ietf-ipoib-ibif-mib-08.txt 
To: [email-masked]
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects for InfiniBand
Interface Types
	Author(s)	: B. Anderson, S. Harnedy
	Filename	: draft-ietf-ipoib-ibif-mib-08.txt
	Pages		: 26
	Date		: 2005-9-13
	
InfiniBand Architecture (IBA) specifies a high speed, channel based,
   switched fabric architecture that delivers scalable performance in 
   data centers.
        
   This memo defines a portion of the Management Information Base (MIB)
   for use with network management protocols in Internet community.
   In particular, it defines objects for managing IBA defined InfiniBand
   interfaces.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-ibif-mib-08.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-ibif-mib-08.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ipoib-ibif-mib-08.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-------------- next part --------------
Skipped content of type multipart/alternative

------------------------------

Message: 3
Date: Tue, 13 Sep 2005 15:50:01 -0400
From: [email-masked]
Subject: [Ipoverib] I-D
	ACTION:draft-ietf-ipoib-subnet-mgmt-agent-mib-08.txt
To: [email-masked]
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects for the 
                          InfiniBand Subnet Management Agent (SMA)
	Author(s)	: S. Harnedy, et al.
	Filename	: draft-ietf-ipoib-subnet-mgmt-agent-mib-08.txt
	Pages		: 70
	Date		: 2005-9-13
	
InfiniBand Architecture (IBA) specifies a high speed, channel based, 
   switched fabric architecture that delivers scalable performance in 
   data centers.
        
   This memo defines a portion of the Management Information Base (MIB) 
   for use with network management protocols in the Internet community.
   In particular, it defines objects for managing InfiniBand Subnet 
   Management Agents (SMA).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-subnet-mgmt-agent-mib-0
8.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-subnet-mgmt-agent-mib-08.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-ietf-ipoib-subnet-mgmt-agent-mib-08.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-------------- next part --------------
Skipped content of type multipart/alternative

------------------------------

Message: 4
Date: Tue, 13 Sep 2005 15:50:01 -0400
From: [email-masked]
Subject: [Ipoverib] I-D
	ACTION:draft-ietf-ipoib-baseboard-mgmt-agent-mib-03.txt 
To: [email-masked]
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects for the InfiniBand
Baseboard Management Agent (BMA)
	Author(s)	: S. Harnedy
	Filename	: draft-ietf-ipoib-baseboard-mgmt-agent-mib-03.txt
	Pages		: 42
	Date		: 2005-9-13
	
InfiniBand Architecture (IBA) specifies a high speed, channel based, 
   switched fabric architecture that delivers scalable performance in 
   data centers.
        
   This memo defines a portion of the Management Information Base (MIB) 
   for use with network management protocols in the Internet community.
   In particular, it defines objects for managing InfiniBand Baseboard 
   Management Agents (BMA).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-baseboard-mgmt-agent-mi
b-03.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-baseboard-mgmt-agent-mib-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE
/internet-drafts/draft-ietf-ipoib-baseboard-mgmt-agent-mib-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-------------- next part --------------
Skipped content of type multipart/alternative

------------------------------

Message: 5
Date: Tue, 13 Sep 2005 15:50:01 -0400
From: [email-masked]
Subject: [Ipoverib] I-D
	ACTION:draft-ietf-ipoib-perf-mgmt-agent-mib-04.txt 
To: [email-masked]
Cc: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="us-ascii"

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over InfiniBand Working Group of the
IETF.

	Title		: Definitions of Managed Objects for the InfiniBand
Performance Management Agent (PMA)
	Author(s)	: S. Harnedy
	Filename	: draft-ietf-ipoib-perf-mgmt-agent-mib-04.txt
	Pages		: 53
	Date		: 2005-9-13
	
InfiniBand Architecture (IBA) specifies a high speed, channel based, 
   switched fabric architecture that delivers scalable performance in 
   data centers.
        
   This memo defines a portion of the Management Information Base (MIB) 
   for use with network management protocols in the Internet community.  
   In particular, it defines objects for managing InfiniBand Performance 
   Management Agents (PMA).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ipoib-perf-mgmt-agent-mib-04.
txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the
message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ipoib-perf-mgmt-agent-mib-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ipoib-perf-mgmt-agent-mib-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
-------------- next part --------------
Skipped content of type multipart/alternative

------------------------------

Message: 6
Date: Tue, 13 Sep 2005 22:55:56 -0700 (PDT)
From: Vivek Kashyap <[email-masked]>
Subject: RE: Ecosystems cost of additional specs (RE: [Ipoverib]
	Please re	ad - proposed WG termination)
To: "H.K. Jerry Chu" <[email-masked]>
Cc: [email-masked], [email-masked]
Message-ID: <[email-masked]>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed

On Mon, 12 Sep 2005, H.K. Jerry Chu wrote:

> ...
> <snip>
>
>> In any case, I think the debate has played itself out and the virtual hum
>> says to proceed.
>
> Actually a similar debate and virtual hum already happened a couple of
> years ago, before the proposal was accepted as a work item for the WG.

There have been other, more recent, agreements/hums too. The connected mode 
draft became a working group draft late last year/early this year.

> So the debate in the past couple of weeks, although interesting and may
> even be educational for the late comers, is mostly moot.

Wasn't the query whether the wg should continue and if there was interest 
in the specification? Why would that make the 'virtual hum' now moot?

>
> The decision facing the working group now is to either have enough
> people committed to reviewing and producing a high quality standard,
> or have the WG disbanded. We will have to decide soon.

I thought the discussion over the last few days was answering the question
of WG continuance.  In any case, I'm committed to continuing to work on the 
draft and bringing it to publication.

Vivek

>
> Jerry
>
>> So, I'll go quiet unless someone has a specific issue or
>> wants to continue the debate for some other reason.  Mark me down as not
>> supporting the hum which is likely just me in this regard.
>>
>> Mike
>
>
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipoverib
>
>

------------------------------

Message: 7
Date: Wed, 14 Sep 2005 08:57:20 -0400
From: "Sean Harnedy" <[email-masked]>
Subject: RE: Ecosystems cost of additional specs (RE: [Ipoverib]
	Please read -	proposed WG termination)
To: "Vivek Kashyap" <[email-masked]>,	"H.K. Jerry Chu"
	<[email-masked]>
Cc: [email-masked], [email-masked]
Message-ID:
	<[email-masked]>
Content-Type: text/plain;	charset="us-ascii"

I have also just updated the 6 IP Over IB MIB I-Ds and they are now on
the WG web page again. What needs to be done now to bring these to
publication?

/sean

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Vivek Kashyap
Sent: Wednesday, September 14, 2005 1:56 AM
To: H.K. Jerry Chu
Cc: [email-masked]; [email-masked]
Subject: RE: Ecosystems cost of additional specs (RE: [Ipoverib] Please
read - proposed WG termination)

On Mon, 12 Sep 2005, H.K. Jerry Chu wrote:

> ...
> <snip>
>
>> In any case, I think the debate has played itself out and the virtual
hum
>> says to proceed.
>
> Actually a similar debate and virtual hum already happened a couple of
> years ago, before the proposal was accepted as a work item for the WG.

There have been other, more recent, agreements/hums too. The connected
mode 
draft became a working group draft late last year/early this year.

> So the debate in the past couple of weeks, although interesting and
may
> even be educational for the late comers, is mostly moot.

Wasn't the query whether the wg should continue and if there was
interest 
in the specification? Why would that make the 'virtual hum' now moot?

>
> The decision facing the working group now is to either have enough
> people committed to reviewing and producing a high quality standard,
> or have the WG disbanded. We will have to decide soon.

I thought the discussion over the last few days was answering the
question
of WG continuance.  In any case, I'm committed to continuing to work on
the 
draft and bringing it to publication.

Vivek

>
> Jerry
>
>> So, I'll go quiet unless someone has a specific issue or
>> wants to continue the debate for some other reason.  Mark me down as
not
>> supporting the hum which is likely just me in this regard.
>>
>> Mike
>
>
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipoverib
>
>

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

------------------------------

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

End of IPoverIB Digest, Vol 16, Issue 21
****************************************
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: [email-masked]
Date: Thu, 15 Sep 2005 20:46:55 -0700 (PDT)

Some comments from me personally (WG Chair hat off the head sitting way
across the desk)

inline
Bill
> I am Ali Ayoub, and I work for Mellanox technologies.
Welcome to the group.
> draft-ietf-ipoib-channel-adapter-mib-07.txt:
Great - glad to hear some of the MIBs are being implemented.

> (from network administrator's point of view).
I would assume such things would belong in the enterprise mib for the
particular vendor.

However if there are specific GENERIC things that belong in this MIB -
write a object up, submit it here and after we look it over Sean can add
it into an updated draft

> IBCA MIB definition should become completely static.
Hate to say it... but this seems like an implementation issue.  But will
take this under advisement... any other implementors out there feel the
same way ?

> the right place for this object would also be in the SMA MIB.
Sean ?

I need to go look at this one closer - but Sean, what was your intention