Subject: [IPP] RFC: Definitions of Workgroup, Enterprise, and Production Printers

From: Michael Sweet via ipp <[email-masked]>
Date: Sat, 15 Jan 2022 10:04:59 -0500

All,

For general discussion and subsequent adoption by our various specifications:

Workgroup Printer: An Output Device that is used by a single End User or small groups of people to produce reports, presentations, photographs, and other low volume output.

Enterprise Printer: A high availability Output Device that is shared by large groups of people and typically supports features such as Job Accounting, Print Policies, Release Printing, Finishing, and Job Storage.

Production Printer: A high volume and/or large format Output Device that is used to deliver finished print products such as books, magazines, business cards, posters, and so forth.

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: William Wagner via ipp <[email-masked]>
Date: Sat, 15 Jan 2022 20:24:01 +0000

Thank you Mike. I have a few comments/questions.

  1.  I suggest adding ‘hardcopy” to “output” in all cases, just so it is clear what is being output.
  2.  It has, I believe, been  the position that “Printer” refers to a service and not necessarily an output device, and may not even include a output device (although this may not be consistent with  common usage.) Here, the definitions clearly define these printers as output devices (i.e.., excluding ‘logical’ printers?) And  is this likely to cause confusion?
  3.  I tend to think of a workgroup printer as being in a work environment and serving a group of people. What would one call my printer at home? Or the printers attached to specific workstations (e.g., receptionists) or printers in medical exam rooms (used for prescriptions, or information on problems for parents.
  4.  For  Workgroup printer and Production , the type of hardcopy output is listed. For  Enterprise Printer, a group  of ancillary services are listed. It might be desirable to list the types of primary hardcopy outputs and then indicate the other support services.
  5.  I think  we should distinguish between a Production Printer and what I would  call a printing press. (I go back to printing reports on an offset press using typed mats for plates) But perhaps  the definition is intended to include high volume newspaper and magazine presses? I though we were more concerned with “light’ production printing.
Thanks,
Bill Wagner

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows

From: Michael Sweet via ipp<mailto:[email-masked]>
Sent: Saturday, January 15, 2022 10:05 AM
To: PWG IPP Workgroup<mailto:[email-masked]>
Subject: [IPP] RFC: Definitions of Workgroup, Enterprise, and Production Printers

All,

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 17 Jan 2022 09:32:58 -0500

Bill, thanks.  Responses inline below...

> On Jan 15, 2022, at 3:24 PM, William Wagner <[email-masked]> wrote:
> 
> 	• I suggest adding ‘hardcopy” to “output” in all cases, just so it is clear what is being output.

Agreed.

> 	• It has, I believe, been  the position that “Printer” refers to a service and not necessarily an output device, and may not even include a output device (although this may not be consistent with  common usage.) Here, the definitions clearly define these printers as output devices (i.e.., excluding ‘logical’ printers?) And  is this likely to cause confusion?

We already have:

    Output Device: a single Logical or Physical Device

but I can reword to specify "Logical or Physical Device" if you think it will help.

> 	• I tend to think of a workgroup printer as being in a work environment and serving a group of people. What would one call my printer at home? Or the printers attached to specific workstations (e.g., receptionists) or printers in medical exam rooms (used for prescriptions, or information on problems for parents.

I went with the notion that any small (SOHO) network printer is a "workgroup" printer, but we could add a separate category for printers that are exclusively marketed as home printers.  Or we could use the SOHO acronym to clarify what we mean by workgroup?

> 	• For  Workgroup printer and Production , the type of hardcopy output is listed. For  Enterprise Printer, a group  of ancillary services are listed. It might be desirable to list the types of primary hardcopy outputs and then indicate the other support services.

After thinking about it, I'm wondering if I should just pull the type of hardcopy output from the Workgroup Printer - only production is focused on a particular kind/volume of output while the others handle "regular" output.

> 	• I think  we should distinguish between a Production Printer and what I would  call a printing press. (I go back to printing reports on an offset press using typed mats for plates) But perhaps  the definition is intended to include high volume newspaper and magazine presses? I though we were more concerned with “light’ production printing.

Most of the current definition comes from the introduction to PPX, which in turn came from the original (5100.3).  I'm not aware of any printing presses that support IPP, but as long as you can send a digital document to the press and get output there is no reason why it couldn't use IPP.  At the same time I don't want to cause undue confusion...

If you have suggestions for how to clarify this definition, I'm open to them.

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 18 Jan 2022 17:13:38 +0000

Thanks for this Mike!

I was reading these and one thing that occurred to me is that the Enterprise Printer category is mostly about features supporting a larger volume of users, although finishing is certainly an exception to this. The Production Printer, by contrast, is more about even more sophisticated features and more granular control of those features, and while still having a need for more Job Accounting is usually not supporting access to a large number of users, Print Policies or Release Printing. Does that seem correct?

I also wanted to point out that a "Cloud Workgroup Printer" adds in some of the AAA requirements of Enterprise printer, which drives some of those Enterprise class features into smaller units. Does that seem reasonable? Should we be adding that to the taxonomy as a separate category or as a mix-in?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Jan 15, 2022, at 8:04 AM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> <signature.asc>_______________________________________________
> ipp mailing list
> [email-masked]

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 18 Jan 2022 17:46:31 +0000

Hi there,

> On Jan 17, 2022, at 7:32 AM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> Signed PGP part

Many "home" class printers these days are Wi-Fi enabled. The boundary between SOHO vs. SMB is tricky.

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 18 Jan 2022 15:01:52 -0500

Smith,

> On Jan 18, 2022, at 12:46 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi there,
> 

For the purposes of an IPP specification, I think we can assume that the printer either has Wi-Fi and/or Ethernet networking or uses IPP-USB.  And these days both workgroup and enterprise printers can be found in SMB environments (i.e. you have one big enterprise MFP/copier for the office and a bunch of smaller workgroup printers for key people/groups), all tied into a single managed service/plan.

I think the key difference (in my mind) is that a Workgroup Printer is meant for use by a small number of people (possibly just one person) for printing a relatively small number of pages while an Enterprise Printer is meant to be used by a large number of people (a whole office/site) to print a large number of pages.

Beyond that, I think we actually have six distinct categories:

- Workgroup/desktop/home, small office printers with one or two paper trays (possibly with a separate manual feed slot), often with duplexers.  Most only support "small format" (Letter/Legal/A4) paper sizes, a few might go up to 13x19 ("medium format"), and an even smaller number specializing in photo/fine art printing that support roll printing (but have no cutter).  Maximum rated volume is typically a few thousand pages per month.

- Enterprise printers with multiple paper trays, duplexer, staple, punch, and/or fold finisher options, and output handling options (mailboxes, etc.)  Most also support release (PIN or otherwise) printing and can be configured for a wide variety of enterprise-y (job storage, accounting, IAA, etc.) or specialized (MICR for banking, etc.) features.  Physically most can be installed on a desk but more often are installed on the floor with tray/storage bases from the vendor. Maximum rated volume is typically tens to hundreds of thousands of pages per month.

- (Light) Production printers with multiple paper trays, duplexer, and wide variety of finishers. They often require dedicated power circuits and service personnel, and provide document processing features such as imposition and accounting/banner/error/insert sheets.  Maximum rated volume is typically hundreds of thousands to millions of pages per month.

- Large format roll-fed printers with special output bins/rolls and cutters for printing large banners, posters, etc. Typically these provide some kinds of production features (imposition/layout in particular) and enhanced color management functionality.

- Label/receipt printers in home, retail, and industrial settings for printing everything from your grocery receipt to the serial/model # label that goes on a manufactured product, easily tens of trillions of "pages" each year as a category.  Cutters are a common finisher option.  Almost all use direct thermal or thermal transfer printing technology.

- Card printers (retail/enterprise/industrial) for printing drivers licenses and other ID cards along with credit/bank cards.  Magnetic strips, RFID chips, and other technologies are often embedded, and many support two-sided printing and embossing functions as well.

The latter two are only slowly adopting modern network protocols/standards.

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 18 Jan 2022 15:18:48 -0500

Smith,

> On Jan 18, 2022, at 12:13 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Thanks for this Mike!
> 

Yes, the focus on production is on the customer, not individual users.  So the accounting stuff is explicitly for billing vs. cost tracking/management in the enterprise (which gets tied to users/orgs/projects).

> I also wanted to point out that a "Cloud Workgroup Printer" adds in some of the AAA requirements of Enterprise printer, which drives some of those Enterprise class features into smaller units. Does…

CUPS has been providing "enterprise" and "light production" functionality to $50 inkjet printers for over 20 years! :)  That doesn't mean that we should call every $50 printer a "Cloud Workgroup Printer", or that we can test such as printer for conformance to such a category - we can only test CUPS' conformance, right?

STD 92 already covers fan-out to output devices and the notion that the IPP Printer object provides a high-level interface to them.  Any managed/cloud print service that talks to a Workgroup Printer is doing fan-out, and if that print service conforms to EPX then it (the print service) is an Enterprise Printer, not the Workgroup Printer it talks to.

________________________
Michael Sweet