Subject: [ippm] FYI, TSVWG agenda item: ipmp

From: Matthew J Zekauskas <[email-masked]>
Date: Fri, 14 Mar 2003 07:25:23 -0500

FYI, for those not on the TSVWG list.

Jon Bennett has updated his IPMP draft (he presented at IPPM
in Atlanta), and is making a presentation to TSVWG (I don't
have any details, I just read the agenda).   In addition,
Tony McGregor (original IPMP author, presented last March
in Minneapolis) has submitted a revised draft of his version
( http://www.ietf.org/internet-drafts/draft-mcgregor-ipmp-01.txt ).

People that are interested might want to read both drafts
and attend the TSVWG meeting.

--Matt

---------- Forwarded Message ----------
Date: Tuesday, March 11, 2003 10:34 PM -0800
From: Allison Mankin <[email-masked]>
To: [email-masked], [email-masked]
Cc: [email-masked], [email-masked], [email-masked]
Subject: [Tsvwg] Agenda for TSVWG Meeting in SF

[excerpt -mjz]

Measurement discussion*

  draft-bennett-ippm-ipmp-01.txt - John Bennett - 15 mins.

   *An IP measurement protocol, this was considered by
    the IPPM WG, but seen as broader, so sent here for a
    discussion by a larger group of transport folks.

---------- End Forwarded Message ----------

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: Jing Shen <[email-masked]>
Date: Sat, 15 Mar 2003 21:49:32 +0800 (CST)

Hi, 
I just read draft-mcgregor-ipmp-01.txt, and have a little question on it:
in Sec4.4.2, it is stated that :
   ........this requires writingthe address to the packet and

   updating the checksum and Path
   Pointer in the packet as described in section 3.3.1 and 4.2.1.
   In this case the forwarding system does not need to process IPMP
   Information Request packets.
.............................

if forwarding router needs to update checksum and path pointer in IPMP

packet, it should know which packet should be updated. Why is the draft

stated forwarding system DOES NOT need to process IRP?  

And, is there any consideration on supporting function like traceroute?

Thanks 

regards

 Matthew J Zekauskas <[email-masked]> wrote:FYI, for those not on the TSVWG list.

--Matt

---------- Forwarded Message ----------
Date: Tuesday, March 11, 2003 10:34 PM -0800
From: Allison Mankin 
To: [email-masked], [email-masked]
Cc: [email-masked], [email-masked], [email-masked]
Subject: [Tsvwg] Agenda for TSVWG Meeting in SF

[excerpt -mjz]

Measurement discussion*

---------- End Forwarded Message ----------

Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, ZheJiang Province 310027
P.R.China

---------------------------------
Do You Yahoo!?
"更多惊喜，同样精彩，NetVista A30 热卖"

---

From: Tony McGregor <[email-masked]>
Date: Mon, 17 Mar 2003 08:15:30 +1200 (NZST)

On Sat, 15 Mar 2003, [gb2312] Jing Shen wrote:

> if forwarding router needs to update checksum and path pointer in
> IPMP packet, it should know which packet should be updated. Why is
> the draft stated forwarding system DOES NOT need to process IRP?

The primary function of the Information Request/Information Reply
mechanism is to allow timestamps to be mapped from router timestamps
to real time.  If a router does not insert timestamps this mechanism
is not needed.

Section 4.4.2 allows a simpler router implementation for a vendor to
provide a very simple IPMP implementation, should they choose to do
that.

> And, is there any consideration on supporting function like traceroute?

A single IPMP echo request/reply will return all IPMP enabled
components of the path.  A traceroute like approach can then be used
to resolve any non-IPMP components of the path, if they exist.  Note
that even if IPMP is only implemented in the end-systems this
mechanism can return the forward and reverse path, because IPMP
preserves TTL at the echoing host.

Tony