Subject: [ippm] recording internal router's ip address

From: Heonkyu Park <[email-masked]>
Date: Wed, 5 Mar 2003 12:27:33 +0900

Dear all,

I'm wondering if there exists a protocol having function to record internal router's ip address from source to destination.

'traceroute' works well, however, it need to send n requests if there is n routers varying ttl value.
'ping -R' has similiar function, still have 9 limit router and many router ignore/discard this option.

What I want is one-way-packet from source to destination without echo_request.
Source send a packet, all internal router record its ip, destination host uses this information and discard it.

Any comments/reply will be appreciated.

Thanks.

Heonkyu Park,
Korea Advanced Institute of Science and Technology, Repulic of Korea
+82-42-869-3554
[email-masked]
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: Tony McGregor <[email-masked]>
Date: Wed, 5 Mar 2003 16:41:07 +1300 (NZDT)

> Any comments/reply will be appreciated.

There is an internet draft which does just that
  
   http://www.ietf.org/internet-drafts/draft-mcgregor-ipmp-01.txt

Tony

_______________________________________________
Ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Matthew Luckie <[email-masked]>
Date: Wed, 5 Mar 2003 16:43:52 +1300 (NZDT)

There has been one _proposed_ called IPMP.

http://wand.cs.waikato.ac.nz/wand/publications/imw2001-probing.pdf
http://www.ietf.org/internet-drafts/draft-mcgregor-ipmp-01.txt

On Wed, 5 Mar 2003, Heonkyu Park wrote:

> Dear all,
>
> I'm wondering if there exists a protocol having function to record
> internal router's ip address from source to destination.

---

From: Matthew Luckie <[email-masked]>
Date: Wed, 5 Mar 2003 16:43:52 +1300 (NZDT)

---

From: Tony McGregor <[email-masked]>
Date: Wed, 5 Mar 2003 16:41:07 +1300 (NZDT)

Tony

---

From: Matthew Luckie <[email-masked]>
Date: Wed, 5 Mar 2003 16:43:52 +1300 (NZDT)

---

From: Tony McGregor <[email-masked]>
Date: Wed, 5 Mar 2003 16:41:07 +1300 (NZDT)

Tony

---

From: "Paul Rolland" <[email-masked]>
Date: Wed, 5 Mar 2003 08:08:27 +0100

Hello,

> > 'traceroute' works well, however, it need to send n 
> requests if there 
> > is n routers varying ttl value. 'ping -R' has similiar 
> function, still 
> > have 9 limit router and many router ignore/discard this option.

This is correct. This is based on the Record_route facility, but many
ISPs are configuting their equipments to ignore this facility.
What's more, the available number of bytes in the ICMP packets is
limited, which is the reason why you can't see more than 9 hops.

> > What I want is one-way-packet from source to destination without 
> > echo_request. Source send a packet, all internal router 
> record its ip, 
> > destination host uses this information and discard it.
Many people would like to have that...
 
>   http://www.ietf.org/internet-drafts/draft-mcgregor-ipmp-01.txt

Correct, but this is a draft, and it now needs to be widely implemented
and deployed.

Does anyone have more details on that point ?

Regards
Paul, [email-masked]

---

From: "Paul Rolland" <[email-masked]>
Date: Wed, 5 Mar 2003 08:08:27 +0100

Hello,

 

Regards
Paul, [email-masked]

---

From: Matthew Luckie <[email-masked]>
Date: Wed, 5 Mar 2003 21:21:42 +1300 (NZDT)

first off, ICMP traceback might be of interest to the original poster
http://www.ietf.org/html.charters/itrace-charter.html

> ISPs are configuting their equipments to ignore this facility.

which is also guaranteed to happen with IPMP

> Many people would like to have that...

we tried at IETF 53 to get enough support so that we could work towards
this as part of the IPPM working group.  if there is sufficient support we
could look towards a birds of a feather at an IETF or working with a WG to
re-charter.

> Does anyone have more details on that point ?

We've written BSD and Linux kernel implementations, and I have plans to
write something in VHDL.

I'll tidy the code up and put it on my web page in a few days.  An old
FreeBSD implementation is sitting on http://moat.nlanr.net/~mjl/ but it
looks nothing like what I have now.

We have it deployed amongst linux-based routers in the CRCnet project
http://www.crc.net.nz

mjl@ttk:~$ ipmp_ping -4Nrhs 184 kor
ipmp_ping gw.kor.crc.net.nz (10.1.11.254)...
*  0  ttk-uni.crc.net.nz  Mar  5 20:57:54 2003 505972149
   1  cbk-uni.crc.net.nz  Mar  5 20:57:49 2003 332780804
   2  mwp-cbk.crc.net.nz  Mar  5 20:57:54 2003 523801648
   3  mfr-mwp.crc.net.nz  Mar  5 20:58:07 2003 600482743
   4  wde-mfr.crc.net.nz  Mar  6 05:01:59 2003 655455170
*  5   gw.kor.crc.net.nz  Mar  5 20:57:54 2003 512720994
   6  wde-kor.crc.net.nz  Mar  6 05:01:59 2003 657799326
   7  mfr-wde.crc.net.nz  Mar  5 20:58:07 2003 604987512
   8  mwp-cbk.crc.net.nz  Mar  5 20:57:54 2003 530654401
   9  cbk-mwp.crc.net.nz  Mar  5 20:57:49 2003 342060041
* 10  ttk-uni.crc.net.nz  Mar  5 20:57:54 2003 530605017
forward path = 4 hops, reverse path = 4 hops
rtt: 25ms

we don't need synchronised clocks to do bandwidth estimation, so i'm in
the middle of writing ipmp_pathchar.  the current (undeveloped and
probably wrong) theory is this:

Given the first packet $P$ is of size $S$ and the second packet $P'$ is of
size $S'$ - where $S'$ is larger than $S$ - then given a round-trip IP
path that is $H$ hops in length, the available bandwidth $A$ seen by the
packets on the path is

\begin{equation}
\mathop{A_{[n]}}_{n = 1 \ldots H} =
\frac{S' - S}{(P'_{[n]} - P_{[n]}) - (P'_{[n-1]} - P_{[n-1]})}
\end{equation}

   A[n]                      S' - S
            = -------------------------------------
n = 1 .. H     (P'[n] - P[n]) - (P'[n-1] - P[n-1])

Our method does not degrade with excessive noise the longer the path it
measures because the packet is not responded to anywhere in the network
except at the end host.
In addition, we can estimate the bandwidth available on the reverse path
without requiring an out-of-band communication.

In his MSRI presentation~\cite{pathchar}, Jacobson identified as future
work the need for a method to isolate each hop's behaviour, so that the
signal to noise ratio and the associated error bounds to not increase with
each additional hop in the path.

We simply require that each clock represented in the measurement is of
sufficient resolution to measure the serialisation rate of the incoming
link, and that it timestamps based on the time it sees the last bit in the
packet.
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Paul Rolland" <[email-masked]>
Date: Wed, 5 Mar 2003 08:08:27 +0100

Hello,

 

Regards
Paul, [email-masked]