Subject: [ippm] I-D Action:draft-ietf-ippm-reporting-metrics-04.txt

From: [email-masked]
Date: Mon, 25 Oct 2010 15:30:08 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Metrics Working Group of the IETF.

	Title           : Reporting Metrics: Different Points of View
	Author(s)       : A. Morton, et al.
	Filename        : draft-ietf-ippm-reporting-metrics-04.txt
	Pages           : 25
	Date            : 2010-10-25

Consumers of IP network performance metrics have many different uses
in mind.  The memo provides "long-term" reporting considerations
(e.g, days, weeks or months, as opposed to 10 seconds), based on
analysis of the two key audience points-of-view.  It describes how
the audience categories affect the selection of metric parameters and
options when seeking info that serves their needs.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ippm-reporting-metrics-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Barry Constantine <[email-masked]>
Date: Wed, 27 Oct 2010 12:37:07 -0700

Hello,

I had some time to review this work and found it interesting.  Explaining the relationship of PDV from an RFC5481/3393 to Y.1540 is very useful.  Also, applying the ITU concept of availability is a good idea.

Below are my comments:

4.1.2.  It is difficult to specify what an application's threshold for delay is.  Applications have many unknown behaviors and loss / delay is certainly one of them.  I think the intent of this paragraph is good, but not sure if it is practical.

4.2 Last sentence.  Could not agree more with this point; satellite communications is a classic example where error correction is used and it is highly desirable to know which packets were truly dropped versus ones that could not be corrected.

5.1.1 Last paragraph.  I had a hard time understanding the concept of the last sentence and how it pertained to this section's theme.

5.2 For long term monitoring, the 95th percentile is considered one of key value.  It is mentioned in this section, but may be useful to expand on a little as was done for median (and why 95th percentile is useful versus maximum).

7.3, section 2.  There was a placeholder for equilibrium.  Feel free to copy from the TCP framework draft if useful:

"the equilibrium throughput refers to the maximum sustained rate obtained by congestion avoidance before packet loss conditions occur (which may cause the state change from congestion avoidance to a retransmission
phase)."

"the equilibrium throughput reflects the maximum rate achieved by a TCP connection within the congestion avoidance phase on an end-end network path." 

7.4 last bullet.  We defined a couple of useful metrics that you may want to consider adding here (TCP Efficiency and Buffer Delay %) also in the TCP framework draft.

7.5 Variability, last two bullets. Plotting retransmissions and RTT during the course of a BTC are excellent ways to understand causes of variability.

I think this is a good work and I hope these comments are useful.

Thanks,

Barry

---

From: Al Morton <[email-masked]>
Date: Wed, 27 Oct 2010 17:13:03 -0400

At 03:37 PM 10/27/2010, Barry Constantine wrote:
>...

Thanks for your review, Barry, especially your comments in the
new section 7 (Restricted Capacity).  I'll reply with follow-up
on the list when time permits,

Al