Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

From: Brian Trammell <[email-masked]>
Date: Mon, 4 Aug 2014 06:51:14 +0200

hi Greg,

I've updated the posted minutes.

Thanks, best regards,

Brian

On 30 Jul 2014, at 02:22, Greg Mirsky <[email-masked]> wrote:

> Hi Brian,
> could you please update the minutes in part of discussion of rate-problem document. I believe the comments tagged 'Mike' were mine as well as proposal, after Al's Shakespearean quote, to modify the requirement to "protocol MUST support generating asymmetrical packet size. Protocol SHOULD support generating packets with asymmetrical size." "general agreement in the room" in my opinion very accurately captures the reaction to the proposal.
> 
> Regards,
> Greg
> 
> 
> On Wed, Jul 23, 2014 at 1:17 PM, Brian Trammell <[email-masked]> wrote:
> Greetings, all,
> 
> Draft minutes for yesterday's meeting are available at:
> 
> http://www.ietf.org/proceedings/90/minutes/minutes-90-ippm
> 
> Many thanks to Sarah Banks for taking minutes during the meeting.
> 
> If you have any comments or additions, please let us know at [email-masked].
> 
> Many thanks, best regards,
> 
> Brian
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 4 Aug 2014 15:27:52 -0400

In the minutes:

- Al Morton: all tools today send asymmetrical packets; if you don't want to
solve this problem, you can choose to ignore it.

s/asymmetrical/symmetrical/

missing from minutes, between Greg and Brian:

- Greg: How about MUST on rate, SHOULD on packet size?

(general agreement in the room)

- Al: then it's SHOULD for BOTH symmetrical and asymmetrical size

- Brian Trammell: there should be a statement of applicability on the SHOULD

Al

From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Monday, August 04, 2014 12:51 AM
To: Greg Mirsky
Cc: [email-masked]
Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

hi Greg,

Thanks, best regards,

Brian

On 30 Jul 2014, at 02:22, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Brian,

On Wed, Jul 23, 2014 at 1:17 PM, Brian Trammell <[email-masked]<mailto:[email-masked]>> wrote:
Greetings, all,

If you have any comments or additions, please let us know at [email-masked]<mailto:[email-masked]>.

Brian
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Brian Trammell <[email-masked]>
Date: Tue, 5 Aug 2014 01:38:14 +0200

hi Al, all,

> s/asymmetrical/symmetrical/

Okay, this makes more sense to me now.

> - Brian Trammell: there should be a statement of applicability on the SHOULD

Corrected; added.

Thanks, cheers,

Brian

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 5 Aug 2014 08:01:27 -0400

Steve, did you come down off the ceiling yet?
I was correcting a typo in the minutes...

Al

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, August 04, 2014 7:34 PM
To: MORTON, ALFRED C (AL); Brian Trammell; Greg Mirsky
Cc: [email-masked]
Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

>Al Morton: all tools today send asymmetrical packets;

This cannot be true!

Can you provide the list of tools you have in mind?

Are you confusing unidirectional BW measurements and bi-directional BW measurements?

What is wrong with measuring the forward rate and/or reverse rate of a bidirectional path using the same packet size say the path MTU?
And repeating the test if needed with different packet sizes?

What is wrong with measuring the forward rate of a unidirectional path using the same packet size say the path MTU?
And repeating the test if needed with different packet sizes?

-Steve

On 8/4/14, "MORTON, ALFRED C (AL)" <[email-masked]<mailto:[email-masked]>> wrote:
In the minutes:

Al

From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Monday, August 04, 2014 12:51 AM
To: Greg Mirsky
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

hi Greg,

Thanks, best regards,

Brian

Hi Brian,

Brian

---

From: Steve Baillargeon <[email-masked]>
Date: Tue, 5 Aug 2014 16:00:52 +0000

Al, On the contrary, both feet are stuck on the ground with actual PM work related to customer networks including the one on your badge!

I am still curious to know the answers to my previous questions.

I am also curious to find why asymmetrical packet size is so important.
Are you thinking about a TCP connection measuring the rate in a given direction with data segments of a given size and (short) ACK segments are travelling in the opposite direction?

-Steve

From: ippm [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: August-05-14 8:01 AM
To: [email-masked]; Brian Trammell; Greg Mirsky
Cc: [email-masked]
Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

Al

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

This cannot be true!

-Steve

Al

hi Greg,

Thanks, best regards,

Brian

Hi Brian,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Tue, 5 Aug 2014 18:12:30 +0200

hi Steve,

> Are you thinking about a TCP connection measuring the rate in a given direction with data segments of a given size and (short) ACK segments are travelling in the opposite direction?

<chair hat off>
<tcp measurement geek hat on>

Well, that's the simplest example of why asymmetric packet size testing seems useful to me, especially given that in most access networks with content-heavy applications, you have one direction that's pure-ACK-dominated and one direction that's 1500-minus-epsilon dominated. Different devices on the path will react differently to those streams, depending on their design. But I'd submit that IPPM is not the place to rehash the various byte-versus-packet arguments...

<chair hat on>

...and it looks to me (in the _corrected_ minutes, anyway) as if we have a workable solution to this dilemma.

Cheers,

Brian

> On 8/4/14, "MORTON, ALFRED C (AL)" <[email-masked]> wrote:
> In the minutes:
>

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 5 Aug 2014 09:29:00 -0700

Hi Brian, Al,
Brian wrote:
<chair hat on>

...and it looks to me (in the _corrected_ minutes, anyway) as if we have a
workable solution to this dilemma.

I believe that the change would be unnoticeable to an untrained eye. Would
it be possible to see the proposed sentence (don't think that more than
that needs change) before it gets buried in the document?

Regards,
Greg

On Tue, Aug 5, 2014 at 9:12 AM, Brian Trammell <[email-masked]> wrote:

> > Al, On the contrary, both feet are stuck on the ground with actual PM
> work related to customer networks including the one on your badge!
> >
> > Are you thinking about a TCP connection measuring the rate in a given
> direction with data segments of a given size and (short) ACK segments are
> travelling in the opposite direction?
>
> <chair hat off>
> Well, that's the simplest example of why asymmetric packet size testing
> seems useful to me, especially given that in most access networks with
> content-heavy applications, you have one direction that's
> pure-ACK-dominated and one direction that's 1500-minus-epsilon dominated.
> Different devices on the path will react differently to those streams,
> depending on their design. But I'd submit that IPPM is not the place to
> rehash the various byte-versus-packet arguments...
>
> <chair hat on>
>
> > What is wrong with measuring the forward rate and/or reverse rate of a
> bidirectional path using the same packet size say the path MTU?
> > What is wrong with measuring the forward rate of a unidirectional path
> using the same packet size say the path MTU?
> > could you please update the minutes in part of discussion of
> rate-problem document. I believe the comments tagged 'Mike' were mine as
> well as proposal, after Al's Shakespearean quote, to modify the requirement
> to "protocol MUST support generating asymmetrical packet size. Protocol
> SHOULD support generating packets with asymmetrical size." "general
> agreement in the room" in my opinion very accurately captures the reaction
> to the proposal.
> >
> > Regards,
> > Greg
> >
> >

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 5 Aug 2014 12:49:53 -0400

Greg,

New Requirement sentence(s):
The ability to control and generate asymmetric rates in a two-way architecture is REQUIRED.
The ability to control and generate symmetric and asymmetric packet sizes in a two-way architecture are both RECOMMENDED.

Al

From: Greg Mirsky [mailto:[email-masked]]
Sent: Tuesday, August 05, 2014 12:29 PM
To: Brian Trammell
Cc: Steve Baillargeon; MORTON, ALFRED C (AL); [email-masked]; [email-masked]
Subject: Re: [ippm] Draft IETF 90 IPPM WG meeting minutes posted to datatracker

Hi Brian, Al,
Brian wrote:
<chair hat on>

...and it looks to me (in the _corrected_ minutes, anyway) as if we have a workable solution to this dilemma.
I believe that the change would be unnoticeable to an untrained eye. Would it be possible to see the proposed sentence (don't think that more than that needs change) before it gets buried in the document?
Regards,
Greg

On Tue, Aug 5, 2014 at 9:12 AM, Brian Trammell <[email-masked]<mailto:[email-masked]>> wrote:
hi Steve,

<chair hat off>

<chair hat on>

Cheers,

Brian

> From: ippm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of MORTON, ALFRED C (AL)
> To: [email-masked]<mailto:[email-masked]>; Brian Trammell; Greg Mirsky
> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> From: ippm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Trammell