Subject: [ippm] R: Comments on draft-chen-ippm-coloring-based-ipfpm-framework-02.txt

From: Ionta Tiziano <[email-masked]>
Date: Tue, 5 Aug 2014 09:39:21 +0000

Hi all,
here are my comments:

(1) Abstract:
- the present document DOES NOT specify a passive measurement method, because the document specifying that particular passive measurement method (that is marking into different blocks of markers by changing one or more bits of packets) is the TEMPIA-OPSAWG-P3M (and IPR disclosures have been submitted years ago directly on the tempia-opsawg-p3m, thus this passive measurement method cannot be used in other drafts, unless previous authorization)
- My proposal is to change the content of the abstract writing the only real added value of the draft-chen-ippm-coloring-based-ipfpm-framework-02, that is:
a) the use of IPFIX for reporting the measurement data (obtained through any possible passive measurement method, including the colouring method introduced in tempia-opsawg-p3m) to a central calculation element for performance metrics calculation
b) the definition of a reference model

(2) Title: basing on what written above, the keyword "coloring-based" should be removed from the title

(3) Introduction: basing on what written above, the introduction should be changed consequently

(4) Content of the document: basing on what written above, the parts regarding the colouring passive measurement method should be removed, thus only mentioning a general passive measurement method, but not anymore the colouring passive measurement method already defined in the tempia-opsawg-p3m.

(4) par. 9: basing on what written above, this paragraph should be removed from the document. Furthermore, in my experience, the colouring through the marking of the last reserved bit of the Flag field of the IPv4 header is almost unfeasible, because the policy-map and class-map philosophy does not allow the check of this field. Consequently any other method for checking this field is too heavy for a (medium/large size) router.

Best
Tiziano Ionta (Telecom Italia)

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 5 Aug 2014 08:54:43 -0400

I have told the authors about overlap with draft-tempia and its IPR
several times, privately.  Now we have Tiziano's message
which clarifies the situation for all. 

Al

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of Ionta Tiziano
> Sent: Tuesday, August 05, 2014 5:39 AM
> To: [email-masked]'
> Subject: [ippm] R: Comments on draft-chen-ippm-coloring-based-ipfpm-
> framework-02.txt
> Importance: High
> 
> Hi all,
> here are my comments:
> 
> (1) Abstract:
> - the present document DOES NOT specify a passive measurement method,
> because the document specifying that particular passive measurement method
> (that is marking into different blocks of markers by changing one or more
> bits of packets) is the TEMPIA-OPSAWG-P3M (and IPR disclosures have been
> submitted years ago directly on the tempia-opsawg-p3m, thus this passive
> measurement method cannot be used in other drafts, unless previous
> authorization)
> - My proposal is to change the content of the abstract writing the only
> real added value of the draft-chen-ippm-coloring-based-ipfpm-framework-02,
> that is:
> a) the use of IPFIX for reporting the measurement data (obtained through
> any possible passive measurement method, including the colouring method
> introduced in tempia-opsawg-p3m) to a central calculation element for
> performance metrics calculation
> (4) Content of the document: basing on what written above, the parts
> regarding the colouring passive measurement method should be removed, thus
> only mentioning a general passive measurement method, but not anymore the
> colouring passive measurement method already defined in the tempia-opsawg-
> p3m.
> 
> (4) par. 9: basing on what written above, this paragraph should be removed
> from the document. Furthermore, in my experience, the colouring through
> the marking of the last reserved bit of the Flag field of the IPv4 header
> is almost unfeasible, because the policy-map and class-map philosophy does
> not allow the check of this field. Consequently any other method for
> checking this field is too heavy for a (medium/large size) router.
> 
> Best
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
> persone indicate. La diffusione, copia o qualsiasi altra azione derivante
> dalla conoscenza di queste informazioni sono rigorosamente vietate.
> Qualora abbiate ricevuto questo documento per errore siete cortesemente
> pregati di darne immediata comunicazione al mittente e di provvedere alla
> sua distruzione, Grazie.
> 
> This e-mail and any attachments is confidential and may contain privileged
> information intended for the addressee(s) only. Dissemination, copying,
> printing or use by anybody else is unauthorised. If you are not the
> intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks.
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm