Subject: [ippm] Comments on draft-elkins-ippm-pdm-option-03

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 17 Mar 2015 10:40:58 -0400

Hi Nalini, Robert, and Mike,

I've read your draft again while waiting for a plane.
There are some great improvements again this time,
and I offer the comments below along with my support.

regards,
Al

Notes on PDM-03

End of 1.2:
...The critical nature of such activities to our daily lives and financial well-being demand    a solution.
suggest:
The critical nature of such activities to our daily lives and financial well-being demand a simple solution to support measurements.

In 1.3:
Then, the diagnostic data corresponding to each packet at different observation points must be matched for proper measurements.
suggest:
Then (in post-collection processing), the diagnostic data corresponding to each packet    at different observation points must be matched for proper measurements.

End of 1.3:
The packet sequence number needs to be unique in the context of the session (5-tuple).
suggest (define 5-tuple):
The packet sequence number needs to be unique in the context of the session (5-tuple of Src/Dst addresses, ports, and protocol number).
(I see you did this later in section 2, you could reference that section.)

In Sec 2:
The PDM contains the following metrics:
suggest: *some* of these are "labels" or "fields", but not metrics.
(and, some are metrics, calculated after the fields have been determined)

in Sec 2.1:
Round-trip delay is the end-to-end delay for a packet from a source host to a destination host.
suggest (you've only described a one-way path, that's not enough)
Round-trip *Network* delay is the delay for packet transfer from a source host to a destination host and then back to the source host.

in section 3.2, 1st par says:
That is, for a value of 00 in the Time Base field, a value of 1 in the DELTA fields indicates 1 picosecond.
But then the list below says:
The possible values of Time Base are as follows: 
 00 - milliseconds 01 - microseconds 10 - nanoseconds 11 - picoseconds
>>> the values in the example and the list don't seem to match 00 /= 11

more in 3.2
Delta Last Received (DELTALR)
This is delta in time - seems appropriate to mention that in the name, DELTATLR
?

and:
DELTALR = Send time packet 2 - Receive time packet 1
Suggest to write this more generally, since loss affects the calculation

DELTALR = Send time packet N - Receive time packet (most recent seq num, <N)

Section 5, step 4:
... So, now, Host A can calculate total end-to-end time. That is:

suggest (Isn't this the Overall RT Time?

So, now, Host A can calculate total Overall Round-trip time (which includes Network RTT and Host Response Time). That is:

More in Step 4:
Round trip delay = DELTALS - DELTALR

(There seems to be an assumption here - one-packet request and response?
Need to look at the pictures describing the exchange, and see what happens
when host B generates multiple packets...)

Section 6.2
Assume that two packets are sent with each send from the server.
Suggest:
Assume that two packets are sent for each ACK from the server.

more in 6.2: Packet 3 in the table has
3 Client 1 1 20 0
or "1" for PSN Last Received
>>> Since Packet 2 has arrived, why isn't PSNLR=2?

Section 7
The calculations assume some minimum rate for links?
Or, What is BPM? (something is missing)

Section 8
Can probably reference the security section of [ELK-PDM]
(assuming there is one there).

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 17 Mar 2015 18:14:06 +0000 (UTC)

Thanks so much, Al.
We will review your comments and revise the draft.
Let's talk about these in the IPPM meeting.   We are on the agenda as the final slot.

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: "MORTON, ALFRED C (AL)" <[email-masked]>
 To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
 Sent: Tuesday, March 17, 2015 7:40 AM
 Subject: Comments on draft-elkins-ippm-pdm-option-03

regards,
Al

Notes on PDM-03

End of 1.2:

In 1.3:

End of 1.3:

In Sec 2:

in Sec 2.1:

more in 3.2

and:

Section 5, step 4:

More in Step 4:

Section 6.2

Section 7

Section 8