Subject: [ippm] review of draft-ietf-ippm-metric-registry-02

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 23 Mar 2015 23:49:11 +0000

I just did a fairly quick read-through of the draft, and had the following comments:

1. Non-IANA registries:
The document is very specific about only applying to IETF-defined performance metrics, and the defined format is said to be only for the IANA registry. It was my hope that the registry format ippm defined could be used by ITU-T, BBF, and others to create registries of the performance metrics they define. The lmap information-model is supposed to be useful for performance metrics existing in any registry; so if this is an IETF-metric-only format, that would mean we would need information-model changes to support other registry formats, and work would need to be done (somewhere) to define other performance metric registry formats. I see nothing in the registry format defined in this draft that would not be applicable to any and all performance metrics, and see no reason why it needs to be restricted to "IETF-only performance metrics" and "IANA-registry-only". If ippm agrees that one purpose of this draft is to define a registry format, usable by any and all registries, I would be happy to provide a complete set of proposed edits to the draft to express this.

2. Lists: 
A number of the registry format elements seem to be lists. I suggest that specific delimiters be identified for all such lists (e.g., comma delimited). This includes the following: Reference Definition, Fixed Parameters, Stream Parameters

3. Reference Definition:
A more explicit format for the Reference Definition would be good. For IETF performance metrics, there is no reason this can't be a url. Which would be great.

4. Fixed/Stream Parameters:
The syntax for expressing a fixed or stream parameter name and its value (and value units) needs to be specified. 

5. Examples:
There need to be a few examples provided of performance metric registry entries. Sort of like a requirement for running code for a protocol. We need workable registry entries to prove that the format defined in this draft is complete and sufficiently specific.

6. Active/Passive:
I don't see that these terms are needed by the registry format or are useful. This includes the requirements that metric names have an indicative prefix.

Again, I'm happy to provide specific text recommendations for any or all of my comments, if the WG agrees that these changes should be made.
Barbara

---

From: <[email-masked]>
Date: Tue, 24 Mar 2015 16:57:56 +0000

Barbara,
Thanks!

Just a follow up on point 1.

As far as I can see from the IANA registry about URNs http://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml#urn-namespaces-1 there are some organisations like 3gpp which have devolved responsibility for registering URNs (Namespace Specific String urn:3gpp:{3gpp-urn}
But broadband forum and itu-t aren't such bodies at the moment. I may well be reading this wrong - we should check with iana.

On the substantive point, I think you're right that we need to allow other bodies to have responsibility for a Namespace Specific String - appointing their own expert review.
I'm not sure how much re-writing this needs - may be better to have a short, separate document?

phil

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
> Sent: 23 March 2015 23:49
> To: [email-masked]
> Subject: [ippm] review of draft-ietf-ippm-metric-registry-02
> 
> The document is very specific about only applying to IETF-defined
> performance metrics, and the defined format is said to be only for the
> IANA registry. It was my hope that the registry format ippm defined
> could be used by ITU-T, BBF, and others to create registries of the
> performance metrics they define. The lmap information-model is supposed
> to be useful for performance metrics existing in any registry; so if
> this is an IETF-metric-only format, that would mean we would need
> information-model changes to support other registry formats, and work
> would need to be done (somewhere) to define other performance metric
> registry formats. I see nothing in the registry format defined in this
> draft that would not be applicable to any and all performance metrics,
> and see no reason why it needs to be restricted to "IETF-only
> performance metrics" and "IANA-registry-only". If ippm agrees that one
> purpose of this draft is to define a registry format, usable by any and
> all registries, I would be happy
>   to provide a complete set of proposed edits to the draft to express
> this.
> 
> 2. Lists:
> A number of the registry format elements seem to be lists. I suggest
> that specific delimiters be identified for all such lists (e.g., comma
> delimited). This includes the following: Reference Definition, Fixed
> Parameters, Stream Parameters
> 
> 3. Reference Definition:
> A more explicit format for the Reference Definition would be good. For
> IETF performance metrics, there is no reason this can't be a url. Which
> would be great.
> 
> The syntax for expressing a fixed or stream parameter name and its
> value (and value units) needs to be specified.
> 
> 5. Examples:
> There need to be a few examples provided of performance metric registry
> entries. Sort of like a requirement for running code for a protocol. We
> need workable registry entries to prove that the format defined in this
> draft is complete and sufficiently specific.
> 
> 6. Active/Passive:
> I don't see that these terms are needed by the registry format or are
> useful. This includes the requirements that metric names have an
> indicative prefix.
> 
> Again, I'm happy to provide specific text recommendations for any or
> all of my comments, if the WG agrees that these changes should be made.
> Barbara
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 24 Mar 2015 15:26:17 -0400

Hi Barbara,

Thanks for your comments, a couple of replies in addition to Phil's below,

Al/ACM
________________________________________
From: ippm [[email-masked]] On Behalf Of STARK, BARBARA H
Sent: Monday, March 23, 2015 7:49 PM
To: [email-masked]
Subject: [ippm] review of draft-ietf-ippm-metric-registry-02

*** 

2. Lists:

ACM: Interesting point, The current proposed entries in https://tools.ietf.org/html/draft-mornuley-ippm-initial-registry-01
are clear I think, at least to human readers, but the form of entries *could* be further specified -- if necessary 

3. Reference Definition:

ACM: There are cases where a URL to an RFC and section number alone will suffice, but in other cases
the entry will require more than one reference and descriptive text. see
https://tools.ietf.org/html/draft-mornuley-ippm-initial-registry-01

ACM: We've currently implemented this as a hierarchical list in
https://tools.ietf.org/html/draft-mornuley-ippm-initial-registry-01
and we could specify this form of syntax if it works for you.

5. Examples:

ACM:  we have a set of examples, composed as the initial registry entries, and one purpose of preparing
these entries was to examine the practicality and suffciency of the registry design.
see
https://tools.ietf.org/html/draft-mornuley-ippm-initial-registry-01

6. Active/Passive:

ACM: it may be possible to remove the definitions here, if they can be agreed elsewhere.
for example:
https://tools.ietf.org/html/draft-morton-ippm-active-passive-01

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 25 Mar 2015 12:58:07 +0000

> As far as I can see from the IANA registry about URNs
> http://www.iana.org/assignments/urn-namespaces/urn-
> namespaces.xhtml#urn-namespaces-1 there are some organisations like
> 3gpp which have devolved responsibility for registering URNs (Namespace
> Specific String urn:3gpp:{3gpp-urn} But broadband forum and itu-t aren't
> such bodies at the moment. I may well be reading this wrong - we should
> check with iana.

I'm not clear on why any non-IANA registry needs to use formal (or informal) IANA URN namespace. For its XML namespace, BBF uses "urn:broadband-forum-org:  ". BBF manages this namespace quite well. I would expect it to be able to easily manage a registry within this namespace. The location of the BBF resources on the Internet is very easy. 

I don't really think IETF needs to concern itself with BBF and ITU-T (and other org) namespace.
Barbara