Subject: Re: [ippm] Suggestions about draft "ippm-active-passive"

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 2 Mar 2015 17:42:12 +0000

> Al  

Good work on this draft.   Thanks for taking the initiative and compiling such
great information and conclusions.

In particular defining Hybrid (which everyone has expressly avoided 
doing to date) and then providing examples of where solutions like PDM 
and Coloring should be categorized.
 
I like what you have come up with and the rationale provided is very convincing and
to me, hard to dispute.      Will it be possible to get this discussion on the 
Agenda in Dallas,  so that we may actively discuss these concepts and perhaps solidify these 
definitions and categorizations?

Great Progress and thanks again for your efforts!

Mike

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of MORTON, ALFRED 
> C
> (AL)
> Sent: Thursday, February 26, 2015 11:56 AM
> To: [email-masked]
> Subject: [ippm] FW: Suggestions about draft "ippm-active-passive"
> Importance: High
> 
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> The latest draft is here:
> http://tools.ietf.org/html/draft-morton-ippm-active-passive-01.txt
> 
> This version benefits from Tizano's comments (see exchange below), and 
> very recent comments from Nalini and her colleague Bill.
> 
> regards,
> Al
> 

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 2 Mar 2015 12:55:13 -0500

Thanks Mike, the draft is on the agenda,
and we'll have the discussion.

Al

> From: Ackermann, Michael [mailto:[email-masked]]
> Sent: Monday, March 02, 2015 12:42 PM
> To: MORTON, ALFRED C (AL)
> Cc: [email-masked]; [email-masked]; draft-ietf-ippm-rate-
> [email-masked]
> Subject: RE: Suggestions about draft "ippm-active-passive"
> 
> > Al
> 
> The information contained in this communication is highly confidential and
> is intended solely for the use of the individual(s) to whom this
> communication is directed. If you are not the intended recipient, you are
> hereby notified that any viewing, copying, disclosure or distribution of
> this information is prohibited. Please notify the sender, by electronic
> mail or telephone, of any unintended receipt and delete the original
> message without making any copies.
> 
>  Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are
> nonprofit corporations and independent licensees of the Blue Cross and
> Blue Shield Association.

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 2 Mar 2015 17:42:12 +0000

Mike

---

From: <[email-masked]>
Date: Tue, 24 Mar 2015 11:01:10 +0000

Al, 
Thanks for the draft. It reads well. I think it can be useful for the registry work (& lmap) - to clarify terms. I'm not sure if it's on the agenda to make it a wg draft - I'd support this if it is.

Some comments:
The 2 dimensional nature of the picture is not easy to understand. The 3 * with Active... are fine, it's the other 2 * (PDM & Passive) that I found difficult. I don't have any great suggestions how to improve it, sorry.

A couple of methods, not sure where they should be placed on passive /active /hybrid:-

1. method where a mobile device observes its location and then triggers sending test traffic (say a speed test) in a particular location. (the 802.11 liaison to lmap hints at something like this.) Think I'd say this was 2 separate methods - passive followed by active.

2. a method where you observe an existing stream of (say) user traffic, whilst adding a separate loading stream. I'd say this was a hybrid method. It's almost addressed by the current text (bullet 1 in S3.4) but not quite (I think). Suggest adding text something like "generating packet stream with the purpose of affecting the stream being measured"? ('with the purpose' - because don't want the definition to include reporting traffic, which can potentially affect the stream being measured)

Best wishes
phil

> From: ippm [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
> (AL)
> Sent: 02 March 2015 17:55
> To: Ackermann, Michael
> Cc: [email-masked]; [email-masked]
> Subject: Re: [ippm] Suggestions about draft "ippm-active-passive"
> 
> Thanks Mike, the draft is on the agenda, and we'll have the discussion.
> 
> Al
> 
> > Good work on this draft.   Thanks for taking the initiative and
> compiling
> > such
> > to me, hard to dispute.      Will it be possible to get this
> discussion on
> > the
> > Agenda in Dallas,  so that we may actively discuss these concepts and
> > perhaps solidify these definitions and categorizations?
> >
> > > From: ippm [mailto:[email-masked]] On Behalf Of MORTON,
> > > ALFRED C
> > > (AL)
> > > This version benefits from Tizano's comments (see exchange below),
> > > and very recent comments from Nalini and her colleague Bill.
> > >
> > > regards,
> > > Al
> > >
> >
> >
> > The information contained in this communication is highly
> confidential
> > and is intended solely for the use of the individual(s) to whom this
> > communication is directed. If you are not the intended recipient, you
> > are hereby notified that any viewing, copying, disclosure or
> > distribution of this information is prohibited. Please notify the
> > sender, by electronic mail or telephone, of any unintended receipt
> and
> > delete the original message without making any copies.
> >
> >  Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan
> > are nonprofit corporations and independent licensees of the Blue
> Cross
> > and Blue Shield Association.
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 24 Mar 2015 15:36:21 -0400

Hi Phil,

Thanks for your comments and support for this draft.

I agree that "effect of stream on network conditions" is quite a braod category,
and Tiziano made the comment previously that this could be further categorized.
In short, I proposed three more narrow categories, but I don't think an N-dimensional
graph will help the visulaization. I planned to offer a different graphical approach
in the slides during the session, and we'll see where that goes.

I'm interested in your new examples (below) and will examine their categorization and
representation along with the other next steps.

regards, 
Al
________________________________________
From: [email-masked] [[email-masked]]
Sent: Tuesday, March 24, 2015 7:01 AM
To: MORTON, ALFRED C (AL); [email-masked]
Cc: [email-masked]
Subject: RE: Suggestions about draft "ippm-active-passive"

Al,

Some comments:

Best wishes
phil