Subject: [ippm] shepherd comments for draft-ietf-ippm-port-twamp-test-01

From: Tianran Zhou <[email-masked]>
Date: Fri, 17 Aug 2018 09:56:39 +0000

Hi Authors and All,

As the document shepherd of draft-ietf-ippm-port-twamp-test, I have reviewed this document and have these comments.
1. Section 4,
"Since the consensus of many dictionary definitions of
"consist" is "composed or made up of","
I do not think these words are necessary. 

2. Section 4, about the "TWAMP Light", you describes the discussions from Lars and Tim. I am not sure if it's necessary to introduce the discussions. Or just describe what is the "TWAMP Light" and the result. 

3. Section 4, "Since the idea of TWAMP Light clearly includes...."
This paragraph seems to introduce why an well know udp port is necessary. I am not sure if this should be appeared in this "definition" section. 

4. Section 5, "It may simplify some operations to have a well-known
port available for the Test protocols, or for future
specifications involving TWAMP-Test to use this port as a default
port."

This is the reason for a well-known port for the test session. I think this is should be more clear and reasonably. But here seem vague.

Cheers,
Tianran

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 17 Aug 2018 23:36:15 +0000

Hi Tianran,

Thanks for your shepherd's review.

The rationale behind the excruciatingly clear statements 
in this document is important to the working group.
There are many messages in the archive discussing
the TWAMP details that the working group has finally 
agreed-on now:
https://mailarchive.ietf.org/arch/msg/ippm/PIPFXw6RCyxjNFninffREkPFLW0

The main reason to include all the details you have
questioned below is to avoid the same or similar questions
from stalling working group progress in the future,
and to clearly describe why things are as they are now. 
In other words, there are two parts of this memo, described
in the first sentence of the Abstract:

   This memo explains the motivation and describes the re-assignment of
   well-known ports for the OWAMP and TWAMP protocols for control and
   measurement, and clarifies the meaning and composition of these
   standards track protocol names for the industry.

The IPPM working group has reached consensus on this draft.
The consensus call was made by Brian during the IPPM session in
Montreal. Once Consensus was reached, there was a call for a 
volunteer for document shepherd. You have kindly agreed to fulfill
that role, which is mostly:

	(For those who have not done so before, the primary role of the document 
	shepherd is to review discussion on the draft and fill out a 
	document shepherd write-up to summarize the WG's process for submission 
	to the IESG.  This document is a relatively simple one and had a 
	not-very-complicated process, so this would be a good first document 
	for a new shepherd, if someone would like to try it out. :)

I see that you have already filled-out the document shepherd's form:
https://datatracker.ietf.org/doc/draft-ietf-ippm-port-twamp-test/shepherdwriteup/
where you said:

	>(9) How solid is the WG consensus behind this document? Does it 
	>represent the strong concurrence of a few individuals, with others
	>being silent, or does the WG as a whole understand and agree with it?   

	I am not familiar with the discussion about this document. 
	Frankly, except the co-author, I did not see any other support 
	during the LC in the list based on the search.

If your search only used the current document file name, then it did not 
find discussions from 2017 which I cited above, or the IETF-99 discussion
where the WG agreed that two related drafts would be combined to cement the 
agreements on this topic. After that agreement was reached and a combined
draft was published, the path to consensus was smooth and without controversy,
in my opinion.

hope this helps,
Al

> -----Original Message-----
> From: Tianran Zhou [mailto:[email-masked]]
> Sent: Friday, August 17, 2018 5:57 AM
> To: [email-masked]; [email-masked]
> Subject: shepherd comments for draft-ietf-ippm-port-twamp-test-01
> 
> Hi Authors and All,
> 
> As the document shepherd of draft-ietf-ippm-port-twamp-test, I have
> reviewed this document and have these comments.
> 1. Section 4,
> 2. Section 4, about the "TWAMP Light", you describes the discussions from
> Lars and Tim. I am not sure if it's necessary to introduce the
> discussions. Or just describe what is the "TWAMP Light" and the result.
> 
> This paragraph seems to introduce why an well know udp port is necessary.
> I am not sure if this should be appeared in this "definition" section.
> 
> This is the reason for a well-known port for the test session. I think
> this is should be more clear and reasonably. But here seem vague.
> 
> 
> Cheers,
> Tianran

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 20 Aug 2018 01:17:35 +0000

Hi Al,

Thanks for your clear pointer and the history description. I will search more related discussions and I would like to update the shepherd document.
The comments are based on my personal review of this document. If the working group already had consensus, I am OK. :-) 

Cheers,
Tianran

> From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
> Sent: Saturday, August 18, 2018 7:36 AM
> To: Tianran Zhou <[email-masked]>; [email-masked];
> [email-masked]
> Subject: RE: shepherd comments for draft-ietf-ippm-port-twamp-test-01
> 
> Hi Tianran,
> 
> The rationale behind the excruciatingly clear statements in this document
> is important to the working group.
> There are many messages in the archive discussing the TWAMP details that the
> working group has finally agreed-on now:
> The main reason to include all the details you have questioned below is to
> avoid the same or similar questions from stalling working group progress in
> the future, and to clearly describe why things are as they are now.
> In other words, there are two parts of this memo, described in the first
> sentence of the Abstract:
> 
> The consensus call was made by Brian during the IPPM session in Montreal.
> Once Consensus was reached, there was a call for a volunteer for document
> shepherd. You have kindly agreed to fulfill that role, which is mostly:
> 
> If your search only used the current document file name, then it did not find
> discussions from 2017 which I cited above, or the IETF-99 discussion where
> the WG agreed that two related drafts would be combined to cement the
> > "Since the consensus of many dictionary definitions of "consist" is
> > "composed or made up of","
> > 2. Section 4, about the "TWAMP Light", you describes the discussions
> > from Lars and Tim. I am not sure if it's necessary to introduce the
> > port available for the Test protocols, or for future specifications
> > involving TWAMP-Test to use this port as a default port."
> >