Subject: [ippm] Hop Count in IOAM Direct Exporting

From: Tal Mizrahi <[email-masked]>
Date: Mon, 11 May 2020 08:49:30 +0300

Hi,

This issue has been raised a number of times, but we have not been
able to get a clear answer from the working group so far, and this is
the major remaining issue in draft-ietf-ippm-ioam-direct-export.
https://tools.ietf.org/html/draft-ioamteam-ippm-ioam-direct-export-00

The issue is whether to add an explicit Hop Count field to the Direct
Exporting header, or to rely on the existing Hop_Lim data field which
has already been defined in draft-ietf-ippm-ioam-data.

We would like to solicit comments from the WG and a clear opinion
about whether you support option 1 or option 2:
Option 1: use an explicit Hop Count field.
Option 2: use the existing Hop_Lim data field.

Thanks,
Tal.

The pros / cons of each option is presented in Section 7 of
draft-ioamteam-ippm-ioam-direct-export-00 as follows:

   o  Hop Limit / Hop Count: in order to help correlate and order the
      exported packets, it is possible to include a 1-octet Hop Count
      field in the DEX header (presumably by claiming some space from
      the Flags field).  Its value starts from 0 at the encapsulating
      node and is incremented by each IOAM transit node that supports
      the DEX option.  The Hop Count field value is also included in the
      exported packet.  An alternative approach is to use the Hop_Lim/
      Node_ID data field; if the IOAM-Trace-Type
      [I-D.ietf-ippm-ioam-data] has the Hop_Lim/Node_ID bit set, then
      exported packets include the Hop_Lim/Node_ID data field, which
      contains the TTL/Hop Limit value from a lower layer protocol.  The
      main advantage of the Hop_Lim/Node_ID approach is that it provides
      information about the current hop count without requiring each
      transit node to modify the DEX option, thus simplifying the data
      plane functionality of Direct Exporting.  The main advantage of
      the Hop Count approach is that it counts the number of IOAM-
      capable nodes without relying on the lower layer TTL, especially
      when the lower layer cannot prvide the accurate TTL information,
      e.g., Layer 2 Ethernet or hierarchical VPN.  It also explicitly
      allows to detect a case where an IOAM-capable node fails to export
      packets to the collector.  In order to facilitate the Hop Count
      approach it is possible to use a flag to indicate an optional Hop
      Count field, which enables to control the tradeoff.  On one hand
      it addresses the use cases that the Hop_Lim/Node_ID cannot cover,
      and on the other hand it does not require transit switches to
      update the option if it is not supported or disabled.  Further
      discussion is required about the tradeoff between the two
      alternatives.

---

From: Haoyu Song <[email-masked]>
Date: Mon, 11 May 2020 18:17:59 +0000

Hi WG,

"Hop Count" or the equivalent information is important to help correlate the export data and ensure the completeness of the export data.  	

Modifying the IOAM DEX option header (by incrementing the hop count) seems undesirable, but this is just a simple operation, and it's faster than trying to retrieve information from elsewhere. 

The alternative approach of using TTL is unreliable for the following reasons.
1. Depending on the application scenario, the TTL may not be available or be hard to retrieve. (e.g., Layer 2, tunnel, etc.)
2. TTL, if exists, is updated per hop. The "hop count" is updated per IOAM DEX-enabled nodes. These two numbers are not equivalent. E.g., 
if TTL is used, two DEX export packets from different nodes reports two TTL numbers 7 and 4, one will have no clue if this is because one or more
export packets are dropped, or some IOAM-DEX enabled nodes don't respond, or some nodes on the path are not IOAM-DEX enabled.  

If we can address the above issues, then the explicit "hop count" is not needed. 

Best regards,
Haoyu

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Sunday, May 10, 2020 10:50 PM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Hop Count in IOAM Direct Exporting

Hi,

This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C59cddc7f25c14c51d39b08d7f56f4ce3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637247730711329608&amp;sdata=ptNRYLflJtmTvx5G16yLSxTG2IHFG%2FCoMaPKcN3GViU%3D&amp;reserved=0

The issue is whether to add an explicit Hop Count field to the Direct Exporting header, or to rely on the existing Hop_Lim data field which has already been defined in draft-ietf-ippm-ioam-data.

We would like to solicit comments from the WG and a clear opinion about whether you support option 1 or option 2:
Option 1: use an explicit Hop Count field.
Option 2: use the existing Hop_Lim data field.

Thanks,
Tal.

_______________________________________________
ippm mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C59cddc7f25c14c51d39b08d7f56f4ce3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637247730711329608&amp;sdata=qHRMJtgDAFuzoDes7x%2BXzIot3naFmty2LiznAL4JcA8%3D&amp;reserved=0

---

From: "Ramesh Sivakolundu (sramesh)" <[email-masked]>
Date: Mon, 11 May 2020 18:28:35 +0000

Isn't this an issue that should be discussed in the context of export data format. IOAM-DEX draft doesn't talk about export data format.

Are there other ways to achieve the same correlation of export data? Node_ID and sequence number in the export data could achieve the same goal.

Am I missing something?

Thanks

-Ramesh

On 5/11/20, 11:18 AM, "ippm on behalf of Haoyu Song" <[email-masked] on behalf of [email-masked]> wrote:

    Hi WG,

    Best regards,
    Haoyu

    -----Original Message-----
    From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
    Sent: Sunday, May 10, 2020 10:50 PM
    To: IETF IPPM WG <[email-masked]>
    Subject: [ippm] Hop Count in IOAM Direct Exporting

    Hi,

    Thanks,
    Tal.

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ippm

---

From: Barak Gafni <[email-masked]>
Date: Mon, 11 May 2020 18:51:31 +0000

My opinion is that we design DEX as an extension to the data specification. Since we took the decision in the data specification to utilize the lower layer to fill in Hop_Lim and poteitnailly use it to track progress in the network, we shall follow that.
Assuming agreement on that: DEX can provide this capability by design. Following Ramesh' comment - per decision on what to export from each node.
Hence, I don't see a reason to add it to the header of DEX itself, and suggest to keep it out.

In addition, DEX is designed to enable simpler processing for the nodes in the network, where headers modification is not required. 

Thanks,
Barak

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Ramesh Sivakolundu (sramesh)
Sent: Monday, May 11, 2020 11:29 AM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Am I missing something?

Thanks

-Ramesh

    Hi WG,

    Best regards,
    Haoyu

    -----Original Message-----
    From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
    Sent: Sunday, May 10, 2020 10:50 PM
    To: IETF IPPM WG <[email-masked]>
    Subject: [ippm] Hop Count in IOAM Direct Exporting

    Hi,

    This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
    https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C36fd32f1d699441d56f308d7f5d92625%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637248185315420621&amp;sdata=m2FOMyIniYfNXJKtIL6%2FgGXr9fhidMHkafVrmJsPcnY%3D&amp;reserved=0

    Thanks,
    Tal.

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C36fd32f1d699441d56f308d7f5d92625%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637248185315420621&amp;sdata=x%2BTn%2BuKFp9hOEfblyrhVZdEzLiHp7oU6AlXSzv7ZMBk%3D&amp;reserved=0

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C36fd32f1d699441d56f308d7f5d92625%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637248185315420621&amp;sdata=x%2BTn%2BuKFp9hOEfblyrhVZdEzLiHp7oU6AlXSzv7ZMBk%3D&amp;reserved=0

_______________________________________________
ippm mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mellanox.com%7C36fd32f1d699441d56f308d7f5d92625%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C637248185315420621&amp;sdata=x%2BTn%2BuKFp9hOEfblyrhVZdEzLiHp7oU6AlXSzv7ZMBk%3D&amp;reserved=0

---

From: Haoyu Song <[email-masked]>
Date: Mon, 11 May 2020 19:09:56 +0000

Hi Ramesh,

The export data should contain enough information to correlate the data: which flow, which packet, and the order of the data.
The sequence number is used to correlated the set of export packets, but it can't tell the order of them and tell if any export packet is missing. 

If we assume the network topology is known, Node_ID is sufficient. Otherwise, Node_ID + sequence number can't help you to order the export packets and detect any missing data. 

Best,
Haoyu

-----Original Message-----
From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
Sent: Monday, May 11, 2020 11:29 AM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Am I missing something?

Thanks

-Ramesh

    Hi WG,

    Best regards,
    Haoyu

    -----Original Message-----
    From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
    Sent: Sunday, May 10, 2020 10:50 PM
    To: IETF IPPM WG <[email-masked]>
    Subject: [ippm] Hop Count in IOAM Direct Exporting

    Hi,

    This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf2fa240204d34723da2708d7f5d91fff%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248185213759306&amp;sdata=xTrih01oUKJtyHSVIEjTgbgazqzePpV8mixVja6z03A%3D&amp;reserved=0

    Thanks,
    Tal.

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf2fa240204d34723da2708d7f5d91fff%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248185213759306&amp;sdata=2WmcF39%2BM%2BQRmxVF0hXXFiqcAUHNLxsdZqa7Zm%2F7n1Q%3D&amp;reserved=0

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf2fa240204d34723da2708d7f5d91fff%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248185213759306&amp;sdata=2WmcF39%2BM%2BQRmxVF0hXXFiqcAUHNLxsdZqa7Zm%2F7n1Q%3D&amp;reserved=0

---

From: Haoyu Song <[email-masked]>
Date: Mon, 11 May 2020 19:21:17 +0000

Hi Barak,

I fully understand the history of this. Please review the issues I raised in my previous email and suggest ways to address them.

IOAM can define any data type but it's okay that the data plane device doesn't have it or cannot supply it. 
If a piece information is needed no matter what, one needs to provide a reliable way to supply it.

So a productive feedback should :
1) either prove that such info is not needed at all.
2) or such info can be readily acquired elsewhere.  

Best regards,
Haoyu

-----Original Message-----
From: Barak Gafni <[email-masked]> 
Sent: Monday, May 11, 2020 11:52 AM
To: Ramesh Sivakolundu (sramesh) <sramesh=[email-masked]>; Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: RE: [ippm] Hop Count in IOAM Direct Exporting

Thanks,
Barak

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Ramesh Sivakolundu (sramesh)
Sent: Monday, May 11, 2020 11:29 AM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Am I missing something?

Thanks

-Ramesh

    Hi WG,

    Best regards,
    Haoyu

    -----Original Message-----
    From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
    Sent: Sunday, May 10, 2020 10:50 PM
    To: IETF IPPM WG <[email-masked]>
    Subject: [ippm] Hop Count in IOAM Direct Exporting

    Hi,

    This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C2d96ee546e154d278f3e08d7f5dc5f11%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248199154794283&amp;sdata=DNtPhDsp1MNRxlMfptkFWQXb6wSN0xaC2rvvPdjwn1Y%3D&amp;reserved=0

    Thanks,
    Tal.

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C2d96ee546e154d278f3e08d7f5dc5f11%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248199154794283&amp;sdata=KbKxS%2BBXp5SDJ8RoGXzeyD%2F71anT7%2BTggcXqGOsbVwI%3D&amp;reserved=0

    _______________________________________________
    ippm mailing list
    [email-masked]
    https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C2d96ee546e154d278f3e08d7f5dc5f11%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248199154794283&amp;sdata=KbKxS%2BBXp5SDJ8RoGXzeyD%2F71anT7%2BTggcXqGOsbVwI%3D&amp;reserved=0

_______________________________________________
ippm mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C2d96ee546e154d278f3e08d7f5dc5f11%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248199154794283&amp;sdata=KbKxS%2BBXp5SDJ8RoGXzeyD%2F71anT7%2BTggcXqGOsbVwI%3D&amp;reserved=0

---

From: Mickey Spiegel <[email-masked]>
Date: Mon, 11 May 2020 12:57:06 -0700

Haoyu,

You are trying to position this as anything providing any amount of
incremental value is worth it. I don't agree with that. This is a judgement
call, balancing the pros and cons before coming up with a final decision.

While the Hop Count that you are proposing does have value in some corner
cases and complex deployment scenarios, it does not add value in the
majority of common cases and deployment scenarios. In an L3 network where
every node supports IOAM there is no benefit. When the topology is known
there is no benefit. Moreover, there is a clear cost, making transit
devices modify the header when it would otherwise be unnecessary.

I prefer option 2, using the existing Hop_Lim data field.

Mickey

On Mon, May 11, 2020 at 11:18 AM Haoyu Song <[email-masked]>
wrote:

> Hi WG,
>
> "Hop Count" or the equivalent information is important to help correlate
> the export data and ensure the completeness of the export data.
>
> Modifying the IOAM DEX option header (by incrementing the hop count) seems
> undesirable, but this is just a simple operation, and it's faster than
> trying to retrieve information from elsewhere.
>
> 1. Depending on the application scenario, the TTL may not be available or
> be hard to retrieve. (e.g., Layer 2, tunnel, etc.)
> 2. TTL, if exists, is updated per hop. The "hop count" is updated per IOAM
> DEX-enabled nodes. These two numbers are not equivalent. E.g.,
> if TTL is used, two DEX export packets from different nodes reports two
> TTL numbers 7 and 4, one will have no clue if this is because one or more
> export packets are dropped, or some IOAM-DEX enabled nodes don't respond,
> or some nodes on the path are not IOAM-DEX enabled.
>
> This issue has been raised a number of times, but we have not been able to
> get a clear answer from the working group so far, and this is the major
> remaining issue in draft-ietf-ippm-ioam-direct-export.
>
> Exporting header, or to rely on the existing Hop_Lim data field which has
> already been defined in draft-ietf-ippm-ioam-data.
>
> We would like to solicit comments from the WG and a clear opinion about
> whether you support option 1 or option 2:

---

From: Haoyu Song <[email-masked]>
Date: Mon, 11 May 2020 20:06:37 +0000

Mickey,

If it’s okay to ignore all the potential corner cases, then we can live with it. But are we sure about that?

As a tradeoff,  I think we can also just leave the hop count field there, but let implementor to decide if they want to update it or not.
This is like to make it optional too.

Best,
Haoyu

From: Mickey Spiegel <[email-masked]>
Sent: Monday, May 11, 2020 12:57 PM
To: Haoyu Song <[email-masked]>
Cc: Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Haoyu,

You are trying to position this as anything providing any amount of incremental value is worth it. I don't agree with that. This is a judgement call, balancing the pros and cons before coming up with a final decision.

While the Hop Count that you are proposing does have value in some corner cases and complex deployment scenarios, it does not add value in the majority of common cases and deployment scenarios. In an L3 network where every node supports IOAM there is no benefit. When the topology is known there is no benefit. Moreover, there is a clear cost, making transit devices modify the header when it would otherwise be unnecessary.

Mickey

On Mon, May 11, 2020 at 11:18 AM Haoyu Song <[email-masked]<mailto:[email-masked]>> wrote:
Hi WG,

Best regards,
Haoyu

-----Original Message-----
From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tal Mizrahi
Sent: Sunday, May 10, 2020 10:50 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Hop Count in IOAM Direct Exporting

Hi,

This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C59cddc7f25c14c51d39b08d7f56f4ce3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637247730711329608&amp;sdata=ptNRYLflJtmTvx5G16yLSxTG2IHFG%2FCoMaPKcN3GViU%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb8e73087c7854e5d6f0808d7f5e582c4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248238421397632&sdata=ctToiZTQ0tqaN3VS%2BfE%2BVXvU9aUhNrE2dHnJbwISMH4%3D&reserved=0>

Thanks,
Tal.

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C59cddc7f25c14c51d39b08d7f56f4ce3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637247730711329608&amp;sdata=qHRMJtgDAFuzoDes7x%2BXzIot3naFmty2LiznAL4JcA8%3D&amp;reserved=0<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb8e73087c7854e5d6f0808d7f5e582c4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248238421407635&sdata=a07giETajRma2hMlxUImZWYo42B1NBZ%2FA9maTqwNoQs%3D&reserved=0>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cb8e73087c7854e5d6f0808d7f5e582c4%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248238421417627&sdata=fueW6xFwQvciu%2BGxry4NM%2FIMKfMFiYHsT7hB3gun8H8%3D&reserved=0>

---

From: "Ramesh Sivakolundu (sramesh)" <[email-masked]>
Date: Mon, 11 May 2020 20:09:46 +0000

A missing sequence number from a given Node (Node_ID) indicates that an export packet is missing.  I am not understanding your point about missing export packets.

Network topology is irrelevant for identifying if an export packet is missing from any node (Node_ID) in any case.

If you are trying to correlate a specific packet in a flow with the exported data then I can see that sequence number will not be of much help. Not clear how Hop_Count of Hop_Lim address that requirement either.

In any case, correlation of specific packet with exported data is out of the scope of IOAM-DEX draft. There are multiple ways to get that level of correlation.

-Ramesh

On 5/11/20, 12:10 PM, "Haoyu Song" <[email-masked]> wrote:

    Hi Ramesh,

    Best,
    Haoyu

    -----Original Message-----
    From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
    Sent: Monday, May 11, 2020 11:29 AM
    To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
    Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

    Am I missing something?

    Thanks

    -Ramesh

        Hi WG,

        Best regards,
        Haoyu

        -----Original Message-----
        From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
        Sent: Sunday, May 10, 2020 10:50 PM
        To: IETF IPPM WG <[email-masked]>
        Subject: [ippm] Hop Count in IOAM Direct Exporting

        Hi,

        Thanks,
        Tal.

---

From: "Ramesh Sivakolundu (sramesh)" <[email-masked]>
Date: Mon, 11 May 2020 20:31:51 +0000

What are the potential corner cases? Are they captured somewhere in the mailing list, that I can review.

Thanks

Regards,
-Ramesh

From: ippm <[email-masked]> on behalf of Haoyu Song <[email-masked]>
Date: Monday, May 11, 2020 at 1:07 PM
To: Mickey Spiegel <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Mickey,

Best,
Haoyu

Haoyu,

Mickey

Best regards,
Haoyu

-----Original Message-----
From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tal Mizrahi
Sent: Sunday, May 10, 2020 10:50 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Hop Count in IOAM Direct Exporting

Hi,

Thanks,
Tal.

---

From: Haoyu Song <[email-masked]>
Date: Mon, 11 May 2020 21:45:16 +0000

Hi Ramesh, 

Let me use the following example to explain the purpose of the different piece of information. 

The following 3-tuple information is essential to correlated the export data from IOAM DEX :   [flow ID,  packet ID (or sequence number),  export data packet ID (or hop count)]

Assume a path with 3 IOAM-DEX enabled nodes (a), (b), (d) and one non-IOAM node c.     (a)->(b)->c->(d)

                                                                                                                  (a)     ->    (b)  ->   c ->  (d)
P1 from flow 1 generates 3 export packets  along the path:    [1, 1, 1],  [1, 1, 2],         [1, 1, 3]
P2 from flow 1  :                                                                                [1, 2, 1],  [1, 2, 2],         [1, 2, 3]
P3 from flow 2  :                                                                                [2, 1, 1],  [2, 1, 2],         [2, 1, 3]

Without flow ID, you can’t differentiate P1 and P3.  ( you receive [-, 1, 1], [-, 1, 2], [-, 1, 3] for both of them)
Without packet ID, you can’t differentiate P1 and P2.  And if P2 is missing, you can’t detect it. (you receive [1, -, 1], [1, -, 2], [1, -, 3] for both of them)
Without the export data ID, you can’t correctly order the export data packets. And if some export packet is missing, you can’t detect it.  
(For P1, you receive [1, 1, -], [1, 1, -], [1, 1, -]. You can't order them.   If you receive only two of them persistently to all the packets,  you don't know there's one missing)
If you use TTL as the export data ID, you might be confused by the TTL number hole created by node c. And what if TTL is not available?

With the three piece of information available, the IOAM DEX data can always be correlated easily without relying on any other part of the user packets. 

To answer your question in another email, the corner cases include: 
1. It has been proposed to use IOAM in L2 networks but there's no TTL available. 
2. It's ambiguous where to get TTL in network tunnels. 
3. Even if TTL exists, retrieving it may be more time consuming and complex, because it needs to parse the protocol header, depending on where IOAM is used.

Haoyu

-----Original Message-----
From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
Sent: Monday, May 11, 2020 1:10 PM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

-Ramesh

    Hi Ramesh,

    Best,
    Haoyu

    -----Original Message-----
    From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
    Sent: Monday, May 11, 2020 11:29 AM
    To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
    Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

    Am I missing something?

    Thanks

    -Ramesh

        Hi WG,

        Best regards,
        Haoyu

        -----Original Message-----
        From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
        Sent: Sunday, May 10, 2020 10:50 PM
        To: IETF IPPM WG <[email-masked]>
        Subject: [ippm] Hop Count in IOAM Direct Exporting

        Hi,

        This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
        https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cab76d087b7424d8c519708d7f5e754e6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248246242819921&amp;sdata=KiJV8hcPDsXt%2FH7zXBUQgYv1a0K9%2F2LwTrJYvogdFXo%3D&amp;reserved=0

        Thanks,
        Tal.

        _______________________________________________
        ippm mailing list
        [email-masked]
        https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cab76d087b7424d8c519708d7f5e754e6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248246242819921&amp;sdata=6%2BYKBFGCI3Stgbdc0ojWscgrUE5Ws%2Fn%2Be1qxJmkAjU0%3D&amp;reserved=0

        _______________________________________________
        ippm mailing list
        [email-masked]
        https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cab76d087b7424d8c519708d7f5e754e6%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248246242819921&amp;sdata=6%2BYKBFGCI3Stgbdc0ojWscgrUE5Ws%2Fn%2Be1qxJmkAjU0%3D&amp;reserved=0

---

From: "Ramesh Sivakolundu (sramesh)" <[email-masked]>
Date: Mon, 11 May 2020 22:22:33 +0000

I concur with the requirement of flow details. Flow ID in DEX header is one way, however, there are other ways to send the flow details in the exported data. 
I concur with the export data packet ID requirement. I just don't agree that export packet data ID needs be in the DEX header. 

Sequence number in the export packet data along with flow details addresses these two requirements listed above.

As far as packet ID, there are other ways to identify the sequence of packet in a flow at any given node from the trace data "timestamp" already defined in [I-D.ietf-ippm-ioam-data].

To get a consensus on this email thread, I am ok with using hop_lim already defined in [I-D.ietf-ippm-ioam-data]. I would prefer that DEX header processing is minimal and does not require any modification of the DEX header by intermediate nodes in the path.

Regards,

-Ramesh

On 5/11/20, 2:46 PM, "Haoyu Song" <[email-masked]> wrote:

    Hi Ramesh, 

                                                                                                                      (a)     ->    (b)  ->   c ->  (d)

    Haoyu

    -----Original Message-----
    From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
    Sent: Monday, May 11, 2020 1:10 PM
    To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
    Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

    -Ramesh

        Hi Ramesh,

        Best,
        Haoyu

        -----Original Message-----
        From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
        Sent: Monday, May 11, 2020 11:29 AM
        To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
        Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

        Am I missing something?

        Thanks

        -Ramesh

            Hi WG,

            Best regards,
            Haoyu

            -----Original Message-----

            Hi,

            Thanks,
            Tal.

---

From: Haoyu Song <[email-masked]>
Date: Tue, 12 May 2020 00:03:49 +0000

Hi Ramesh,

In my original PBT draft, I also described that  "time stamp" is possibly one way for export data correlation. However, it requires the network-wide clock synchronization which is not always the case.

Ideally, the information needed for data correlation should be contained in the option header itself. If it relies on some other sources, it's always possible that the data is not available or useful. Of course, one can argue that there are multiple possible ways and it's very likely we can somehow solve it (e.g., by using TTL, timestamp, topology knowledge, inference from data from other flows/packets...), but none is 100% reliable and these just bring more complexity for data analyzer. One has to adapt to the network capability and change the way to correlate the data case by case. 

IMHO, keep the "hop count" optional might be a good tradeoff. One can still keep the header "read only" and ignore the field. Or if one prefers, he can use it to simplify the data analyzer's job.   
 
Best regards,
Haoyu

-----Original Message-----
From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
Sent: Monday, May 11, 2020 3:23 PM
To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

Regards,

-Ramesh

    Hi Ramesh, 

                                                                                                                      (a)     ->    (b)  ->   c ->  (d)

    Haoyu

    -----Original Message-----
    From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
    Sent: Monday, May 11, 2020 1:10 PM
    To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
    Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

    -Ramesh

        Hi Ramesh,

        Best,
        Haoyu

        -----Original Message-----
        From: Ramesh Sivakolundu (sramesh) <[email-masked]> 
        Sent: Monday, May 11, 2020 11:29 AM
        To: Haoyu Song <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
        Subject: Re: [ippm] Hop Count in IOAM Direct Exporting

        Am I missing something?

        Thanks

        -Ramesh

            Hi WG,

            Best regards,
            Haoyu

            -----Original Message-----

            Hi,

            This issue has been raised a number of times, but we have not been able to get a clear answer from the working group so far, and this is the major remaining issue in draft-ietf-ippm-ioam-direct-export.
            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ioamteam-ippm-ioam-direct-export-00&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C9e27cd6446654e393b1c08d7f5f9cf23%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248325597627833&amp;sdata=o9GP0PMnUONr01NjYB7%2FA%2B8Gi1aqabQKNLwet1rVdJ4%3D&amp;reserved=0

            Thanks,
            Tal.

            _______________________________________________
            ippm mailing list
            [email-masked]
            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C9e27cd6446654e393b1c08d7f5f9cf23%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248325597627833&amp;sdata=eWAj2ICagNt0aSdrD%2BcuD0yIiVHAMTvegWRF5N3yXyw%3D&amp;reserved=0

            _______________________________________________
            ippm mailing list
            [email-masked]
            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7C9e27cd6446654e393b1c08d7f5f9cf23%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637248325597627833&amp;sdata=eWAj2ICagNt0aSdrD%2BcuD0yIiVHAMTvegWRF5N3yXyw%3D&amp;reserved=0