Subject: [ippm] Questions about draft-xiao-ippm-ioam-conf-state

From: wangyali <[email-masked]>
Date: Sun, 24 May 2020 11:49:35 +0000

Hi authors,

This is Yali. This is an interesting work. I have following two questions.

First, is the list of Namespace-IDs the subset or all of Namespaces which the IOAM encapsulating node belongs to? If it is, I suggest adding some words to illustrate this.

Second, could this extension to the echo request/reply mechanisms also be used in ICMP defined for IPv4?

In my opinion, as the Information Request and Reply Type=15 and Type=16 have been obsolete [RFC6918], so it could be used as the IOAM Capability echo request/reply messages to acquire the enabled IOAM capabilities.

Thanks,
Yali

---

From: <[email-masked]>
Date: Tue, 26 May 2020 16:57:34 +0800 (CST)

Hi Yali,

Many thanks for your review and questions.

Please see my inline reply with <XM>.

Best Regards,

Xiao Min

原始邮件

发件人：wangyali <[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2020年05月24日 19:50
主 题 ：[ippm] Questions about draft-xiao-ippm-ioam-conf-state

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

Hi authors,

 

<XM>  Yes, you're correct. I'll make it more clear in the next revision.

<XM>  In theory the mechanism described in this draft can also apply to ICMPv4, whereas I believe ICMPv4 needs to be taken into account only after the IOAM over IPv4 is defined. Currently the IOAM over IPv6 has been adopted in IPPM WG as draft-ietf-ippm-ioam-ipv6-options, if you're interested, we can work together on ICMPv6 first.

 

Thanks,

Yali

---

From: wangyali <[email-masked]>
Date: Wed, 27 May 2020 02:11:45 +0000

Hi Min,

Thanks for your reply. Please see inline [Yali].

Best regards,
Yali

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 26, 2020 4:58 PM
To: wangyali <[email-masked]>
Cc: [email-masked]
Subject: Re:[ippm] Questions about draft-xiao-ippm-ioam-conf-state

Hi Yali,

Best Regards,

Xiao Min
原始邮件
发件人：wangyali <[email-masked]<mailto:[email-masked]>>
收件人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年05月24日 19:50
主 题 ：[ippm] Questions about draft-xiao-ippm-ioam-conf-state
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm
Hi authors,

First, is the list of Namespace-IDs the subset or all of Namespaces which the IOAM encapsulating node belongs to? If it is, I suggest adding some words to illustrate this.
<XM>  Yes, you're correct. I'll make it more clear in the next revision.
 [Yali] OK. Thanks.
Second, could this extension to the echo request/reply mechanisms also be used in ICMP defined for IPv4?
<XM>  In theory the mechanism described in this draft can also apply to ICMPv4, whereas I believe ICMPv4 needs to be taken into account only after the IOAM over IPv4 is defined. Currently the IOAM over IPv6 has been adopted in IPPM WG as draft-ietf-ippm-ioam-ipv6-options, if you're interested, we can work together on ICMPv6 first.
 [Yali] IOAM over IPv6 is important. While considering a scenario that IOAM applied in the legacy IPv4 network, I think the problem of echo request/reply IOAM node capabilities also needs to be taken account. But it may be discussed in another draft later.
In my opinion, as the Information Request and Reply Type=15 and Type=16 have been obsolete [RFC6918], so it could be used as the IOAM Capability echo request/reply messages to acquire the enabled IOAM capabilities.
 [Yali] Do you think this is a way to request/reply IOAM capabilities?
Thanks,
Yali

---

From: <[email-masked]>
Date: Wed, 27 May 2020 17:21:26 +0800 (CST)

Hi Yali,

This draft is a supportive document to IOAM encapsulations, so I believe it's too early to consider concrete ICMPv4 extensions, before there is rough consensus on IOAM over IPv4 encapsulation.

Best Regards,

Xiao Min

原始邮件

发件人：wangyali <[email-masked]>
收件人：肖敏10093570;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2020年05月27日 10:11
主 题 ：RE: Re:[ippm] Questions about draft-xiao-ippm-ioam-conf-state

Hi Min,

 

Best regards,

Yali

 

Hi Yali,

Best Regards,

Xiao Min

原始邮件

日期：2020年05月24日 19:50

主题：[ippm] Questions about draft-xiao-ippm-ioam-conf-state

Hi authors,

 

 [Yali] OK. Thanks.

<XM>  In theory the mechanism described in this draft can also apply to ICMPv4, whereas I believe ICMPv4 needs to be taken into account only after the IOAM over IPv4 is defined.
 Currently the IOAM over IPv6 has been adopted in IPPM WG as draft-ietf-ippm-ioam-ipv6-options, if you're interested, we can work together on ICMPv6 first.

 [Yali] IOAM over IPv6 is important. While considering a scenario that IOAM applied in the legacy IPv4 network, I think the problem of echo request/reply
 IOAM node capabilities also needs to be taken account. But it may be discussed in another draft later.

In my opinion, as the Information Request and Reply Type=15 and Type=16 have been obsolete [RFC6918], so it could be used as the IOAM Capability echo request/reply messages to acquire
 the enabled IOAM capabilities.

Thanks,

Yali

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 27 May 2020 19:49:11 -0700

To be clear regarding IPv4, the guidance in previous meetings has been that a standard IPv4 extension is almost certainly not something that would progress as a standard. I would suggest not basing work on the presence of such an IPv4 extension.

Best,
Tommy

> On May 27, 2020, at 2:21 AM, [email-masked] wrote:
> 
> Hi Yali,
> 
> 
> 
> 发件人：wangyali <[email-masked] <mailto:[email-masked]>>
> 收件人：肖敏10093570;
> 抄送人：[email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>;
> 日 期 ：2020年05月27日 10:11
> 发件人：wangyali <[email-masked] <mailto:[email-masked]>>
> 收件人：[email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>;
> 日期：2020年05月24日 19:50
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>
> Hi authors,
>

---

From: wangyali <[email-masked]>
Date: Thu, 28 May 2020 02:54:44 +0000

Hi Min and Tommy,

Thank you. Significant information.

Yali

From: Tommy Pauly [mailto:[email-masked]]
Sent: Thursday, May 28, 2020 10:49 AM
To: [email-masked]; wangyali <[email-masked]>
Cc: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Questions about draft-xiao-ippm-ioam-conf-state

Best,
Tommy

On May 27, 2020, at 2:21 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Yali,

Best Regards,
Xiao Min
原始邮件
发件人：wangyali <[email-masked]<mailto:[email-masked]>>
收件人：肖敏10093570;
抄送人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年05月27日 10:11
主 题 ：RE: Re:[ippm] Questions about draft-xiao-ippm-ioam-conf-state
Hi Min,

Best regards,
Yali

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, May 26, 2020 4:58 PM
To: wangyali <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re:[ippm] Questions about draft-xiao-ippm-ioam-conf-state

Hi Yali,

Best Regards,
Xiao Min
原始邮件

---

From: <[email-masked]>
Date: Thu, 28 May 2020 15:51:02 +0800 (CST)

Hi Tommy,

Thanks for this timely notice. I'll follow the guidance you mentioned.

Get back to the current draft, I need your further guidance on how to progress it.

This draft has been presented a couple of times since IETF 100. The intention of this draft is clear and the mechanism described in this draft is straightforward.

With several revisions that followed the changes made in IOAM-Data draft, and resolved the received comments on or off the mailing list, this draft is relatively stable now.

Best Regards,

Xiao Min

原始邮件

发件人：TommyPauly <[email-masked]>
收件人：肖敏10093570;[email-masked] <[email-masked]>;
抄送人：IETF IPPM WG ([email-masked]) <[email-masked]>;
日 期 ：2020年05月28日 10:49
主 题 ：Re: [ippm] Questions about draft-xiao-ippm-ioam-conf-state

Tommy

Hi Yali,

Best Regards,

Xiao Min

_______________________________________________ippm mailing [email-masked]://www.ietf.org/mailman/listinfo/ippm

收件人：肖敏10093570;

日 期 ：2020年05月27日 10:11

Hi Min,

Best regards,

Yali
 
From: [email-masked] [mailto:[email-masked]]Sent: Tuesday, May 26, 2020 4:58 PMTo: wangyali <[email-masked]>Cc: [email-masked]: Re:[ippm] Questions about draft-xiao-ippm-ioam-conf-state

Hi Yali,

 

Best Regards,

Xiao Min

原始邮件

日期：2020年05月24日 19:50

_______________________________________________ippm mailing [email-masked]://www.ietf.org/mailman/listinfo/ippm

Hi authors,

 [Yali] OK. Thanks.

Thanks,

Yali