Subject: Re: [ippm] [Ext] Re: [Last-Call] Last Call: <draft-ietf-ippm-ioam-data-11.txt> (Data Fields for In-situ OAM) to Proposed Standard

From: Michelle Cotton <[email-masked]>
Date: Wed, 2 Dec 2020 22:17:50 +0000

Hello,

Comments below, see [MC].
If there is any clarification needed for RFC8126, please let us know so that we can include it in a future revision.

--Michelle

On 12/2/20, 7:32 AM, "last-call on behalf of Salz, Rich" <[email-masked] on behalf of rsalz=[email-masked]> wrote:

    Let me comment on this. I've been one of the three TLS registry experts for a couple of years. TL;DR I think the draft is not in conflict with how things are done.

    On 12/2/20, 5:37 AM, "tom petch" <[email-masked]> wrote:

        This I-D seems at odds with RFC8126 over the use of Expert Review in s.8.7

        ' The responsible AD will appoinht ...'
        RFC8126 seems clear that the IESG appoints and may do so in advance and 
        having more than one is recommended

    Well, the AD is part of the IESG. From what I have seen, registry experts are always appointed by the AD's, as they are expected to be the subject matter experts.

[MC] The Area Director helps identify the expert for a registry, the IESG officially approves/designates the selected person(s).

        'the expert will approve or deny..'
        RFC8126 seems clear that that is the role of IANA.  The expert 
        recommends and it is then up to IANA to act

    IANA's actions are updating the registry. The expert(s) recommendations are binding.

[MC] IANA follows the decisions by the designated experts.  IANA facilitates any communications and makes the approved updates to the registry.

    >    'the expert can approve allocations.
        No, that is the role of IANA; early allocation is possible but that is 
        the decision of IANA.

    If there's an expert, IANA will forward to the expert(s) and ask what to do.

    I think reading Section 5 justifies my views above.  Perhaps 8126 is not internally consistent in some of these details.

[MC] Early allocations are decided by the Working Group Chairs and Area Directors per RFC7120.

    -- 
    last-call mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/last-call__;!!PtGJab4!vb5C1TPMltwSjmb6uQuf0v8FaQPGdMVixEjosDfvFEccssVXgMmoMzVSf_wUc3idjfPjm3E-gO0$

---

From: tom petch <[email-masked]>
Date: Thu, 3 Dec 2020 10:49:09 +0000

From: ippm <[email-masked]> on behalf of Michelle Cotton <[email-masked]>
Sent: 02 December 2020 22:17

Hello,

<tp>
Michelle

Thank you for your thoughts below; I am content with your wording.

I did have one additional thought that this I-D lacks details of what fields should be present in an entry and, for Expert Review, RFC8126 says that there should be a field for change controller which sounds good to me

Tom Petch

--Michelle