Subject: [ippm] Explicit Flow Measurements implementations

From: Nilo Massimo <[email-masked]>
Date: Thu, 18 Mar 2021 11:57:25 +0000

Hi All.

After the "Explicit Flow Measurements" draft presentation (https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-01) in the IPPM WG on March 12th, it was asked by Ian Sweet and Martin Duke if there are any implementations of the EFM methodology on servers and clients.

Here is a list of some implementations made by the authors of the draft.

TIM/Telecom Italia has realized an implementation for delay measurement with:
- a client and a passive observer on mobile user devices, built in Android using Quic-Go (with gomobile binding) and spindump library.
  The observer executes delay measurements, both with Spin bit and Delay bit marking methods.
  The client app exchange QUIC traffic marked for Spin bit/Delay bit versus a server.

- a server built by mean of Quic-Go, generates marked traffic and supports delay measurements with Spin bit and Delay bit methods.

  (Draft https://datatracker.ietf.org/doc/html/draft-cnbf-ippm-user-devices-explicit-monitoring-01)
  This implementation have been tested on TIM production network, both with mobile and fixed access.

- Other implementations for loss algorithms (QR and T) have been tested in our lab with good results and we are planning to move them in production network for some services under our control.

Akamai and Orange have built a monitoring system with QL marking, specifically for loss measurements.
Their implementation has already been used in CDN servers to make EFM.
Litespeed Tech also implemented QL marking in their lsquic library.

Moreover, Ericsson is carrying out several monitoring initiatives using the SpinBit for delay EFM.

Best Regards,
Massimo and Fabio

____________________
TIM - Telecom Italia
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
____________________

TIM - Uso Interno - Tutti i diritti riservati.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Ian Swett <[email-masked]>
Date: Mon, 22 Mar 2021 18:24:14 -0400

Thanks for the summary.

Is there a plan to share(via email or presentation) what's been learned
from those experiments with the IETF?  If they've been shared in the past
and I forgot, please just add relevant links to this thread so they're easy
for people to find.

Thanks, Ian

On Thu, Mar 18, 2021 at 7:57 AM Nilo Massimo <massimo.nilo=
[email-masked]> wrote:

> Hi All.
>
>
>
> After the "Explicit Flow Measurements" draft presentation (
> https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-01)
> in the IPPM WG on March 12th, it was asked by Ian Sweet and Martin Duke if
> there are any implementations of the EFM methodology on servers and clients.
>
>
>
> - a client and a passive observer on mobile user devices, built in Android
> using Quic-Go (with gomobile binding) and spindump library.
>
> - a server built by mean of Quic-Go, generates marked traffic and supports
> delay measurements with Spin bit and Delay bit methods.
>
>
>
>   (Draft
> https://datatracker.ietf.org/doc/html/draft-cnbf-ippm-user-devices-explicit-monitoring-01
> )
>
> - Other implementations for loss algorithms (QR and T) have been tested in
> our lab with good results and we are planning to move them in production
> network for some services under our control.
>
>
>
> ------------------------------
> <https://on.tim.it/banner-mail-dip>
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
> persone indicate. La diffusione, copia o qualsiasi altra azione derivante
> dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
> abbiate ricevuto questo documento per errore siete cortesemente pregati di
> darne immediata comunicazione al mittente e di provvedere alla sua
> distruzione, Grazie.
>
> * This e-mail and any attachments is confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks. *
>
> *Rispetta l'ambiente. Non stampare questa mail se non è necessario.*
>

---

From: Nilo Massimo <[email-masked]>
Date: Tue, 23 Mar 2021 11:31:32 +0000

Hi Ian,
thank you for your reply.

As for our TIM activities, we will collect the material and in the next days we plan to share it via email in the IPPM WG.

Best Regards,
Massimo

____________________

TIM - Telecom Italia
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
____________________

From: Ian Swett <ianswett=[email-masked]>
Sent: lunedì 22 marzo 2021 23:24
To: Nilo Massimo <[email-masked]>
Cc: IETF IPPM WG ([email-masked]) <[email-masked]>; [email-masked]; Dmitri Tikhonov <[email-masked]>; Lubashev, Igor <[email-masked]>; [email-masked]; Isabelle Hamchaoui <[email-masked]>; [email-masked]; Mirja Kuehlewind <[email-masked]>; [email-masked]; Marcus Ihlar <[email-masked]>
Subject: [EXT] Re: Explicit Flow Measurements implementations

Thanks for the summary.

Is there a plan to share(via email or presentation) what's been learned from those experiments with the IETF?  If they've been shared in the past and I forgot, please just add relevant links to this thread so they're easy for people to find.

Thanks, Ian

On Thu, Mar 18, 2021 at 7:57 AM Nilo Massimo <massimo.nilo=[email-masked]<mailto:[email-masked]>> wrote:
Hi All.

Best Regards,
Massimo and Fabio
 ____________________
TIM - Telecom Italia
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
____________________

---

From: Ian Swett <[email-masked]>
Date: Tue, 23 Mar 2021 09:31:44 -0400

Great, thanks!

On Tue, Mar 23, 2021 at 7:31 AM Nilo Massimo <massimo.nilo=
[email-masked]> wrote:

> As for our TIM activities, we will collect the material and in the next
> days we plan to share it via email in the IPPM WG.
>
>
>
> Best Regards,
>
> Massimo
>
>
>
> ____________________
>
>
>
> TIM - Telecom Italia
>
> Via G. Reiss Romoli, 274
>
> 10148 - Torino (Italy)
>
> ____________________
>
>
>
> *From:* Ian Swett <ianswett=[email-masked]>
> *Sent:* lunedì 22 marzo 2021 23:24
> *To:* Nilo Massimo <[email-masked]>
> *Cc:* IETF IPPM WG ([email-masked]) <[email-masked]>; [email-masked]; Dmitri
> Tikhonov <[email-masked]>; Lubashev, Igor <
> [email-masked]>; [email-masked]; Isabelle Hamchaoui <
> [email-masked]>; [email-masked]; Mirja Kuehlewind <
> [email-masked]>; [email-masked]; Marcus Ihlar <
> [email-masked]>
> *Subject:* [EXT] Re: Explicit Flow Measurements implementations
>
>
>
> Thanks for the summary.
>
>
>