Subject: [ippm] Adoption call for Explicit Flow Measurements Techniques

From: Tommy Pauly <[email-masked]>
Date: Fri, 08 Oct 2021 08:59:12 -0700

Hello IPPM,

This email starts an adoption call for draft-mdt-ippm-explicit-flow-measurements, "Explicit Flow Measurements Techniques”. This document is proposed as an Informational document that describes techniques that go beyond single bit markings like the QUIC spin bit.

https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/ <https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/>
https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02 <https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02>

This adoption call will last until Friday, October 22. Please review the document, and reply to this email thread to indicate if you think IPPM should adopt this document.

Best,
Tommy

---

From: "Bulgarella Fabio (Guest)" <[email-masked]>
Date: Mon, 11 Oct 2021 13:57:32 +0000

Hi WG, Chairs,

I support the adoption of this document as author.

These passive e2e methodologies for perfomance measurement are quite important for TELCOs as they contribute to evaluate the quality of service delivered to the customer?.

Best Regards,

Fabio B.

________________________________
Da: ippm <[email-masked]> per conto di Tommy Pauly <tpauly=[email-masked]>
Inviato: venerdì 8 ottobre 2021 17:59
A: IETF IPPM WG ([email-masked])
Oggetto: [EXT] [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

This email starts an adoption call for draft-mdt-ippm-explicit-flow-measurements, "Explicit Flow Measurements Techniques". This document is proposed as an Informational document that describes techniques that go beyond single bit markings like the QUIC spin bit.

https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/
https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02

Best,
Tommy

---

From: Cociglio Mauro <[email-masked]>
Date: Tue, 12 Oct 2021 12:08:57 +0000

Hi all.
I support the adoption of this document as author.
Telecom Italia has developed some mobile applications that implement the metrics described in the draft on smartphones.
The tests have already been successfully completed and we are organizing a field trial for more in-depth validation.
The idea is to have apps that generate QUIC traffic marked  according to the specifications of the draft and an app that analyzes the traffic by acting as an observer.
Best regards.
Mauro
_____________________
Mauro Cociglio
TIM – Telecom Italia
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

Da: ippm <[email-masked]> Per conto di Tommy Pauly
Inviato: venerdì 8 ottobre 2021 17:59
A: IETF IPPM WG ([email-masked]) <[email-masked]>
Oggetto: [EXT] [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

Best,
Tommy

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 12 Oct 2021 09:40:09 -0700

Dear All,
I support adoption of this draft. On-path telemetry is an essential OAM
tool.

Regards,
Greg

On Fri, Oct 8, 2021 at 8:59 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> Hello IPPM,
>
> This email starts an adoption call for
> draft-mdt-ippm-explicit-flow-measurements, "Explicit Flow Measurements
> Techniques”. This document is proposed as an Informational document that
> describes techniques that go beyond single bit markings like the QUIC spin
> bit.
>
> This adoption call will last until *Friday, October 22*. Please review
> the document, and reply to this email thread to indicate if you think IPPM
> should adopt this document.
>
> Best,
> Tommy
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: Alexander L Clemm <[email-masked]>
Date: Tue, 12 Oct 2021 22:06:25 -0700

Dear all,

I think that a description of various flow measurement techniques using 
various types of marking bits will make for a useful informational 
document with substance.   I support adoption as well.

--- Alex

On 10/12/2021 9:40 AM, Greg Mirsky wrote:
> Dear All,
> I support adoption of this draft. On-path telemetry is an essential 
> OAM tool.
>
> Regards,
> Greg
>
> On Fri, Oct 8, 2021 at 8:59 AM Tommy Pauly 
> <tpauly=[email-masked]> wrote:
>
>     Hello IPPM,
>
>     draft-mdt-ippm-explicit-flow-measurements, "Explicit Flow
>     Measurements Techniques”. This document is proposed as an
>     Informational document that describes techniques that go beyond
>     single bit markings like the QUIC spin bit.
>
>     This adoption call will last until *Friday, October 22*. Please
>     review the document, and reply to this email thread to indicate if
>     you think IPPM should adopt this document.
>
>     Best,
>     Tommy

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 14 Oct 2021 08:54:38 +0000

Dear All,
I support the adoption as co-author.
This informational document describes measurement techniques potentially applicable to different Client-Server protocols.

Regards,

Giuseppe

From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Friday, October 8, 2021 5:59 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

Best,
Tommy

---

From: Marcus Ihlar <[email-masked]>
Date: Thu, 14 Oct 2021 14:09:06 +0000

Speaking purely as an individual here and not as co-chair.

I support the adoption of this draft, it serves as a good foundation to advance our understanding of the utility of end-to-end marking bits.

Marcus

From: ippm <[email-masked]> On Behalf Of Alexander L Clemm
Sent: den 13 oktober 2021 07:06
To: [email-masked]
Subject: Re: [ippm] Adoption call for Explicit Flow Measurements Techniques

Dear all,

I think that a description of various flow measurement techniques using various types of marking bits will make for a useful informational document with substance.   I support adoption as well.

--- Alex

   Dear All,

   I support adoption of this draft. On-path telemetry is an essential OAM tool.

   Regards,

   Greg

   On Fri, Oct 8, 2021 at 8:59 AM Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>> wrote:

      Hello IPPM,

      Best,

      Tommy

      _______________________________________________
      ippm mailing list
      [email-masked]<mailto:[email-masked]>
      https://www.ietf.org/mailman/listinfo/ippm

   _______________________________________________
   ippm mailing list
   [email-masked]<mailto:[email-masked]>
   https://www.ietf.org/mailman/listinfo/ippm

---

From: Nicolas Kuhn <[email-masked]>
Date: Thu, 14 Oct 2021 16:31:06 +0200

Dear all,

I support the adoption of the draft.

On a side note, it may be worth pointing out RFC9065, with the proposed
approach being 'beneficial' (as opposed to malicious!).
"

 Current uses of transport header information by network devices on
   the Internet path are explained.  These uses can be beneficial or
   malicious.  This is written to provide input to the discussion around
   what is an appropriate balance by highlighting some implications of
   transport header encryption.
"

Cheers

Nico

On Thu, Oct 14, 2021 at 4:09 PM Marcus Ihlar <marcus.ihlar=
[email-masked]> wrote:

> I support the adoption of this draft, it serves as a good foundation to
> advance our understanding of the utility of end-to-end marking bits.
>
>
>
> Marcus
>
>
>
> *From:* ippm <[email-masked]> *On Behalf Of * Alexander L Clemm
> *Sent:* den 13 oktober 2021 07:06
> *To:* [email-masked]
> *Subject:* Re: [ippm] Adoption call for Explicit Flow Measurements
> Techniques
>
>
>
> Dear all,
>
> various types of marking bits will make for a useful informational document
> with substance.   I support adoption as well.
>
> --- Alex
>

---

From: <[email-masked]>
Date: Thu, 14 Oct 2021 16:37:07 +0000

Hi,
I support the adoption.
It will help troubleshooting QUIC performance.
Regards
Emile

De : ippm [mailto:[email-masked]] De la part de Tommy Pauly
Envoyé : vendredi 8 octobre 2021 17:59
À : IETF IPPM WG ([email-masked]) <[email-masked]>
Objet : [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

Best,
Tommy

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Haoyu Song <[email-masked]>
Date: Thu, 14 Oct 2021 16:57:13 +0000

IPPM WG and chairs,

The proposed method is interesting and useful. I support the WG adoption.
I have a question to the authors. The draft says that the method is valuable for encrypted transport headers but later it suggested to encapsulate the bits in QUIC and TCP header. How does that work if the transport header is encrypted?

Best regards,
Haoyu
From: ippm <[email-masked]> On Behalf Of Tommy Pauly
Sent: Friday, October 8, 2021 8:59 AM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mdt-ippm-explicit-flow-measurements%2F&data=04%7C01%7Chaoyu.song%40futurewei.com%7C0bb1ccaae82a449e5c8308d98a749f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637693055772340329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=o%2FcX355kvvyuGlhYGsYrsEPfQimXoPMFoxYFptqmxsE%3D&reserved=0>
https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-mdt-ippm-explicit-flow-measurements-02&data=04%7C01%7Chaoyu.song%40futurewei.com%7C0bb1ccaae82a449e5c8308d98a749f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637693055772350280%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=RcUvJsuRDvZ38Ec1Ss2X10CzTDHX5rCC748iZmcLJyU%3D&reserved=0>

Best,
Tommy

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 14 Oct 2021 21:24:02 +0000

Hi Haoyu,
The methods described in this document, if applied to encrypted protocols, need to use unencrypted header fields in order to enable the on-path measurements. That is the case of the examples for QUIC and TCP. In this regard, note that the spin bit has already been defined in the QUIC short packet header (RFC9000).

We can further clarify this point in the next version.

Regards,

Giuseppe

From: ippm <[email-masked]> On Behalf Of Haoyu Song
Sent: Thursday, October 14, 2021 6:57 PM
To: Tommy Pauly <tpauly=[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Adoption call for Explicit Flow Measurements Techniques

IPPM WG and chairs,

Best regards,
Haoyu
From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tommy Pauly
Sent: Friday, October 8, 2021 8:59 AM
To: IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

Best,
Tommy

---

From: "Lubashev, Igor" <[email-masked]>
Date: Fri, 15 Oct 2021 03:44:33 +0000

I support adoption as a co-author.

These measurement techniques are useful for L3 QoS monitoring by on-path agents without access to cryptographic materials, while preserving privacy and ossification-resistant properties of the encrypted protocols.  Once these techniques are standardized here, we at Akamai intend to work with QUIC WG on a concrete implementation draft and to implement it in our deployed service.

  *   Igor

From: Tommy Pauly <tpauly=[email-masked]>
Sent: Friday, October 8, 2021 11:59 AM
To: IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: [ippm] Adoption call for Explicit Flow Measurements Techniques

Hello IPPM,

https://datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-mdt-ippm-explicit-flow-measurements/__;!!GjvTz_vk!Fe6CmX6oRY4BuCrOAjYjaMp6TvANt6jmECP3VdWldtxzls-UA9a3gmSZUUQAr00$>
https://datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-mdt-ippm-explicit-flow-measurements-02__;!!GjvTz_vk!Fe6CmX6oRY4BuCrOAjYjaMp6TvANt6jmECP3VdWldtxzls-UA9a3gmSZ0R7hAeA$>

Best,
Tommy

---

From: Ike Kunze <[email-masked]>
Date: Fri, 15 Oct 2021 07:57:03 +0000

Hi all,

I also support adoption.
For our recent ANRW paper [1], we have first implemented the proposed loss measurement techniques based on the descriptions in the draft and then evaluated their performance.
While the descriptions of the approaches could be a bit more precise, their performance looks promising and I think they offer a helpful means for network telemetry in times of QUIC.

Best,
Ike

[1] https://dl.acm.org/doi/10.1145/3472305.3472319

On 8. Oct 2021, at 17:59, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Hello IPPM,

Best,
Tommy

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 22 Oct 2021 10:48:32 -0700

Hello IPPM,

Thanks to everyone who provided feedback! It sounds like we have support to take on this work in IPPM.

Authors, please submit draft-ietf-ippm-explicit-flow-measurements-00 when ready.

Best,
Tommy

> On Oct 8, 2021, at 8:59 AM, Tommy Pauly <tpauly=[email-masked]> wrote:
> 
> Hello IPPM,
>