Subject: Re: [ippm] Fw: New Version Notification for draft-du-ippm-self-contained-alt-mark-00.txt

From: Jai Kumar <[email-masked]>
Date: Thu, 11 Nov 2021 19:44:21 +0000

Hi Zongpeng,

It’s not very clear what is the definition of block information and who generates it?

Q1.
Block information; is it a set of entities like block id+CRC+TLV?

Q2.
Who is client in this case? Data plane or sw process? If it is not the data plane then how do we maintain block id for line rate traffic given that coloring is done alternate colored blocks for all the packets in a flow.

Thanks,
-Jai
From: ippm <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Wednesday, November 10, 2021 at 5:59 PM
To: "IETF IPPM WG ([email-masked])" <[email-masked]>
Subject: [ippm] Fw: New Version Notification for draft-du-ippm-self-contained-alt-mark-00.txt

Hi, everyone

    We have recently proposed a new draft draft-du-ippm-self-contained-alt-mark-00.

    We are glad that anyone who is interested in can give some suggestions.
    We think it is an enhancement to the alternate-marking-mechanism.
    The benefit is mainly to enable that client can send every packet with performance-monitoring information.

    A slide is also available:
     https://datatracker.ietf.org/meeting/112/materials/slides-112-ippm-self-contained-alternate-marking-mechanism-for-performance-monitoring-in-high-quality-network-00

Best Regards
Zongpeng Du

________________________________
[email-masked]<mailto:[email-masked]> & [email-masked]

From: internet-drafts<mailto:[email-masked]>
Date: 2021-10-25 12:07
To: Peng Liu<mailto:[email-masked]>; Zongpeng Du<mailto:[email-masked]>
Subject: New Version Notification for draft-du-ippm-self-contained-alt-mark-00.txt

A new version of I-D, draft-du-ippm-self-contained-alt-mark-00.txt
has been successfully submitted by Zongpeng Du and posted to the
IETF repository.

Name: draft-du-ippm-self-contained-alt-mark
Revision: 00
Title: Self-Contained Alternate-Marking Mechanism for Performance Monitoring in High-Quality Network
Document date: 2021-10-24
Group: Individual Submission
Pages: 6
URL:            https://www.ietf.org/archive/id/draft-du-ippm-self-contained-alt-mark-00.txt
Status:         https://datatracker.ietf.org/doc/draft-du-ippm-self-contained-alt-mark/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-du-ippm-self-contained-alt-mark

Abstract:
   This document introduces a self-contained method that can involve the
   client in based on some extensions to the alternate-marking
   (coloring) technique.

The IETF Secretariat

-- 
This electronic communication and the information and any files transmitted 
with it, or attached to it, are confidential and are intended solely for 
the use of the individual or entity to whom it is addressed and may contain 
information that is confidential, legally privileged, protected by privacy 
laws, or otherwise restricted from disclosure to anyone else. If you are 
not the intended recipient or the person responsible for delivering the 
e-mail to the intended recipient, you are hereby notified that any use, 
copying, distributing, dissemination, forwarding, printing, or copying of 
this e-mail is strictly prohibited. If you received this e-mail in error, 
please return the e-mail to the sender, delete it from your computer, and 
destroy any printed copy of it.

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 12 Nov 2021 09:59:35 +0800

Hi, Jai

    Thank you very much for your comments. 
    Please see inline.
    If there is any further problem, please connect me again. Thanks in advance.

Best Regards
Zongpeng Du

[email-masked] & [email-masked]
 
From: Jai Kumar
Date: 2021-11-12 03:44
To: [email-masked]; IETF IPPM WG ([email-masked])
Subject: Re: [ippm] Fw: New Version Notification for draft-du-ippm-self-contained-alt-mark-00.txt
Hi Zongpeng,

[zongpeng]  In our draft, we think the block information is something like the block ID, packet numbers in the block, the timestamp of the first packet, etc.
According to rfc8321, the block is generated by the coloring point, which is normally a node in the network. In our draft, we think the client can also be the coloring point.
[zongpeng]

Q1.

    [zongpeng] Yes[zongpeng] 

Q2.
 
[zongpeng]
We think the client can be an APP in a phone, or some software in a laptop. Maybe, some low-layer functions implemented in the OS which can be called by the APP or the software to enable the coloring.
What we want is an E2E method. Every node along the path including the server can monitor the performance if they want.
   In the mechanism, the client can send the coloring & block information continually, and does not need to report anything else.
[zongpeng]

Thanks,
-Jai
 
Hi, everyone

Best Regards
Zongpeng Du

[email-masked] & [email-masked]
 
From: internet-drafts
Date: 2021-10-25 12:07
To: Peng Liu; Zongpeng Du
Subject: New Version Notification for draft-du-ippm-self-contained-alt-mark-00.txt

Abstract:

The IETF Secretariat

This electronic communication and the information and any files transmitted with it, or attached to it, are confidential and are intended solely for the use of the individual or entity to whom it is addressed and may contain information that is confidential, legally privileged, protected by privacy laws, or otherwise restricted from disclosure to anyone else. If you are not the intended recipient or the person responsible for delivering the e-mail to the intended recipient, you are hereby notified that any use, copying, distributing, dissemination, forwarding, printing, or copying of this e-mail is strictly prohibited. If you received this e-mail in error, please return the e-mail to the sender, delete it from your computer, and destroy any printed copy of it.