Subject: [Isis-wg] Lack of I/E bit in TLV 135

From: "Ruth Civil" <[email-masked]>
Date: Fri, 09 May 2003 09:09:59 -0400

There was a quick exchange on this mailing list a couple of days ago
where someone asked about the lack of an I/E bit in the Extended IP
Reachability TLV (type 135). 

The response was that it wasn't included because it was more or less
useless.  

What happens if an ISIS router using wide metrics needs to distinguish
between internal and external routes in order to apply different route
preferences to internal vs external routes ?

I believe there are some routers (most notably Juniper) which offer the
ability to configure both a preference (for internal routes) and an
external-preference (for external routes). What method could such
routers be using to distinguish between internal and external routes in
order to apply those different preferences (when wide metrics are being
used) ?  

- Ruth

-- 
Ruth Civil
Routing development
ESN 6 395 1142
[email-masked]
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Manral, Vishwas" <[email-masked]>
Date: Mon, 12 May 2003 23:20:08 -0400

Hi,

Wouldn't it cause routing loops if we made routing calculation decisions
based on an optional feature i.e. sub-TLV?

Thanks,
Vishwas

-----Original Message-----
From: Tony Przygienda [mailto:[email-masked]]
Sent: Tuesday, May 13, 2003 1:39 AM
To: Tony Li
Cc: Ruth Civil; [email-masked]
Subject: Re: [Isis-wg] Lack of I/E bit in TLV 135

Tony Li wrote:

>One might use an administrative tag...  this would allow you
>to describe more semantics than simply I/E.
>  
>
didn't christian write a while ago
 a draft on sub-TLV in 135 that carried the external/internal?
    - tony

---

From: "Tony Li" <[email-masked]>
Date: Mon, 12 May 2003 23:32:29 -0700

Yes, anything that changes the semantics of an SPF would
definitely be hazardous.

However, when a protocol is injecting routes from a
different level or from a different protocol, or exporting
routes, then it is possible to filter the routes without
causing (too much) danger of breaking the net.

Obvious cases that still won't be addressed are creating
positive feedback loops and the like.

Tony

|    -----Original Message-----
|    From: Manral, Vishwas [mailto:[email-masked]] 
|    Sent: Monday, May 12, 2003 8:20 PM
|    To: [email-masked]'; Tony Li
|    Cc: Ruth Civil; [email-masked]
|    Subject: RE: [Isis-wg] Lack of I/E bit in TLV 135
|    
|    
|    Hi,
|    
|    Wouldn't it cause routing loops if we made routing 
|    calculation decisions
|    based on an optional feature i.e. sub-TLV?
|    
|    Thanks,
|    Vishwas
|    
|    -----Original Message-----
|    From: Tony Przygienda [mailto:[email-masked]]
|    Sent: Tuesday, May 13, 2003 1:39 AM
|    To: Tony Li
|    Cc: Ruth Civil; [email-masked]
|    Subject: Re: [Isis-wg] Lack of I/E bit in TLV 135
|    
|    
|    Tony Li wrote:
|    
|    >One might use an administrative tag...  this would allow you
|    >to describe more semantics than simply I/E.
|    >  
|    >
|    didn't christian write a while ago
|     a draft on sub-TLV in 135 that carried the external/internal?
|        - tony
|    
|    
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg