Subject: [Isis-wg] clns static routes exporting to is-is

From: Sumesh K P <[email-masked]>
Date: Tue, 6 May 2003 23:54:37 -0500

> Hi All,
> 
> See the topology below.
> 
> + --------+                +----------+               +----------+
>  |    A    | <-----------> |    B     | <----------->|    C     |
> +---------+                +----------+               +----------+
> 
> Case - 1
> -------------
> A is an ES and does not run ES-IS
> B and C are ISs and runs IS-IS in dual-mode.
> Static clnp ES route to A is configured at B.
> Should this ES information be carried in B's ES neighbor TLV ?.
> 
> Case - 2
> -------------
> A is an IS and does not run IS-IS.
> B and C are ISs and runs IS-IS in dual-mode.
> Static clnp IS route to A is configured at B.
> Should this IS information be carried in B's IS neighbor TLV ?.
> 
> Case-3
> -----------
> Is this applicable for IP based information too ?.
> 
> Please reply with CC to [email-masked]. I am temporarily
> unsubscribed from this list due to some "unknown" problem, but Tony knows
> :).
> 
> Thank You,
> Sumesh.
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Jonnala, Nagi" <[email-masked]>
Date: Wed, 7 May 2003 02:41:04 -0400

Sumesh & all, 

My 2 cents. Please correct me if I misinterpret.

>Case - 1

I think you are right. You advertise them in ES neighbor TLV
so that it will be treated as the leaf node.

>Case - 2

You claim that A is an IS. In the topology, though it is not
connected to any other ISs. If that is the case, I think it doesn't
really matter if you advertise it in ES neighbor TLV (or) IS neighbor TLV
because anyway it is a leaf node. 

On contrary, if A is connected to other ISs (hope fully running IS-IS
protocol among them and obviously it has got some LSPs).

In this case, you CAN choose to advertise it in IS neighbor TLV
since it has got some network topology to be considered in SPF.

>Case-3

Since the info. is static, you advertise it in IP external
reachability info. 

Correct me if I'm wrong.

-Nagi.

---

From: "Jonnala, Nagi" <[email-masked]>
Date: Wed, 7 May 2003 03:00:59 -0400

>since it has got some network topology to be considered in SPF.

I'm wrong. You should always advertise it in ES neighbor TLV
but never in IS neighbors TLV. The reason is that it might create
lot of issues if you advertise it in IS neighbor TLV and the link
is down for some reason and you never know it is down since it is
a static route.

Thanks to Vishwas for the offline discussion.

-Nagi.

---

From: Sumesh K P <[email-masked]>
Date: Wed, 7 May 2003 02:13:33 -0500

Hi Nagi et. al,

Thank You very much for the reply. You interpreted the mail right.
Let us take this ring-case, all of them runs IS-IS. A, B and C runs IS-IS on
both the interfaces while the interface of D  connected to C is a passive
interface.
A static route to D is configured at C. In this case should C be advertising
this to B in its IS neighbor TLV or the ES-neighbor TLV ?. I am not sure how
A will be interpreting D received from B's LSP, in case the information is
carried in the ES neighbor TLV.

+-----+        +-----+        
| A   |<------>|  B  |
+-----+        +-----+
  A               A
  |               |
  V               V
+-----+        +-----+        
|  D  |<------>|  C  |
+-----+        +-----+        

Regards,
Sumesh.

Original Message-----
From: Jonnala, Nagi [mailto:[email-masked]]
Sent: Wednesday, May 07, 2003 12:31 PM
To: Jonnala, Nagi; 'Sumesh K P'; [email-masked]
Subject: RE: [Isis-wg] clns static routes exporting to is-is

-Nagi.

---

From: "Jonnala, Nagi" <[email-masked]>
Date: Wed, 7 May 2003 04:05:16 -0400

Sumesh,

The idea behind advertising D in ES neighbor TLV 
in C's LSP is:

1) If anybody wants to reach that particular destination D,
   no problems, you can use this information.

2) If you want to go "through" intermediate station D,
   sorry, you cannot use this information.

Specific answer to your question is below.

Let us assume 'X' is connected to D only.

A interprets that ES neighbor TLV (regarding D) received through B
like this.

I can use this route to end station D(through B) if this path has low cost
than
the direct path to D.

But A will not caluculate any route to X through A-B-C-D-X
because the ES TLV says it is just a leaf node.

Conversely, A can calculate a route to X through A-D-X because
D is a neighbor to A.

-Nagi.

-----Original Message-----
From: Sumesh K P [mailto:[email-masked]]
Sent: Wednesday, May 07, 2003 12:44 PM
To: 'Jonnala, Nagi'; [email-masked]
Subject: RE: [Isis-wg] clns static routes exporting to is-is

Hi Nagi et. al,

+-----+        +-----+        
| A   |<------>|  B  |
+-----+        +-----+
  A               A
  |               |
  V               V
+-----+        +-----+        
|  D  |<------>|  C  |
+-----+        +-----+        

Regards,
Sumesh.

Original Message-----

-Nagi.