Subject: [Isis-wg] an ISIS MIB question

From: "He, James" <[email-masked]>
Date: Wed, 1 Dec 1999 13:03:28 -0500

I have the following MIB questions:

  In isisISAdjTable, isisISAdjNeighborSysType
can have the values: 3(intermediate system), 4(L1 system), 
5(L2 system). Why do you need the value of 3 when there 
are already enumerations used for L1 and L2 systems?

  Also, isisISAdjNeighSysID has a length of 12 octets.
a SystemID has up to 8 octets. Why does this ID
need some extra octets?

  I noticed that isisISAdjIPAddrTable does not have
as much information as isisISAdjTable. Information
such as the type of neighboring systems and 
the type of the adjacencies are not in the IP table.
Is there any way to bridge these two tables?
I am wondering if there is an efficient way of obtaining
all neighbor system information given an IP of the
local system. 

  Which table contains the area address(es) of the local
system, isisISAdjAreaAddrTable or isisManAreaAddrTable?
The isisISAdjAreaAddrTable is indexed on 
isisISAdjAreaAddrSysInstance, isisISAdjAreaAddrCircIndex,
and isisISAdjAreaAddrAdjIndex. What if there are more
than one area addresses for a neighbor? These indices
cannot differentiate multiple addresses from the same
neighbor sent on the same circuit.

Thanks.

James

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 2 Dec 1999 11:46:00 -0500

> are already enumerations used for L1 and L2 systems?

Good question. I'll look at that for the next draft.  

> a SystemID has up to 8 octets. Why does this ID

The extra octets are to store the extended circuitId
as described in DKatz's 3-way handshake draft (see below).  
While that is still just a draft, I cannot cite it directly.

I have placed the systemId first, as that makes more
sense for someone walking the table.   

isisISAdjNeighSysID OBJECT-TYPE
    SYNTAX OCTET STRING (SIZE(0..12))
    MAX-ACCESS read-only
    STATUS current
    DESCRIPTION
        "The system ID and circuit ID of the neighboring
        Intermediate System set from the source ID field
        of the neighbor's IIH PDUs."
    REFERENCE "{ISIS.aoi neighbourSystemIds (83)}"
::= { isisISAdjEntry 7 }

Compare to 

3.1  Syntax

   A new IS-IS Option type, "Point-to-Point Adjacency State", is
   defined:

          Type = 0xF0 (decimal 240)
          Length = 5 to 17 octets
          Value:
            Adjacency State (one octet):
              0 = Up
              1 = Initializing
              2 = Down
            Extended Local Circuit ID (four octets)
            Neighbor System ID if known (zero to eight octets)
            Neighbor Extended Local Circuit ID (four octets, if Neighbor
              System ID is present)

> Is there any way to bridge these two tables?

I've tried to keep them distinct: there may be systems
that run ISIS that do not route IP traffic.  

> system, isisISAdjAreaAddrTable 

Do you have suggestions for any edits that would make it clearer?

"This table contains the set of Area Addresses of
neighboring Intermediate Systems as reported in received IIH PDUs."

> isisManAreaAddrTable?

"The set of manual area addresses configured on this
Intermediate System."

> neighbor sent on the same circuit.

Good point.  Let me mull that over.  

- jdp