Subject: RE: FW: [Isis-wg] FW: JTC 1/SC 6 Liaison Statement on Routeing

From: Les Ginsberg <[email-masked]>
Date: Thu, 7 Sep 2000 15:38:24 -0700

The original intent of the workplan submitted to ISO was a two step process:

1)To provide a revised version of the base ISO 10589 spec that incorporates
the known DRs etc. This is the work that Micah has taken on - for which he
deserves much applause as it involved considerable effort and I am sure not
all of it was fun.

2)Moving forward from the output of Step #1, to incorporate the IP related
extensions so that there was a unified document/set of documents which
accurately reflected the current usage of the protocol given its deployment
in both OSI and IP environments. The need for this is driven by the
evolution of the usage of the protocol in the IP environment and the
(potential) use of IS-IS in dual environments. Also, there is the feeling of
some (myself included) that the current fragmented definition is less than
optimal.

How best to implement Step #2 is a question yet to be answered. Whether to
try to put everything into a single document or provide a set of documents?
How to manage these documents (within IETF, within ISO, liason)?

There are obviously very different approaches to both organizations as far
as document formats, approval processes, participation in the process etc.

The fact that the IETF has been invited into this process is a very good
thing for it means that all the interested parties can easily have a voice
in defining at least the content of what should go into the document(s). How
such documents are to be maintained, while an important issue, I think
should be separated from the more immediate questions of:

  o What set of inputs should be used to create the document(s)?
  o What form should the document(s) take?

I certainly think that RFC 1195, appropriately revised, should be part of
the input set. as well as those extensions that are agreed upon. In addition
to those extensions mentioned by others I would also add the "3-way
handshake" draft as an essential.

   Les

> -----Original Message-----
> From: Micah Bartell [mailto:[email-masked]]
> Sent: Thursday, September 07, 2000 2:57 PM
> To: David Oran; ISIS WG
> Subject: Re: FW: [Isis-wg] FW: JTC 1/SC 6 Liaison Statement 
> on Routeing
> 
> 
> Folks,
> 
> I will say that the only documents that I integrated into the 
> ISO 10589 2nd edition were those specified in the 
> "Instructions" from the ISO meeting in Prague.  The changes 
> consist of the following documents:
> 
> ISO/IEC 10589:1992/Cor.1:1993
> ISO/IEC 10589:1992/Cor.2:1996
> ISO/IEC 10589:1992/Cor.3:1996
> ISO/IEC 10589:1992/Amd 1:1996
> 6N10323 - Defect Reports 7-26
> 6N10659 - Defect Reports 27-34
> 6N10733 - Technical Corrigendum 4
> The editor will also apply the minimal changes necessary to resolve
> additional Defect Reports 35-44.
> 
> Regarding the changes proposed for DR 35-44, the SIF 
> recommendation was used in place of these DRs.
> 
> Nothing IP specific was added to ISO 10589.  The question 
> that the ISO is presenting here to the IETF as I understand it is: 
> 
> What does the IETF recommend as the best method moving 
> forward to handle changes to the ISO spec by the IETF and how 
> best should the IP specific information be handled?
> 
> 
> The ISO world does not seem intent upon making great sweeping 
> changes to the spec, to the best of my knowledge and most new 
> work is being handled within the IETF.
> 
> I think it would be wise to develop a method for dealing with 
> all IETF changes before setting the precedent of integrating 
> ANY of the IETF ID's or RFC's directly into the spec.  That 
> document is already getting unwieldly in Word and if it is 
> going to be accepting another 100 pages of material, it will 
> very likely need to be restructured.
> 
> The question of whether the ISO wishes to continue to 
> maintain this spec also needs to be asked.  If not, it may be 
> possible to publish the ISO 10589 as a standards track RFC.  
> This would likely require some modification to the structure 
> of the document.  ( Does an RFC really need 30 pages of 
> complex conformance tables? )  Also the ISO 10589 spec is not 
> friendly to a purely text based representation.
> 
> These are just some of my thoughts on the matter.  While, I 
> am the current editor for the document, I am not presenting 
> these suggestions as a "representative" of the ISO, or 
> stating this to be their official position.
> 
> I will investigate further making available the PDF version 
> that I have of the 2nd Edition.  This is pending a response from ANSI.
> 
> /mpb
> 
> 
> At 04:23 PM 9/7/2000 -0400, David Oran wrote:
> >Copying the WG...
> >
> >-----Original Message-----
> >From: Henk Smit [mailto:[email-masked]]
> >Sent: Thursday, September 07, 2000 3:50 PM
> >To: David Oran
> >Subject: Re: [Isis-wg] FW: JTC 1/SC 6 Liaison Statement on Routeing
> >
> >
> >
> > > For those of you who hate MSWORD, I append the text at 
> the end of the
> > > message text as well.
> >
> >   Thank you, I appreciate it !
> >  Pretty weird that a standards body like ISO is using a proprietary
> >  files format. ;-)
> >
> > > Are there other drafts they should fold it? If so, please craft a
> > > response and I'll get it to them.
> >
> >   draft-ietf-isis-dyname-02.txt is not a draft anymore.
> >  It is now an RFC: RFC2763.
> >
> >   I have just submitted a new version of 
> draft-ietf-isis-traffic-01.txt,
> >  draft-ietf-isis-traffic-02.txt. It might be a while before 
> it becomes
> >  an RFC.
> >
> >   And what about RFC1195 itself ? There is no mention that this RFC
> >  will be incorporated ?
> >
> >   If RFC1195 is incorporated, there is one more ISIS draft 
> that I would
> >  like to see added. Tony Li, Tony Prziegynda and myself are 
> also authors
> >  of a draft that is related. 
> draft-ietf-isis-domain-wide-02.txt. It is
> >  slated to be an RFC pretty soon, just waiting for the RFC editor to
> >  process it. If 10589 is including IP specific stuff, I 
> think this one
> >  should be incorporated too.
> >
> >     Henk.
> >
> >
> >
> > > -----Original Message-----
> > > From: Matthew Deane [mailto:[email-masked]]
> > > Sent: Thursday, September 07, 2000 11:35 AM
> > > To: [email-masked]'; [email-masked]'; [email-masked]';
> > > [email-masked]'
> > > Cc: 'Jim Long (SC 6/WG 7 Convenor)'; 'Jooran Lee'
> > > Subject: JTC 1/SC 6 Liaison Statement on Routeing
> > >
> > >
> > > > Dear IETF Directors,
> > > >
> > > > Per ISO/IEC JTC 1/SC 6 Prague Plenary Resolution 6.7.7, the
> >following
> > > > document is forwarded to IETF Routeing and Transport 
> Area Directors
> > > for
> > > > consideration:
> > > >
> > > > SC 6 N 11618, Liaison Statement to IETF on ISO/IEC CD 10589 (2nd
> > > version)
> > > >
> > > >
> > > > Please do not hesitate to contact me should you have 
> any questions.
> > > >
> > > > Sincerely,
> > > >
> > > > Matt Deane
> > > > JTC 1/SC 6 Secretariat
> > > >
> > > >  <<06n1618.rtf>>
> > >
> > >
> > >                                                           
>             SC 6 N 11618
> > >
> > > Title: Liaison Report to the IETF Routing Area Director 
> on 2nd CD for
> > > ISO/IEC 10589 (IS-IS Routing)
> > >
> > > Source: ISO/IEC JTC1/SC6
> > >
> > > ISO/IEC JTC1/SC6 WG7 is currently creating a new base text for
> >ISO10589.
> > > SC6 intends to use this new version 2 as the base for adding the
> > > enhancements which have been requested by the IETF to 
> optimise the use
> > > of ISO 10589 for Internet routing solutions.  The IETF IS-IS WG
> >convenor
> > > originally identified  Internet Drafts:
> ><draft-ietf-isis-dyname-02.txt>
> > > and <draft-ietf-isis-traffic-01.txt> as the source documents which
> > > specify these enhancements.   SC6 invites the IETF to 
> confirm that the
> > > above Internet Drafts are the correct references and to 
> inform SC6 if
> > > there are additional IETF documents which refer to any other
> > > requirements for  IS-IS Routing enhancements.
> > >
> > >  SC6 would like to interact with the IETF on clarifying 
> the detailed
> > > requirements in the hope that it may be possible to  
> introduce them
> > > during the editing cycle for version 2 of the standard.   
> To this end,
> > > we would like the Routing Area Directors to arrange an 
> IS-IS BOF at
> >the
> > > San Diego IETF meeting to discuss these requirements and 
> how they can
> >be
> > > incorporated into the new version of  ISO 10586.
> > >
> > >  SC6 will post an initial draft version of the new base 
> document as an
> > > Internet Draft in August 2000 but this will not contain 
> the changes
> > > requested by the IETF.  A ballot closure date of February 2001 has
> >been
> > > set for the 2nd CD Ballot to allow incorporation of final 
> input on the
> > > Internet requirements if they can be agreed at the 
> December 2000 IETF
> > > meeting.
> > >
> > > For information, the current instructions to the editor 
> are that he
> > > should use ISO/IEC 10589:1992 as a base for editing, and 
> shall apply
> >the
> > > minimum textual changes mandated by the following TCs and DRs:
> > >
> > >    ISO/IEC 10589:1992/Cor.1:1993
> > >    ISO/IEC 10589:1992/Cor.2:1996
> > >    ISO/IEC 10589:1992/Cor.3:1996
> > >    ISO/IEC 10589:1992/Amd 1:1996
> > >    6N10323 - Defect Reports 7-26
> > >    6N10659 - Defect Reports 27-34
> > >    6N10733 - Technical Corrigendum 4
> > >    The editor will also apply the minimal changes 
> necessary to resolve
> > > additional Defect Reports 35-44.
> > >
> > > If SC6 and the IETF are unable to resolve the required 
> changes, the
> > > Editor will add a temporary note to the cover page and the scope
> >clause
> > > stating that:  " ISO 10589 does not currently include the 
> extensions
> > > originally requested by the IETF in Internet Drafts:
> > > <draft-ietf-isis-dyname-02.txt> and 
> <draft-ietf-isis-traffic-01.txt>.
> > > National Body and Liaison organization comments are 
> invited to comment
> > > on the best way to progress these extensions."
> > >

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Jude V. Ballard" <[email-masked]>
Date: Fri, 8 Sep 2000 21:06:38 -0600 (MDT)

Speaking as someone who is in the early stages of experience with this
protocol, I would love to see this as a set of documents managed by the
IETF.  If for no other reason than to have a unified source, and format 
for the information.  (I find the ISO format to be a bit unwieldy, but
that is an opinion and not very relevant)

It may also lead to development of protocol analysis, and "experience
with"  docs (additional benifits to the internet community.)  

I would be more than willing to volunteer my time in order to help
complete this work.  (Although the majority of you are probably more
qualified.)

-Jude