Subject: [ITU+IETF] RE: [Enum] Re: Structure of DNS entry for ENUM

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 4 Feb 2000 11:36:16 -0500

Randy Bush [mailto:[email-masked]] wrote:

> > However, it's not clear to me why the fields of the E.164 
> number which are
> > clearly delineated, such as country code and city/area 
> code, could not at
> > least have been kept together, delimited by dots. The long 
> series of dots
> > seems a bit excessive?
> 
> because only north americans think country codes and city 
> codes are clearly
> delineatable in a universal way?

Not so. That's what I tried to point out using the European number example.

And if some E.164 number in the future becomes hierarched(??), you can
always add in dots. The result will never be ambiguous.

Bert
[email-masked]

_______________________________________________
ITU+IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/itu+ietf

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 04 Feb 2000 11:55:39 -0500

> always add in dots. The result will never be ambiguous.

This is unworkable, IMHO. It requires the clients of the system to have
knowledge of the numbering plan for every single country. The
dot-between-each-digit moves this knowledge into the DNS zone
delegations, which is where it belongs.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com