Subject: RE: [ITU+IETF] RE: [Enum] Re: Structure of DNS entry for ENUM

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 4 Feb 2000 13:06:42 -0500

Randy Bush [mailto:[email-masked]] wrote

> a friend pointed out that i could have been less terse. :-)
> 
> the first problem is that it would be exceedingly unlikely 
> that dns protocol
> folk would be at all sympathetic with special hacks for some 
> specific domain
> as there would soon be 1,000 specific donains that wanted 
> special treatment.
> 
> but this does not even work for the one domain.  it directly 
> implies that
> the entire domain for all of planet earth is flat and in a 
> single zone file.
> this is the opposite of 'rational' as used in internet design.

Fair enough.

The point is, when you dial an international number, you the client in fact
know full well that there is a country code (at very least). So _that_ much
can be delimeted by a dot without undue hardship. All countries also use a
city/area code of some kind. It's not too much to ask to delimit that as
well.

What I think is truly "unworkable" (a favorite word here) is the current
plan, which requires every normal human to write down the phone number on a
piece of paper before being able to type it in, in reverse order, with all
the dots.

Business cards show international phone numbers with some semblance of
hierarchy. Country code alone might be enough?

Bert
[email-masked]

_______________________________________________
ITU+IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/itu+ietf

---

From: Randy Bush <[email-masked]>
Date: Fri, 04 Feb 2000 10:09:58 -0800

> piece of paper before being able to type it in, in reverse order, with all

nope.  as the rule is exceedingly simple, 
  o have full country+city+local number
  o reverse the order of the digits
  o put a dot between each one
  o append .foo.bar
clients can do it simply, coded once, and work universally.

this same hack has worked for tpc.int for many years.

randy

---

From: Keith Moore <[email-masked]>
Date: Fri, 04 Feb 2000 13:17:21 -0500

> know full well that there is a country code (at very least).

no.  you don't even know that.  

you just dial the international prefix followed by the digits that are 
on someone's business card.

or, soon, you click on a tel: URL link and the dialing gets done for you. 

except for some knowledge of local prefix rules,
users don't have to know the structure of phone numbers in order to use them.
that's a feature, not a bug.

Keith

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 04 Feb 2000 13:29:43 -0500

> piece of paper before being able to type it in, in reverse order, with all

Wrong. The human user doesn't do this unless the UI on your
phone/software is really bad. Most likely you'll enter the number, hit
return, and the host will perform this translation. As Randy pointed
out, its been going on for a while now...

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com