Subject: [jose] Feedback request on jose tracker issue #12: Should the x5c field be removed from JWE?, ,

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 11 Apr 2013 19:59:20 -0400

Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 
<http://trac.tools.ietf.org/wg/jose/trac/ticket/12> suggests removing 
the "x5c" header parameter from JWE, saying that no use case for it has 
emerged.  The same logic may apply to other key specification parameters 
for JWE.

Which of these best describes your preferences on this issue?

1.  Retain the "x5c" header parameter in JWE.

2. Remove the "x5c" header parameter (and possibly other related key 
specification parameters) from JWE.

3.  Another resolution (please specify in detail).

0.  I need more information to decide.

Your reply is requested by Friday, April 19^th or earlier.

---

From: <[email-masked]>
Date: Fri, 12 Apr 2013 08:32:10 +0200

1

x5c is the most explicit way to describe which private key is the right one. It is an alternative to kid which is another reason why  kid must not be mandatory.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Friday, April 12, 2013 1:59 AM
To: [email-masked]
Subject: [jose] Feedback request on jose tracker issue #12: Should the x5c field be removed from JWE?, ,

Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 suggests removing the "x5c" header parameter from JWE, saying that no use case for it has emerged.  The same logic may apply to other key specification parameters for JWE.

2.  Remove the "x5c" header parameter (and possibly other related key specification parameters) from JWE.

Your reply is requested by Friday, April 19th or earlier.

---

From: Roland Hedberg <[email-masked]>
Date: Sat, 13 Apr 2013 21:20:22 +0200

1

12 apr 2013 kl. 01:59 skrev Karen O'Donoghue <[email-masked]>:

> Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 suggests removing the “x5c” header parameter from JWE, saying that no use case for it has emerged.  The same logic may apply to other key specification parameters for JWE.
> 
> 
> 1.  Retain the “x5c” header parameter in JWE.
> 
> 2.  Remove the “x5c” header parameter (and possibly other related key specification parameters) from JWE.
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Roland Hedberg <[email-masked]>
Date: Sat, 13 Apr 2013 21:22:08 +0200

+1

---

From: hideki nara <[email-masked]>
Date: Mon, 15 Apr 2013 16:02:43 +0900

1

2013/4/12 Karen O'Donoghue <[email-masked]>

>  Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 suggests
> removing the “x5c” header parameter from JWE, saying that no use case for
> it has emerged.  The same logic may apply to other key specification
> parameters for JWE.****
>
> **
> **
>
> Which of these best describes your preferences on this issue?****
>
> 1.  Retain the “x5c” header parameter in JWE.****
>
> 2.  Remove the “x5c” header parameter (and possibly other related key
> specification parameters) from JWE.****
>
> 3.  Another resolution (please specify in detail).****
>
> 0.  I need more information to decide.****
>
> ** **

---

From: Mike Jones <[email-masked]>
Date: Mon, 15 Apr 2013 15:22:44 +0000

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roland Hedberg
Sent: Saturday, April 13, 2013 12:22 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [jose] Feedback request on jose tracker issue #12: Should the x5c field be removed from JWE?, , 

+1

1

---

From: Richard Barnes <[email-masked]>
Date: Mon, 15 Apr 2013 11:29:06 -0400

Count me as "don't really care", modulo ISSUE-15.

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 15 Apr 2013 16:44:39 +0000

1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roland Hedberg
Sent: Saturday, April 13, 2013 12:22 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [jose] Feedback request on jose tracker issue #12: Should the x5c field be removed from JWE?, , 

+1

1

---

From: nov matake <[email-masked]>
Date: Tue, 16 Apr 2013 01:41:19 +0900

I don't care too.

nov

On Apr 16, 2013, at 12:29 AM, Richard Barnes <[email-masked]> wrote:

> On Thu, Apr 11, 2013 at 7:59 PM, Karen O'Donoghue <[email-masked]> wrote:

---

From: Matias Woloski <[email-masked]>
Date: Mon, 15 Apr 2013 14:07:28 -0300

1.

In some cases, it is simpler for me to just put the whole base64 public
key. For instance, in some platforms is not straightforward to parse an
X509 cert and extract the serial number, hence being able to send the
public key blob there, makes it easier for interop.

On Mon, Apr 15, 2013 at 1:44 PM, Anthony Nadalin <[email-masked]>wrote:

> x5c is the most explicit way to describe which private key is the right
> one. It is an alternative to kid which is another reason why  kid must not
> be mandatory.
>
> removing the "x5c" header parameter from JWE, saying that no use case for
> parameters for JWE.

---

From: Edmund Jay <[email-masked]>
Date: Mon, 15 Apr 2013 11:05:23 -0700 (PDT)

1

________________________________
From: Karen O'Donoghue <[email-masked]>
To: [email-masked]
Sent: Thu, April 11, 2013 4:59:32 PM
Subject: [jose] Feedback request on jose tracker issue #12: Should the x5c field 
be removed from JWE?, , 

Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 suggests     
removing the “x5c” header parameter from JWE, saying that no use     case for it 
has emerged.  The same logic may apply to other key     specification parameters 
for JWE.

---

From: Matt Miller <[email-masked]>
Date: Tue, 16 Apr 2013 09:57:11 -0600

I have a slight preference for (2), assuming JWE retains the "kid" parameter.  I personally would rather limit key indication to a JWK (and wrapping "x5c" in a JWK), or a reference to a JWK ("kid", and maybe "jku").

- m&m

Matt Miller < [email-masked] >
Cisco Systems, Inc.

On Apr 11, 2013, at 5:59 PM, Karen O'Donoghue <[email-masked]> wrote:

> Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 <http://trac.tools.ietf.org/wg/jose/trac/ticket/12> suggests removing the "x5c" header parameter from JWE, saying that no use case for it has emerged.  The same logic may apply to other key specification parameters for JWE.
> 
>

---

From: Richard Barnes <[email-masked]>
Date: Tue, 16 Apr 2013 12:48:29 -0400

That limitation seems very sensible to me.  It would be a large
simplification over current JWE, with its abundance of key identifiers.
--Richard

On Tue, Apr 16, 2013 at 11:57 AM, Matt Miller <[email-masked]> wrote:

> I have a slight preference for (2), assuming JWE retains the "kid"
> parameter.  I personally would rather limit key indication to a JWK (and
> wrapping "x5c" in a JWK), or a reference to a JWK ("kid", and maybe "jku").
>
>
> - m&m
>
> > Issue #12 http://trac.tools.ietf.org/wg/jose/trac/ticket/12 <
> http://trac.tools.ietf.org/wg/jose/trac/ticket/12> suggests removing the
> "x5c" header parameter from JWE, saying that no use case for it has

---

From: Justin Richer <[email-masked]>
Date: Tue, 16 Apr 2013 12:55:49 -0400

I also like this approach.

  -- Justin

On 04/16/2013 12:48 PM, Richard Barnes wrote:
> On Tue, Apr 16, 2013 at 11:57 AM, Matt Miller <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     parameter.  I personally would rather limit key indication to a
>     JWK (and wrapping "x5c" in a JWK), or a reference to a JWK ("kid",
>     and maybe "jku").
>
>
>     - m&m
>
>     Matt Miller < [email-masked] <mailto:[email-masked]> >
>     Cisco Systems, Inc.
>
>     On Apr 11, 2013, at 5:59 PM, Karen O'Donoghue <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>     <http://trac.tools.ietf.org/wg/jose/trac/ticket/12> suggests
>     removing the "x5c" header parameter from JWE, saying that no use
>     case for it has emerged.  The same logic may apply to other key
>     specification parameters for JWE.
>     >
>     >
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Richard Barnes <[email-masked]>
Date: Tue, 16 Apr 2013 13:03:38 -0400

So, just so we're clear on what we're talking about, the proposal would be
something like the following?

1. Have one/two fields in JWE/JWS that can hold a reference a [JW]Key,
namely "kid" and/or "jku"
2. Move the other key labeling fields under JWK, namely "x5u", "x5t", "x5c"
3. Keep the "jwk" field in JWE/JWS to contains the JWK, possibly with
identifiers from (2)

For that matter, I would be OK moving "kid" inside the JWE/JWS "jwk"
parameter as well, and just having a "jwk" element at the top level.

On Tue, Apr 16, 2013 at 12:55 PM, Justin Richer <[email-masked]> wrote:

> jose mailing [email-masked]://www.ietf.org/mailman/listinfo/jose
>
>
>

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 17 Apr 2013 14:40:04 +0200

Hi,

1. Retain the “x5c” header
parameter in JWE.

Br,

Charles Marais.

Le 12/04/2013 01:59, Karen O'Donoghue a
écrit :

Issue #12
http://trac.tools.ietf.org/wg/jose/trac/ticket/12 suggests
removing the “x5c” header parameter from JWE, saying that no use
case for it has emerged.  The same logic may apply to other key
specification parameters for JWE.

Which of these best
describes your preferences on this issue?

1.  Retain the “x5c”

header parameter in JWE.

2.  Remove the “x5c”

header parameter (and possibly other related key specification
parameters) from JWE.

3.  Another
resolution (please specify in detail).

0.  I need more
information to decide.

Your reply is requested by Friday, April
19th or earlier.

--

MARAIS Charles

FT/OLNC/OLPS/ASE/IDEA/UED

Tel : 02.96.05.24.18

[email-masked]

WF004Bis / R&D Lannion / 2, avenue Pierre Marzin / 22307
LANNION Cedex - France

---

From: Javier Rojas Blum <[email-masked]>
Date: Thu, 18 Apr 2013 23:26:05 -0400

2

But keeping the "kid" header param

On 04/17/2013 08:40 AM, [email-masked] wrote:
> Le 12/04/2013 01:59, Karen O'Donoghue a écrit :
>> the "x5c" header parameter from JWE, saying that no use case for it 
>> has emerged.  The same logic may apply to other key specification 
>> parameters for JWE.
>>
>>
> *MARAIS Charles*
> *FT/OLNC/OLPS/ASE/IDEA/UED *
> Tel : 02.96.05.24.18
> [email-masked] <mailto:[email-masked]>
> WF004Bis / R&D Lannion / 2, avenue Pierre Marzin / 22307 LANNION Cedex 
> - France
>
>
>
>
>

---

From: Nat Sakimura <[email-masked]>
Date: Sat, 20 Apr 2013 01:36:46 +0900

+1

2013/4/12  <[email-masked]>:
> 1
>
>
>
> x5c is the most explicit way to describe which private key is the right one.
> It is an alternative to kid which is another reason why  kid must not be
> mandatory.
>
>
>

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en