Subject: [jose] JOSE and JWT specs incorporating decisions from IETF 86

From: Mike Jones <[email-masked]>
Date: Wed, 24 Apr 2013 02:06:47 +0000

New versions of the JSON Object Signing and Encryption (JOSE) specifications JSON Web Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), and JSON Web Algorithms (JWA) and the JSON Web Token (JWT) specification have been released that incorporate the working group decisions made during and since IETF 86<http://www.ietf.org/meeting/86/>.

The primary new features in these working group drafts are:

*        adding support for private and symmetric keys to JWK and JWA,

*        adding support for JSON Serializations to JWS and JWE,

*        replacing the custom JOSE CBC+HMAC algorithms with ones compatible with those proposed in draft-mcgrew-aead-aes-cbc-hmac-sha2<http://tools.ietf.org/html/draft-mcgrew-aead-aes-cbc-hmac-sha2-01>,

*        defining that the default action for header parameters and claims that are not understood is to ignore them, while providing a way to designate that some extension header parameters must be understood.

More details on the changes made can be found in the Document History entries.

The specifications are available at:

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-09

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-09

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-key-09

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-09

*        http://tools.ietf.org/html/draft-ietf-oauth-json-web-token-07

HTML formatted versions are also available at:

*        http://self-issued.info/docs/draft-ietf-jose-json-web-signature-09.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-encryption-09.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-key-09.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-algorithms-09.html

*        http://self-issued.info/docs/draft-ietf-oauth-json-web-token-07.html

                                                            -- Mike

P.S.  This notice has also been posted at http://self-issued.info/?p=1008.

---

From: Nichole Richardson <[email-masked]>
Date: Wed, 24 Apr 2013 13:10:35 -0700

Auto-generated message: Nichole Richardson has left this conversation and will
no longer see your messages

On April 23, 2013 7:06:47 PM PDT, Mike Jones wrote:
> *        http://self-issued.info/docs/draft-ietf-jose-json-web-signature-09..html
> 
> P.S.  This notice has also been posted at http://self-issued.info/?p=1008..
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth