Subject: Re: [jose] Feedback request on jose tracker issue#11: Should we use RFC 5116 and remove the JWE Integrity Value field?

From: Russ Housley <[email-masked]>
Date: Fri, 19 Apr 2013 14:25:10 -0400

2.  Switch to using the RFC 5116 (AEAD) serialization ...

And, when using a mode like CBC, simply prepend the IV to the ciphertext.

Russ

= = = = = = = = = 

Which of these best describes your preferences on this issue?
1.  Continue having separate Ciphertext, Initialization Vector, and
Integrity Value values in the JWE representation.
2.  Switch to using the RFC 5116 (AEAD) serialization to represent the
combination of these three values.
3.  Another resolution (please specify in detail).
0.  I need more information to decide.

---

From: Richard Barnes <[email-masked]>
Date: Fri, 19 Apr 2013 14:46:44 -0400

IV should not be at issue here.  RFC 5116 doesn't do anything with IVs, and
all libraries I know of have a separate IV and cipher text fields.  So we
let's keep those separate.

On Fri, Apr 19, 2013 at 2:25 PM, Russ Housley <[email-masked]> wrote:

> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>