Subject: [jose] validation of the crypto examples in the jose specifications

From: Antonio Sanso <[email-masked]>
Date: Thu, 3 Apr 2014 15:30:50 +0000

hi *,

since release version 1.0 Apache Oltu started some support of the jose specifications (JWT, JWS) for now.
We plan to extend the support to all the other specifications JWE, etc..
It would  make sense to use the example contained in the specifications in the unit and integration tests and this is already the case.
E.g. if you see unit test [1] contains already tests that validates the examples from the JWS specification [2] and the jose cook book [3].

As said we are planning to extend those coverage to all the jose examples.

regards

antonio

[0] https://oltu.apache.org/
[1] https://github.com/apache/oltu/blob/trunk/jose/jws/src/test/java/org/apache/oltu/jose/jws/signature/impl/SignatureMethodRSAImplTest.java
[2] http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-25#appendix-A.2
[3] http://tools.ietf.org/html/draft-ietf-jose-cookbook-01#section-3.1

---

From: Mike Jones <[email-masked]>
Date: Thu, 3 Apr 2014 18:49:34 +0000

Yes, it makes sense to use the examples in unit and integration tests - both from the JWS, JWE, JWK, and JWA specs - and from the cookbook.  It would be great to have confirmation that your code reproduces those results.

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Antonio Sanso
Sent: Thursday, April 03, 2014 8:31 AM
To: [email-masked]
Subject: [jose] validation of the crypto examples in the jose specifications

hi *,

regards

antonio

---

From: Antonio Sanso <[email-masked]>
Date: Fri, 4 Apr 2014 13:59:40 +0000

Thanks Mike,

On Apr 3, 2014, at 8:49 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

Yes, it makes sense to use the examples in unit and integration tests – both from the JWS, JWE, JWK, and JWA specs – and from the cookbook.  It would be great to have confirmation that your code reproduces those results.

nice. As said we already started with JWS and we will hopefully cover all the examples. I will keep the list posted once we completed the validation.

regards

antonio

                                                            -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Antonio Sanso
Sent: Thursday, April 03, 2014 8:31 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] validation of the crypto examples in the jose specifications

hi *,

regards

antonio

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose