Subject: [jose] RFC 7165 on Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)

From: [email-masked]
Date: Mon, 14 Apr 2014 21:58:18 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 7165

        Title:      Use Cases and Requirements for 
                    JSON Object Signing and Encryption (JOSE) 
        Author:     R. Barnes
        Status:     Informational
        Stream:     IETF
        Date:       April 2014
        Mailbox:    [email-masked]
        Pages:      25
        Characters: 58324
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-jose-use-cases-06.txt

        URL:        http://www.rfc-editor.org/rfc/rfc7165.txt

Many Internet applications have a need for object-based security
mechanisms in addition to security mechanisms at the network layer or
transport layer.  For many years, the Cryptographic Message Syntax
(CMS) has provided a binary secure object format based on ASN.1.
Over time, binary object encodings such as ASN.1 have become less
common than text-based encodings, such as the JavaScript Object
Notation (JSON).  This document defines a set of use cases and
requirements for a secure object format encoded using JSON, drawn
from a variety of application security mechanisms currently in
development.

This document is a product of the Javascript Object Signing and Encryption Working Group of the IETF.

INFORMATIONAL: This memo provides information for the Internet community.
It does not specify an Internet standard of any kind. Distribution of
this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/search
For downloading RFCs, see http://www.rfc-editor.org/rfc.html

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: Mike Jones <[email-masked]>
Date: Tue, 15 Apr 2014 21:01:18 +0000

Congratulations on fishing this, Richard!

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, April 14, 2014 9:58 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [jose] RFC 7165 on Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)

        RFC 7165

Many Internet applications have a need for object-based security mechanisms in addition to security mechanisms at the network layer or transport layer.  For many years, the Cryptographic Message Syntax
(CMS) has provided a binary secure object format based on ASN.1.
Over time, binary object encodings such as ASN.1 have become less common than text-based encodings, such as the JavaScript Object Notation (JSON).  This document defines a set of use cases and requirements for a secure object format encoded using JSON, drawn from a variety of application security mechanisms currently in development.

INFORMATIONAL: This memo provides information for the Internet community.
It does not specify an Internet standard of any kind. Distribution of this memo is unlimited.

For searching the RFC series, see http://www.rfc-editor.org/search For downloading RFCs, see http://www.rfc-editor.org/rfc.html

Requests for special distribution should be addressed to either the author of the RFC in question, or to [email-masked].  Unless specifically noted otherwise on the RFC itself, all RFCs are for unlimited distribution.

The RFC Editor Team

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Richard Barnes <[email-masked]>
Date: Tue, 15 Apr 2014 17:16:37 -0400

Thanks!

On Tue, Apr 15, 2014 at 5:01 PM, Mike Jones <[email-masked]>wrote:

> Over time, binary object encodings such as ASN.1 have become less common
> than text-based encodings, such as the JavaScript Object Notation (JSON).
>  This document defines a set of use cases and requirements for a secure
> object format encoded using JSON, drawn from a variety of application
> security mechanisms currently in development.
>
> For searching the RFC series, see http://www.rfc-editor.org/search For
> downloading RFCs, see http://www.rfc-editor.org/rfc.html
>
> Requests for special distribution should be addressed to either the author
> of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for unlimited
> distribution.
>
>
> The RFC Editor Team

---

From: John Bradley <[email-masked]>
Date: Tue, 15 Apr 2014 19:24:30 -0300

Yes congratulations.