Subject: [jose] RFC 8037 "alg" quirkiness

From: Anders Rundgren <[email-masked]>
Date: Sun, 30 Aug 2020 08:57:53 +0200

I have just implemented support for Edwards curves in my JSON library.

Although it is certainly not a deal-breaker I find the use of "EdDSA" as a generic Edwards algorithm identifier rather quirky since it departs from the other JWS algorithms:
https://tools.ietf.org/html/rfc8037#appendix-A.4

For curiosity reasons I took a peek at the initial draft which has (in my opinion...) a more logical solution:
https://tools.ietf.org/html/draft-liusvaara-jose-cfrg-curves-00#appendix-A.4

May I ask why this change was performed?

For JSF (JSON Signature Format) I will stick to the "00" scheme which also permits use of ed25519ph and friends if needed:
https://mobilepki.org/jsf-lab/home

thanx,
Anders

---

From: Neil Madden <[email-masked]>
Date: Sun, 30 Aug 2020 08:10:17 +0100

8037 was done by CFRG, so probably best to ask there. 

I like this aspect of the spec. IMO “alg” as a header was a mistake. By using a generic algorithm header, it forces implementors to associate the specific details in metadata stored with the key, which is much safer. 

Neil

> On 30 Aug 2020, at 07:58, Anders Rundgren <[email-masked]> wrote:
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose