Subject: Add PRF_READY flag (similar to PROT_READY) for PRF?

From: Simon Josefsson <[email-masked]>
Date: Mon, 08 Nov 2004 20:33:12 +0100

Would it make sense to add a new GSS_Init_sec_context flag PRF_READY
to make it possible to use the PRF function earlier?  The flag would
be similar to PROT_READY.  Alternatively, overload the PROT_READY flag
to mean that the PRF function is ready too?

Just an idea,
Simon

_______________________________________________
Kitten mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/kitten

---

From: Nicolas Williams <[email-masked]>
Date: Tue, 9 Nov 2004 17:32:40 -0600

> to mean that the PRF function is ready too?

I thought about this and decided against it on the KISS principle.  Of
course, the EAP folks may disagree.  I suppose I should as them...  I
will.

Nico
--

---

From: "Joseph Salowey" <[email-masked]>
Date: Tue, 9 Nov 2004 22:14:54 -0800

I'm jumping in the middle of the conversation, but I don't see what EAP
would require to know this early. 

Joe

[email-masked] wrote:
>> be similar to PROT_READY.  Alternatively, overload the PROT_READY
>> flag to mean that the PRF function is ready too?
> 
> I thought about this and decided against it on the KISS
> principle.  Of course, the EAP folks may disagree.  I suppose
> I should as them...  I will.
> 
> Nico