Subject: RE: RC4-HMAC

From: "John Brezak" <[email-masked]>
Date: Mon, 4 Dec 2000 17:58:37 -0800

inline

> -----Original Message-----
> From: Ken Raeburn [mailto:[email-masked]]
> Sent: Monday, December 04, 2000 5:45 PM
> To: [email-masked]
> Subject: Re: RC4-HMAC
> 
> 
> "John Brezak" <[email-masked]> writes:
> 
> > A few clarifications:
> > - The initial intent of the RC4-HMAC I-D was to publish it as
> > informational for those folks that want to interoperate 
> with Win2000.
> > - KD values and the assigned values represent the 
> "experimental" nature
> > of the protocol and lessons learned during implementation 
> (bugs if you
> > will).
> > 
> > If this is to proceed on a standards track, then these 
> issues should be
> > cleaned up, however the informational nature of the I-D is 
> still very
> > relevant to at least the win2000 implementation.
> 
> Sure.  The main thing is, is it to be an Informational RFC or
> standards-track?  If it's informational, then it should describe what
> Win2000 is doing well enough to make an interoperable implementation.
> If it's standards track, it should conform to the Kerberos spec or
> give a good reason why it the divergence was necessary.  (IMO, of
> course.)
> 
> Jeff Schiller suggested that I go with Informational for the 3DES
> GSSAPI spec, because eventually we ought to go with a new mechanism
> that better utilizes the existing Kerberos messages and encryption
> scheme definitions rather than re-inventing them.  The 3DES extensions
> are not intended to be what we want everyone to settle on, just an
> intermediate measure for better security in the short term.

[JBrezak] This was the purpose to discuss it at the WG. If there was
sufficient interest
to make RC4-HMAC a standards-track RFC or just informational.
Conformance to the other KD table would be nice, but it may be very
expensive to achive. The mapping table was something the Microsoft devs
are considering for the 3DES work.

> 
> > Heimdal has implemented the RC4-HMAC enctype and a few 
> others that are
> > not public. The latest posting reflects changes pointed out during
> > implementations from the earlier versions.
> 
> Just to be clear: Heimdal's implemented the -02 version then?

[JBrezak] That is my understanding - Assar?

> Ken

---

From: Assar Westerlund <[email-masked]>
Date: 07 Dec 2000 23:27:54 +0100

> [JBrezak] That is my understanding - Assar?

Sorry for taking some time to answer.  No, my current code implements
the -03 version that I got from John.

/assar

---

From: Assar Westerlund <[email-masked]>
Date: 07 Dec 2000 23:35:13 +0100

> the -03 version that I got from John.

Lemme try not add more to the confusion here.

I did implement it from the text that I got from John.  This text was
labeled '03' and I got that from John before Novemember.  But that
text is (except for mark-up and formatting) identical to the
draft-brezak-win2k-krb-rc4-mhac-02.txt internet-draft.

/assar