Subject: Re: Questions on Section 5.2 and 7.1

From: Jeffrey Altman <[email-masked]>
Date: Fri, 4 Oct 2002 15:42:46 EDT

REALM names that are not DNS compatible names cannot be looked up via
DNS.  We altered the title of the section to restrict the description
to DNS style realms.

> 
> Maybe I am missing something here. 
> 
> Section 5.2 spend a lot of time describing the misuse of the GeneralString
> and how some vendors have used unescaped UTF-8 etc. 
> 
> Section 7.1 then describes the realm name, as thorough it is IA5string only.
> But what then happens to those realms names which are not IA5string? 
> I am assuming they need to be a realm type of other. 
> 
> The TransitedEncoding has tr-type and only one type is defined, 
> DOMAIN-X500-COMPRESS. This would imply that "other" names can not
> be added to the Transited field. 
> 
> When we get to PKCROSS, and the CA name is going to be treated like a realm,
> or needs to be added to the transited field, will we have problems trying 
> to get it into the transited field? 
> Will we need another tr-type to include DOMAIN, X500 and other? 
> I am assuming we will have to address some of these issues with extensions. 
> 
> Do we need a statement in Clarifications, that transited cross realm
> is defined only with domain and X500 style realm names? Or is it already there?
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> -- 
> 
>  Douglas E. Engert  <[email-masked]>
>  Argonne National Laboratory
>  9700 South Cass Avenue
>  Argonne, Illinois  60439 
>  (630) 252-5444
> 

 Jeffrey Altman * Sr.Software Designer     Kermit 95 2.0 GUI available now!!!
 The Kermit Project @ Columbia University  SSH, Secure Telnet, Secure FTP, HTTP
 http://www.kermit-project.org/            Secured with MIT Kerberos, SRP, and 
 [email-masked]               OpenSSL.

---

From: "Douglas E. Engert" <[email-masked]>
Date: Fri, 04 Oct 2002 14:54:07 -0500

> DNS.  We altered the title of the section to restrict the description

We did? What section and number says DNS only?

 5.2.2. Realm and PrincipalName
 7. Naming Constraints
 7.1. Realm Names

--