Subject: Using PDM as a Preauth

From: "Douglas E. Engert" <[email-masked]>
Date: Wed, 04 Dec 2002 19:39:03 -0600

Patent issued aside, how would the WG feel about using PDM as a
preuath?  

http://www.securitycentric.com/files/ipsec_key_exchange.pdf

Is it two much overhead for packetcable? 

Are there any other pitfalls?

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444

---

From: Sam Hartman <[email-masked]>
Date: Thu, 05 Dec 2002 12:25:22 -0500

>>>>> "Douglas" == Douglas E Engert <[email-masked]> writes:

    Douglas> Patent issued aside, how would the WG feel about using
    Douglas> PDM as a preuath?

I believe that John raised some concerns about performance, but I
don't remember if they were just negatives he was listing on his
slides or if he actually considered them real issues.

Other than patent issues I'd be fine with either EKE, SRP or PDM; I
haven't looked at SPEKE enough to comment.

---

From: "Douglas E. Engert" <[email-masked]>
Date: Thu, 05 Dec 2002 14:48:28 -0600

If the krb-wg is to go forward with a pre-auth method which uses or appears 
to use any of the methods which may be subject to a patent or IPR, then the 
vendors who would implement it need to speak up on the subject.  

We would not want to go through all the work of designing the method 
to find out none will implement it for fear of a patent problem.
We would also not want the situation where one vendor makes a 
separate deal.    

These vendors include Microsoft, Sun, MIT, Cisco, IBM. 

I have been talking to Stephen Farrell and Radia Perlman about the
situation, and Jabalon appears to make claims on most of the interesting 
methods, include EKE, SRP and even PDM.   

EKE sounds like one of the better methods technically and since Lucent 
has a patent and appears be willing to release it. I am attaching 
Raidia's note on the subject. 

Maybe our ADs could also comment on what it would take to get Lucent 
to release EKE separately to the IETF.

Radia Perlman - Boston Center for Networking wrote:
> 
> Here are a bunch of links that certainly look like this is the
> case. If this is true, then IETF can (and should) build it into
> stuff like sacred.
> 
> http://cm.bell-labs.com/sys/doc/auth.html includes this
> text:
> 
>    The Plan 9 open source license provides for use of Lucent's
>    encrypted key exchange patents in this context.
> 
> http://www.lucent.com/press/0802/020807.bla.html includes
> this text:
> 
>    While Factotum and Secure Store were both written for
>    the Plan 9 operating system, an open-source relative of
>    Unix developed at Bell Labs, they can be ported to other
>    operating systems, including Linux*, Windows*, Solaris*
>    and Unix*. Both applications are currently available in
>    source code form to industry and academia at
>    http://plan9.bell-labs.com/plan9
> 
> And the Plan 9 license (located at
> http://plan9.bell-labs.com/plan9dist/license.html) says they
> grant you "a royalty-free, nonexclusive, non-transferable,
> worldwide license to use, reproduce, modify, execute, display,
> perform, distribute and sublicense" the software and a
> "nonexclusive and non-transferable license under any patents
> which Lucent has a right to license and which, but for this
> license, are unavoidably and necessarily infringed by the
> execution of the inherent functionality of the Original
> Software in the form furnished under this Agreement".
> 
> ******
> the last one is a bit too legalistic for me to be sure I understand it.
> 
> Anyway, what are your opinions about this?
> 
> Radia
--

---

From: Sam Hartman <[email-masked]>
Date: Thu, 05 Dec 2002 16:05:23 -0500

[cc trimmed]

I think we really need an answer on how urgent a implementable
solution to this problem is.  

EKE seems like it would be a great solution to this problem, but I
suspect even simple legal negotiations to confirm status of a patent
would take some time.

---

From: "Douglas E. Engert" <[email-masked]>
Date: Thu, 05 Dec 2002 16:01:12 -0600

> solution to this problem is.

I agree, and we are really waiting to hear from the vendors most affected
by this problem. I had one short offline message from Microsoft, but would
like them to address the list as well. 

It might turn out that we are not in any great rush for this. 
Clarifications is still #1. 

--

---

From: "Jacques A. Vidrine" <[email-masked]>
Date: Thu, 5 Dec 2002 17:06:19 -0600

On Thu, Dec 05, 2002 at 02:48:28PM -0600, Douglas E. Engert wrote:
> EKE sounds like one of the better methods technically 

While I'd love to be able to use EKE, I would love even more
being able to use A-EKE or SRP, since the verifier used in the
latter protocols, should it be stolen, cannot be used directly for
impersonation.

That would be in a world where the patent issues don't enter into the
choice :-(

Cheers,
-- 
Jacques A. Vidrine <[email-masked]>          http://www.celabo.org/
NTT/Verio SME          .     FreeBSD UNIX     .       Heimdal Kerberos
[email-masked]     .  [email-masked]  .          [email-masked]