Subject: RE: AES and SHA-1 timing

From: "Paul Leach" <[email-masked]>
Date: Wed, 16 Apr 2003 10:47:36 -0700

> -----Original Message-----
> From: Nicolas Williams [mailto:[email-masked]] 
> Sent: Wednesday, April 16, 2003 7:40 AM
> To: Marcus Watts
> Cc: [email-masked]
> Subject: Re: AES and SHA-1 timing
> 
> 
> On Wed, Apr 16, 2003 at 03:28:14AM -0400, Marcus Watts wrote:
> > We see some form of preauthentication logic as being a much more 
> > promising way to protect weak keys.
> 
> This summarizes it nicely.

I don't know if this is related, but I'm assuming that preauth is in
use. The higher iteration count is to make it hard to generate a
candidate password, then the key for that password, and then use that
key to attempt to decrypt the preauth from a sniffed AS-REQ.

If that's not what this is about, then could someone describe what it
means?

Paul

---

From: Nicolas Williams <[email-masked]>
Date: Wed, 16 Apr 2003 11:03:19 -0700

> If that's not what this is about, then could someone describe what it

It's a reference to the need for new pre-auth types which have better
mechanisms for protecting weak passwords than PA-ENC-TIMESTAMP.

Nico
--