Subject: ticket forwarding and renewable flag

From: Tim Alsop <[email-masked]>
Date: Fri, 6 Jun 2003 17:21:39 +0100

Hi,

I have a question relating to rfc1510 standards compliance and wondered whether the behavior I am experiencing is a because rfc1510 is open to interpretation in certain areas (hence the need for clarifications). I therefore would appreciate any views on this matter.

I have a question about the renewable flag on a tgt.

If I first get a tgt with renewable flag and also forwardable flag. If I then use an application which forwards this tgt to another system the new tgt issued by the KDC which is then forwarded does not have the renewable flag set when it arrives - is this supposed to happen because rfc1510 was designed that way, or is it a bug in the particular implementation of k5 ?

Cheers, Tim.

---

From: "Matt Crawford" <[email-masked]>
Date: Fri, 06 Jun 2003 14:09:11 -0500

When you asked the TGS to write you a new ticket with the new
address(es) in it, did you also ask for the RENEWABLE flag to be
kept?  You should get whatever value you asked for in that bit, if
the original TGT had it set.