Subject: Documents of the IETF KRB-WG

From: "Douglas E. Engert" <[email-masked]>
Date: Wed, 13 Aug 2003 13:20:05 -0500

The milestone chart on the krb-wg page is way out of date, and needs 
to be revised. Now that we have finished Clarifications, AES and KCRYPTO
it is time to get the tasks before the WG in order. 

I am attaching a chart in html which lists all of the outstanding documents 
or proposed documents before the WG, some of these have expired. I want to 
first make sure we have all of them listed, with correct draft IDs, as well 
as dates and primary people responsible.
   
After we identify all of the documents, we can then look at dependencies
and a schedule. 

I would like to solicit comments from the WG especially those people
listed as "PrimeAuthor" (Taken as the first person listed in the draft)
to review there documents.

I have also listed some individual documents which could become WG documents
There may be others.  

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444

Status

Name

Title

DraftName

PrimeAuthor

Issue Date

Extensions

(new)

none See: http://www.kerberos.us

Many

PKINIT

Public Key Cryptography for
Initial Authentication  in
Kerberos

draft-ietf-cat-kerberos-pk-init-16

Brian Tung

9/12/2001

PKCROSS

Public Key Cryptography for
Cross-Realm Authentication in Kerberos

draft-ietf-cat-kerberos-pk-cross-08

Matt Hurr

11/8/2001

AES GSS

(new)

ADH Preauth

(Revised PFS?)

Extra TGT

(revised IAKERB?)

Change/set PW

Kerberos Set/Change Password: Version 2

draft-ietf-krb-wg-kerberos-set-passwd-00

Nico Williams

2003

LDAP Admin

Kerberos KDC LDAP Schema

draft-skibbie-krb-kdc-ldap-schema-02

Dona Skibbie

5/30/2002

U2U GSS

User to User
Kerberos Authentication using GSS-API

draft-swift-win2k-krb-user2user-03

Michael Swift

10/1/2001

IAKERB

Initial and Pass Through
Authentication Using Kerberos V5 and the GSS-API

draft-ietf-cat-iakerb-09

Jonathan Trostle

10/1/2002

HW Preauth

Passwordless Initial
Authentication to Kerberos by Hardware Preauthentication

draft-ietf-krb-wg-hw-auth-02

Matt Crawford

10/24/2002

(Extensions)

UTF-8

Preparation of
Internationalized Strings Profile for  Kerberos UTF-8 Strings

draft-ietf-krb-wg-utf8-profile-01

Jeff Altman

2/24/2003

SAM

Integrating Single-use
Authentication Mechanisms with Kerberos

draft-ietf-krb-wg-kerberos-sam-01

Cliff Neuman

10/1/2002

nonWG

PFS

Kerberos Perfect Forward
Secrecy

draft-weber-krb-wg-kerberos-pfs-00

Joel Weber

7/24/2003

nonWG

SYNC

Kerberos Clock
Synchronization

draft-weber-krb-wg-kerberos-clock-synchronization-01

Joel Weber

6/20/2003

IESG

KCRYPTO

Encryption and Checksum Specifications

draft-ietf-krb-wg-crypto-05

Ken Raeburn

6/10/2003

IESG

Clarifications

The Kerberos Network Authentication Service (V5)

draft-ietf-krb-wg-kerberos-clarifications-04

Cliff Neuman

6/19/2003

IESG

AES

AES Encryption for Kerberos
5

draft-raeburn-krb-rijndael-krb-05

Ken Raeburn

6/20/2003

---

From: Sam Hartman <[email-masked]>
Date: Thu, 14 Aug 2003 18:00:45 -0400

Extra tgt was an old cat draft.  I'll probably be offering to take
over editorship or at least be significantly involved.

I have some questions about the draft, but will time out and submit
something soon if I don't get answers.

---

From: "Douglas E. Engert" <[email-masked]>
Date: Fri, 15 Aug 2003 09:41:21 -0500

> something soon if I don't get answers.

Since it was an old CAT draft, and as I recall, was not one of the original
ones taken over by the krb-wg, it might be best if it gets a new name as well.

--