Subject: ASN.1 for static-static dh

From: [email-masked] (Sam Hartman)
Date: Mon, 30 Aug 2004 15:01:52 -0400 (EDT)

Both options depend on the following data type:

DH-Rep-Info ::= sequence {
        dhSignedData            [0] ContentInfo,
                                    -- Type is SignedData.
                                    -- Content is KDCDHKeyInfo
                                    -- (defined below).
	dhServerNonce 		[1] DHNonce OPTIONAL
}

Option 1:

    PA-PK-AS-REP ::= CHOICE {
	dhInfo 			[0] DH-Rep-Info,
        encKeyPack              [1] ContentInfo,  
				    -- Type is EnvelopedData.
				           -- Content is SignedData over
					          -- ReplyKeyPack (defined below).
        ...
    }

Option 2:

    PA-PK-AS-REP ::= CHOICE {
        dhSignedData            [0] ContentInfo,
                                    -- Type is SignedData.
                                    -- Content is KDCDHKeyInfo
                                    -- (defined below).
        encKeyPack              [1] ContentInfo,
                                    -- Type is EnvelopedData.
                                    -- Content is SignedData over
                                    -- ReplyKeyPack (defined below).
	staticStaticDHInfo	[2] DH-Rep-Info,
        ...
    }

--Sam

---

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Tue, 31 Aug 2004 18:18:19 -0700

I spoke with Sam over the phone earlier on this, and I also support
option 1.

Larry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Sam Hartman
Sent: Tuesday, August 31, 2004 12:54 PM
To: Eric Rosenfeld
Cc: [email-masked]
Subject: Re: ASN.1 for static-static dh

>>>>> "Eric" == Eric Rosenfeld <[email-masked]> writes:

    Eric> Sam,

    Eric> Thanks for the ASN.1. Option 2 minimizes changes to existing
    Eric> implementations, while Option 1 is cleaner when starting
    Eric> with a blank slate. I think it is more important at this
    Eric> point to ge the ID to last call, so I am OK with either
    Eric> option. Am I correct in assuming that Option 1 is preferred?

I have no idea.  I don't care much.  I think Larry prefers option 2.