Subject: RE: pk-init-27 comments, part 2

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Wed, 27 Jul 2005 16:12:44 -0700

You can not negotiation of the etype for paChecksum, but the etype of asChecksum is negotiated, that is the big difference here.

There is probably a good reason not to include the padata for the AS_REQ, but there is no reason I can think of not to include the whole AS_REQ, if nothing else, it is easier to implement.

-----Original Message-----
From: Love Hörnquist Åstrand [mailto:[email-masked]] 
Sent: Wednesday, July 27, 2005 3:32 PM
To: [email-masked]
Cc: Liqiang(Larry) Zhu; [email-masked]; [email-masked]; [email-masked]
Subject: Re: pk-init-27 comments, part 2

[email-masked] writes:

> A couple of thoughts on Love and Larry's earlier comments:
>
>>-------- Original Message --------
>>Subject: RE: pk-init-27 comments, part 2
>>Date: Tue, 26 Jul 2005 10:24:19 -0700
>>From: Liqiang(Larry) Zhu <[email-masked]>
>
>> PKAuthenticator.paChecksum could work too, since it covers the client
>> name, but it does cover less information.
>
> We believe that both approaches work at an abstract level, assuming
> unforgeable signatures and collision-free hashes.  However, we're a
> little concerned about the use of sha1 (as appears to be mandated for
> paChecksum) and potential collisions; would the asChecksum in the
> pk-init-27 version of ReplyKeyPack be stronger in practice?

If you feel worried about paChecksum, lets fix us that and then do the same
thing for asChecksum.

As I understand it, they require the same property, binding the AS-REQ-BODY
to the pkinit data.

Love

---

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Wed, 27 Jul 2005 16:35:44 -0700

Clarifications: 

there is no reason I can think of not to include the whole AS_REQ for asChecksum in the AS_REPLY.

If you have a good reason, I would love to hear about it.

-- Larry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Liqiang(Larry) Zhu
Sent: Wednesday, July 27, 2005 4:13 PM
To: Love Hörnquist Åstrand; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: pk-init-27 comments, part 2

You can not negotiate the etype for paChecksum, but the etype of asChecksum is negotiated, that is the big difference here.

-----Original Message-----
From: Love Hörnquist Åstrand [mailto:[email-masked]] 
Sent: Wednesday, July 27, 2005 3:32 PM
To: [email-masked]
Cc: Liqiang(Larry) Zhu; [email-masked]; [email-masked]; [email-masked]
Subject: Re: pk-init-27 comments, part 2

Love