Subject: PKINIT and TD-DH-PARAMETERS in KRB-ERROR

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Tue, 20 Sep 2005 00:07:03 -0700

Folks, shall we add the following into security considerations?

   Kerberos error messages are not integrity protected, as a result, the
   domain parameters sent by the KDC as TD-DH-PARAMETERS can be tampered
   with by an attacker so that the set of domain parameters selected
   could be either weaker or not mutually preferred.  Local policy can
   configure sets of domain parameters acceptable locally, or disallow
   the negotiation of DH domain parameters.

I took this mostly out of the pkinit-ecc ID.

-- larry

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Tue, 20 Sep 2005 04:06:20 -0700

> I took this mostly out of the pkinit-ecc ID.

I find it strange that the PK-INIT error PA-DATA isn't protected using the
certificate of the KDC.

Love