Subject: Re: [Ietf-krb-wg] Last call issues on anonymous

From: Jeffrey Hutzelman <[email-masked]>
Date: Wed, 17 Sep 2008 18:30:26 -0400

--On Friday, August 22, 2008 02:02:06 PM -0700 Larry Zhu 
<[email-masked]> wrote:

>>  - Should anonymous-tickets be limited to single-use (i.e. not be
>>  cached), so that independent sessions are not automatically correlated
>>    by repeated use of a cached anonymous service ticket.
>
> This is discussed at the very end of section 4.
>
>   A server accepting an anonymous service ticket may assume that
>    subsequent requests using the same ticket originate from the same
>    client.  Requests with different tickets are likely to originate from
>    different clients.

Great, but this text points out something the server can do if it turns out 
to be useful to the server.  Martin is pointing out a security 
consideration, which is that using the same anonymous ticket multiple times 
allows a server (or possibly a passive attacker) to notice that several 
operations are being done by the same client, even when the client does not 
want that.  Don't you think that is worthy of metion in the security 
considerations section?

I would recommend resolving this by replacing (again!) the last sentence in 
the next-to-last paragraph of -09 section 8:

OLD:

        A service that is authenticated by the anonymous principals
        may be able to infer the identity of the client by examining
        and linking quasi-static protocol information such as the IP
        address from which a request is received.

NEW:
        A service that is authenticated by the anonymous principals
        may be able to infer the identity of the client by examining
        and linking quasi-static protocol information such as the IP
        address from which a request is received, or by linking
        multiple uses of the same anonymous ticket.

-- Jeff
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Larry Zhu <[email-masked]>
Date: Wed, 17 Sep 2008 16:19:43 -0700

Jeff wrote:
> I would recommend resolving this by replacing (again!) the last sentence in the next-to-last paragraph of -09 section 8:

>        multiple uses of the same anonymous ticket.

This addition at the very last of the paragraph looks like a fine addition.

-----Original Message-----
From: Jeffrey Hutzelman [mailto:[email-masked]]
Sent: Wednesday, September 17, 2008 3:30 PM
To: Larry Zhu; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ietf-krb-wg] Last call issues on anonymous

OLD:

NEW:

-- Jeff