Subject: Re: [Ietf-krb-wg] EPAK extension proposal

From: Jeffrey Hutzelman <[email-masked]>
Date: Thu, 26 Mar 2009 14:37:53 -0700

--On Wednesday, November 19, 2008 06:05:20 PM -0700 Phillip Hellewell 
<[email-masked]> wrote:

>    Hello, my name is Phillip Hellewell.  I attended Brigham Young
> University's Computer Science graduate program where I worked in the
> Internet Security Research Lab.  As part of my research I designed and
> implemented a Kerberos extension called EPAK with my advisor Dr. Kent
> Seamons in 2007.
>
>    EPAK (Extensible Pre-Authentication in Kerberos) was presented at ACSAC
> 2007. The ACSAC paper can be obtained in PDF format here:
> http://www.acsac.org/2007/abstracts/30.html.
>
> P. L. Hellewell, T. W. van der Horst, and K. E. Seamons. Extensible
> Pre-Authentication in Kerberos. 23rd Annual Computer Security Applications
> Conference (ACSAC), Miami, FL, December 2007.
>
>    Below is a brief introduction to EPAK.  Work is underway for creating
> an Internet draft, and I would like to see this as a working group item;
> any comments about EPAK and help in the standardization process will be
> greatly appreciated.

For some reason I never responded to this back in November, despite having 
a partially-composed response for almost that long.  Even then, you were a 
bit late to the preauth framework party, but not so late that we cannot 
discuss this work.  Can you comment on how this relates or compares to the 
framework described in draft-ietf-krb-wg-preauth-framework-10.txt ?

I'd also like to hear comments from the working group on what, if anything, 
we should do with this work.

-- Jeffrey T. Hutzelman (N3NHS) <[email-masked]>
   Co-chair, IETF Kerberos Working Group
   Carnegie Mellon University - Pittsburgh, PA

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: "Thomas Hardjono" <[email-masked]>
Date: Fri, 27 Mar 2009 11:57:54 -0500

Phillip,

I did read you paper a couple of months ago. I think it would a very useful
exercise to see how to fit EPAK within the new FAST framework for pre-auth.

Let me know if I can help.

cheers,

/thomas/

> -----Original Message-----
> From: [email-masked] [mailto:ietf-krb-wg-
> [email-masked]] On Behalf Of Jeffrey Hutzelman
> Sent: Thursday, March 26, 2009 4:38 PM
> To: Phillip Hellewell; [email-masked]
> Cc: Kent Seamons; [email-masked]
> Subject: Re: [Ietf-krb-wg] EPAK extension proposal
>