Subject: Re: [Ietf-krb-wg] WG Last Call - krb-wg charter update (LDAP)

From: Quanah Gibson-Mount <[email-masked]>
Date: Fri, 03 Apr 2009 12:29:57 -0700

--On Monday, February 25, 2008 5:28 PM -0500 Jeffrey Hutzelman 
<[email-masked]> wrote:

> --On Friday, February 22, 2008 12:05:08 PM -0800 Quanah Gibson-Mount
> <[email-masked]> wrote:
>
>> --On Saturday, June 16, 2007 8:12 PM +0200 Leif Johansson
>> <[email-masked]>  wrote:
>>
>>> Sam Hartman wrote:
>>>> Question:
>>>>
>>>> Who would author documents in this space?
>>>> Who would review documents?
>>>> who would implement?
>>>>
>>>>
>>> I would author and review.
>>
>> Any update on this?
>
> No.  The work is part of the charter, but has not yet begun.

It's been over a year now.  Any update?

--Quanah

--

Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
--------------------
Zimbra ::  the leader in open source messaging and collaboration
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 03 Apr 2009 15:58:56 -0400

> It's been over a year now.  Any update?

The data model document is in or about to start what we hope will be its 
final last call.  Once that's done, work on a schema document can start, if 
there's anyone willing to do it.
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Quanah Gibson-Mount <[email-masked]>
Date: Fri, 03 Apr 2009 13:01:47 -0700

--On Friday, April 03, 2009 3:58 PM -0400 Jeffrey Hutzelman <[email-masked]> 
wrote:

> final last call.  Once that's done, work on a schema document can start,
> if there's anyone willing to do it.

Excellent.  By schema document, do you just mean the regular oc/Attr 
definitions?  Or a more high-level description of the schema?

--Quanah

--

Quanah Gibson-Mount

---

From: "Henry B. Hotz" <[email-masked]>
Date: Tue, 7 Apr 2009 16:58:11 -0700

Speaking only for myself, I'd favor something more general.  Just as  
an idle question would the group favor XML (possibly SPML) or ASN1 as  
profiles in addition to LDIF?

On Apr 3, 2009, at 1:01 PM, Quanah Gibson-Mount wrote:

> --On Friday, April 03, 2009 3:58 PM -0400 Jeffrey Hutzelman <[email-masked] 
> >
> wrote:
>

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]

---

From: Howard Chu <[email-masked]>
Date: Tue, 07 Apr 2009 17:03:51 -0700

> profiles in addition to LDIF?

That question didn't make any sense. An LDAP schema defines the data model, 
LDIF and ASN.1 are just data encoding formats. XML is ... garbage.

>> --On Friday, April 03, 2009 3:58 PM -0400 Jeffrey Hutzelman<[email-masked]
>>>
>> wrote:
>>

-- 
   -- Howard Chu
   CTO, Symas Corp.           http://www.symas.com
   Director, Highland Sun     http://highlandsun.com/hyc/
   Chief Architect, OpenLDAP  http://www.openldap.org/project/
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Howard Chu <[email-masked]>
Date: Tue, 07 Apr 2009 17:05:43 -0700

> LDIF and ASN.1 are just data encoding formats. XML is ... garbage.

Misspoke a bit there - ASN.1 is obviously more than just data encoding; the 
LDAP schema is defined in terms of ASN.1. (Was thinking of DER for some reason...)

---

From: "Henry B. Hotz" <[email-masked]>
Date: Wed, 8 Apr 2009 09:16:02 -0700

On Apr 7, 2009, at 5:03 PM, Howard Chu wrote:

> LDIF and ASN.1 are just data encoding formats.

I was thinking of carrying the schema all the way to the  
representation.  You'd have the abstract schema, and the  
representation profile(s).  If the ultimate goal is some actual data  
exchange, then that level of specification will ultimately be needed.   
If that's not the intent, you're right (though I'd want to know what  
the goal actually was).

> XML is ... garbage.

OT ;-)