Subject: [Ietf-krb-wg] draft-ietf-krb-wg-utf8-profile-01.txt

From: "Srinivas Cheruku" <[email-masked]>
Date: Mon, 20 Jul 2009 15:07:24 +0530

HI, 

Can anyone let me know the status on this draft
draft-ietf-krb-wg-utf8-profile-01.txt
<http://tools.ietf.org/html/draft-ietf-krb-wg-utf8-profile-01.txt> ? It is
very old and not sure on the current status.
 
Looks like UTF-8 is the preferred character encoding for Kerberos(maybe this
is the reason why OTP draft uses UTF-8 strings). Is there any other valid
draft on the preferred character encoding for Kerberos?
 
Does anybody know to what extent Windows/AD support UTF-8 in Kerberos?

Thanks,
Srini

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Larry Zhu <[email-masked]>
Date: Thu, 30 Jul 2009 06:03:08 +0000

The draft apparently has expired. Another draft IAKERB, which is a working group work item, also uses UTF8 encoding. The character encoding is a chartered item in this working group and we have not made significant progress.

Speaking as an individual, if I have a crystal ball, I would see that UTF8 is likely to become the encoding of choice in Kerberos going forward.

We do not discuss vendor specific information in this list though in this case backward compatibility with the existing deployment is one of the considerations. Windows Kerberos implementations do support UTF-8 and you can find the detailed information from MSDN (hint: search for KILE).

--Larry

From: [email-masked] [mailto:[email-masked]] On Behalf Of Srinivas Cheruku
Sent: Monday, July 20, 2009 2:37 AM
To: [email-masked]
Subject: [Ietf-krb-wg] draft-ietf-krb-wg-utf8-profile-01.txt

HI,

Can anyone let me know the status on this draft draft-ietf-krb-wg-utf8-profile-01.txt<http://tools.ietf.org/html/draft-ietf-krb-wg-utf8-profile-01.txt>? It is very old and not sure on the current status.

Looks like UTF-8 is the preferred character encoding for Kerberos(maybe this is the reason why OTP draft uses UTF-8 strings). Is there any other valid draft on the preferred character encoding for Kerberos?

Thanks,
Srini