Subject: Re: [Ietf-krb-wg] OTP draft - full tagged ASN.1 structures

From: Larry Zhu <[email-masked]>
Date: Tue, 28 Jul 2009 08:29:13 +0000

Speaking as an individual, if we need to make an incompatible change in the current ID then we should make it consistent then.

--Larry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Love Hörnquist Åstrand
Sent: Monday, June 29, 2009 9:01 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ietf-krb-wg] OTP draft - full tagged ASN.1 structures

I don't care which tagging your are using but prefer the full tagging
for consistancy with other Kerberos documents.

Love

29 jun 2009 kl. 04:32 skrev [email-masked]:

> As I mentioned in my reply, I have used tagging to resolve potential
> ambiguity when there is more than one optional element of the same
> type.
> I didn't believe that full tagging was required.
>
> However, from Tom and Sam's replies to Srini's question, it does
> seem as
> if full tagging would make parsing easier.
>
> Jeff & Larry, do you think that this change is required?
>
> --Gareth
>
>> -----Original Message-----
>> From: Srinivas Cheruku [mailto:[email-masked]]
>> Sent: 23 June 2009 12:35
>> To: 'Sam Hartman'
>> Cc: Richards, Gareth; [email-masked]
>> Subject: RE: [Ietf-krb-wg] OTP draft - full tagged ASN.1 structures
>>
>>
>>>>>>> Sam Hartman [mailto:[email-masked]] writes:
>>
>>> While these tags are not required by the ASN.1 spec, at
>> least for some
>>> Kerberos implementations it would be far easier to implement
>> ASN.1 that
>>> followed the Kerberos style.
>>
>>> OTOH, it is late in the process for this sort of change.
>>
>> I think Gareth can change the draft and I don't think it is too late.
>>
>> Thanks,
>> Srini
>>
>>
>>
> _______________________________________________
> ietf-krb-wg mailing list
> [email-masked]
> https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Nicolas Williams <[email-masked]>
Date: Wed, 29 Jul 2009 13:21:02 -0500

> for consistancy with other Kerberos documents.

My own opinion is that adding redundancy on the wire is bad, and fully
tagging with explicit tags does just that.  But since we already do it
throughout Kerberos, and since there are many hand-coded parsers, I
think it's much better, in this context, to stick with explicit tagging
for every SEQUENCE field.

Nico
--