Subject: [Ietf-krb-wg] Assignments for Camellia-CCM enctypes

From: [email-masked]
Date: Wed, 4 Aug 2010 12:02:59 -0400 (EDT)

Independently of whether the working group adopts
draft-kanno-krbwg-camellia-ccm, I request that the designated expert
(Ken Raeburn) review the proposed enctypes for IANA assignments.

The draft describing the enctypes is at:

  http://tools.ietf.org/html/draft-kanno-krbwg-camellia-ccm-01

I've submitted two proposed edits which may make the draft easier to
evaluate, but to speed up the process I'm not waiting for a turnaround
on those edits.  The first edit is a rewrite of section 4, with the
important part being:

  saltp = enctype-name | 0x00 | salt
  tkey = random2key(PBKDF2(passphrase, saltp, iter_count, keylength))
  key = DK(tkey, "kerberos")

The second edit is an explanation of what CMAC means in the
pseudo-code:

  CMAC is defined in [RFC4493], except that the underlying block
  cipher is Camellia-128 or Camellia-256 instead of AES-128.

We also have a reference implementation (using negative enctype and
cksumtype numbers); I can provide a pointer on request.

As noted in figure 2 of the draft, the required assignments are
encryption type numbers for:

  camellia128-ccm-128
  camellia256-ccm-128

and checksum type numbers for:

  cmac-128-camellia128
  cmac-128-camellia256

Thanks for your time.
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Thu, 5 Aug 2010 01:01:01 -0700

> (Ken Raeburn) review the proposed enctypes for IANA assignments.

I don't object to the camellia enc and checksum number being assign.

Loe

---

From: Ken Raeburn <[email-masked]>
Date: Wed, 18 Aug 2010 13:04:15 -0400

> (Ken Raeburn) review the proposed enctypes for IANA assignments.

I apologize for not getting on this sooner.  The past couple weeks were busy for me, but I should have time this week.

Does the -02 version contain your desired edits?  Should I be looking at that instead?

Ken

---

From: Thomas Hardjono <[email-masked]>
Date: Wed, 18 Aug 2010 13:26:42 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ken Raeburn [[email-masked]]
Sent: Wednesday, August 18, 2010 1:04 PM
To: Greg Hudson
Cc: [email-masked]
Subject: Re: [Ietf-krb-wg] Assignments for Camellia-CCM enctypes

Ken

Hi Ken,

Draft-02 is the latest version.

Thanks.

/thomas/

---

From: Thomas Hardjono <[email-masked]>
Date: Wed, 18 Aug 2010 13:32:58 -0400

Actually, Ken, please wait a day or so as I plan to be submitting draft-03.

Thanks.

/thomas/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Thomas Hardjono [[email-masked]]
Sent: Wednesday, August 18, 2010 1:26 PM
To: Kenneth G Raeburn; Greg Hudson
Cc: [email-masked]
Subject: Re: [Ietf-krb-wg] Assignments for Camellia-CCM enctypes

Ken

Hi Ken,

Thanks.

/thomas/

---

From: "Thomas Hardjono" <[email-masked]>
Date: Thu, 19 Aug 2010 12:01:06 -0400

Ken,

Version -03 has just been uploaded.
Please use this latest version.

Thanks for your help.

/thomas/

> -----Original Message-----
> From: [email-masked] [mailto:ietf-krb-wg-
> [email-masked]] On Behalf Of Thomas Hardjono
> Sent: Wednesday, August 18, 2010 1:33 PM
> To: Thomas Hardjono; Kenneth G Raeburn; Greg Hudson
> Cc: [email-masked]
> From: [email-masked] [ietf-krb-wg-
> [email-masked]] On Behalf Of Thomas Hardjono
[[email-masked]]
> From: [email-masked] [ietf-krb-wg-
> [email-masked]] On Behalf Of Ken Raeburn [[email-masked]]
> I apologize for not getting on this sooner.  The past couple weeks
were
> busy for me, but I should have time this week.
> 
> Does the -02 version contain your desired edits?  Should I be
looking
> at that instead?