Subject: [Ietf-krb-wg] I-D Action:draft-ietf-krb-wg-otp-preauth-17.txt

From: [email-masked]
Date: Thu, 28 Apr 2011 04:45:04 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Kerberos Working Group of the IETF.

	Title           : OTP Pre-authentication
	Author(s)       : G. Richards
	Filename        : draft-ietf-krb-wg-otp-preauth-17.txt
	Pages           : 40
	Date            : 2011-04-28

The Kerberos protocol provides a framework authenticating a client
using the exchange of pre-authentication data.  This document
describes the use of this framework to carry out One Time Password
(OTP) authentication.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-krb-wg-otp-preauth-17.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: <[email-masked]>
Date: Thu, 28 Apr 2011 08:13:35 -0400

I have just submitted a minor update to the OTP pre-auth ID to include the issues reported by Linus:

1) Section 3.6 - Reply Key Generation

Corrected the hash formula to be

       H = hash(realm|nonce|OTP)

2) Section 4.1 - PA-OTP-CHALLENGE

Corrected the text describing the otp-keyInfo element of the PA-OTP-CHALLENGE to state that the element is not optional.

3) Renamed the otp-keyID and otp-keyInfo elements of the PA-OTP-CHALLENGE and PA-OTP-REQUEST to be otp-tokenID and otp-tokenInfo

4) Section 4.2 - PA-OTP-REQUEST

Corrected text describing the otp-time, otp-format and otp-algID elements to say:

         "Use of this element
        is OPTIONAL but it MAY be used by the client to simplify the OTP
        calculations carried out by the KDC."

5) Replaced references to draft-ietf-krb-wg-preauth-framework-17 and draft-ietf-krb-wg-anon-12 with RFCs 6113 and 6112

6) Added publication dates to the references for X.680 and X.690 (The new version of xml2frc complained)

--Gareth

> -----Original Message-----
> From: [email-masked] [mailto:ietf-krb-wg-
> [email-masked]] On Behalf Of [email-masked]
> Sent: 28 April 2011 12:45
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Ietf-krb-wg] I-D Action:draft-ietf-krb-wg-otp-preauth-17.txt
>
> using the exchange of pre-authentication data.  This document describes
> the use of this framework to carry out One Time Password
> (OTP) authentication.
>