Subject: [Ietf-krb-wg] Fwd: New AD type

From: Luke Howard <[email-masked]>
Date: Sun, 3 Apr 2011 00:32:30 +1100

Sorry, I should have asked this of krb-wg not kitten.

Begin forwarded message:

> From: Luke Howard <[email-masked]>
> Date: 2 April 2011 10:40:31 PM AEDT
> To: [email-masked]
> Subject: New AD type
> 
> I want a new authorisation data type. Who do I ask?
> 
> (It's KRB5_AUTHDATA_SAML, encapsulating a SAML assertion inside a ticket. The contents are defined by SAML, although we will also specify how Kerberos session and long-term keys may be used to sign the assertion.)
> 
> -- Luke

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Michiko Short <[email-masked]>
Date: Mon, 4 Apr 2011 17:03:05 +0000

We now send our requests to IANA.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Luke Howard
Sent: Saturday, April 02, 2011 6:33 AM
To: [email-masked]
Subject: [Ietf-krb-wg] Fwd: New AD type

Begin forwarded message:

From: Luke Howard <[email-masked]<mailto:[email-masked]>>
Date: 2 April 2011 10:40:31 PM AEDT
To: [email-masked]<mailto:[email-masked]>
Subject: New AD type

-- Luke

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 04 Apr 2011 13:12:48 -0400

> We now send our requests to IANA.

For AD types, that's now the appropriate thing to do.  RFC6113 will be
published shortly, and the registry has already been created.

However, I suspect that at least part of what Luke is working on
actually may want to appear in an IETF document.  In which case, we
usually handle number assignment close to the point of publication,
rather than early in the document lifecycle.

-- Jeff

---

From: Tom Yu <[email-masked]>
Date: Mon, 04 Apr 2011 14:27:12 -0400

> published shortly, and the registry has already been created.

If RFC 6113 is the preauth framework, it doesn't establish an authdata
type number registry, but rather a preauth type number registry.
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 04 Apr 2011 16:03:18 -0400

> type number registry, but rather a preauth type number registry.

D'oh; you're right.  For now, the authdata registry remains in the hands
of krb-wg.