Subject: [Ietf-krb-wg] pkinit-alg-agility-04: ISSUE #2: Reps Calculation Incorrect

From: Margaret Wasserman <[email-masked]>
Date: Tue, 3 May 2011 11:48:12 -0400

ISSUE #2: Reps Calculation Incorrect
========
In Section 6:

This is incorrect:

   1.  reps = keydatalen (K) / hash length (H)

It is necessary to round this value up (rather than down as will  
happen with in\
teger arithmetic) in order to make sure that the buffer is completely  
filled wi\
th hashed data.  There are a number of ways to do this, one of which is:

    1. reps = keydatalen (K) + (hash length (H) - 1)/hash length (H)

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Martin Rex <[email-masked]>
Date: Tue, 3 May 2011 21:01:15 +0200 (MEST)

>     1. reps = keydatalen (K) + (hash length (H) - 1)/hash length (H)

Could it be that you acutally meant:

      1. reps = (keydatalen (K) + (hash length (H) - 1))/hash length (H)

i.e. a missing parenthesis around the parts of the dividend?

-Martin

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 3 May 2011 15:07:59 -0400

> i.e. a missing parenthesis around the parts of the dividend?

Yes, that is indeed what I meant.  Good catch, Martin!

Margaret