Subject: [Ietf-krb-wg] pkinit-alg-agility-04: ISSUE #3: Question about OtherInfo Tags

From: Margaret Wasserman <[email-masked]>
Date: Tue, 3 May 2011 11:49:35 -0400

ISSUE #3: Question about OtherInfo Tags
========
In Section 6, the document says:

    OtherInfo ::= SEQUENCE {
            algorithmID   AlgorithmIdentifier,
            partyUInfo     [0] OCTET STRING,
            partyVInfo     [1] OCTET STRING,
            suppPubInfo    [2] OCTET STRING OPTIONAL,
            suppPrivInfo   [3] OCTET STRING OPTIONAL
    }

Why are these items tagged starting at the second item?  I would
normally expect all of the items to be tagged, or only the optional
items to be tagged.

_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Tue, 03 May 2011 10:46:22 -0700

> normally expect all of the items to be tagged, or only the optional

Because that is how NIST made it to be.

Love

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 3 May 2011 14:22:39 -0400

> Because that is how NIST made it to be.

I figured it might be something like that.  Thanks for letting me know.

Margaret

---

From: Tom Yu <[email-masked]>
Date: Tue, 03 May 2011 18:44:42 -0400

> Because that is how NIST made it to be.

Could you please provide more details, or citations?  SP 800-56A
(March 2007 revision) doesn't actually contain ASN.1 syntax for
OtherInfo.
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Tue, 03 May 2011 21:41:18 -0700

> (March 2007 revision) doesn't actually contain ASN.1 syntax for

 3.2.2   draft-dang-nistkdf-01

Love

---

From: Tom Yu <[email-masked]>
Date: Wed, 04 May 2011 09:22:07 -0400

>  3.2.2   draft-dang-nistkdf-01

That expired almost 5 years ago, and the ASN.1 syntax there isn't
valid either.  (uses the nonexistent keyword "MANDATORY")  Is there
anything more official from NIST on OtherInfo?
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Wed, 04 May 2011 10:26:58 -0700

> anything more official from NIST on OtherInfo?

That was published at the same time as nist was working on SP800-56

I talked to Tim Polk at the time and he said that the had missed the missing ASN1 in the document.

Love