Subject: [L2CP] L2C Encapsulation using GSMP RFC3293 Framework

From: "Haag, T" <[email-masked]>
Date: Fri, 24 Feb 2006 17:20:16 +0100

All,

Running Layer 2 Control in ATM and Ethernet based networks should base on common requirements like RFC3293.

The document talks about three different types of encapsulation which have different draw backs.

 - GSMP Packet Encapsulation for ATM (section 2)

   VPI=0/VCI=15; preferred value would be VPI=254; VCI=32...
   No MAC address needed

- GSMP Packet Encapsulation for Ethernet (section 3)
  MAC Address needed

- GSMP Packet Encapsulation for TCP (section 4)
  No MAC Address needed; But additional IPsec for security 

To be consistent by operating parallel ATM and Ethernet in networks the encapsulation should be done similar for all Types.

I think it should be investigated to run GSMP packets over bridged encapsulation via ATM according RFC2684 using MAC addresses for detection of Layer 2 Control sender instance, and receiver instance. This would enable to run GSMP Ethernet Packet Encapsulation on Top of ATM using the same sender and receiver assignment.

Regards

Thomas Haag
_______________________________________________
L2cp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2cp

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 24 Feb 2006 10:36:31 -0800

To run GSMP on ATM or ethernet, will a reliability
layer be required? Something to provide error/loss
detection and retransmission and congestion control.

TCP provides this functionality when GSMP runs on
TCP. Therefore this functionality should not be
duplicated in GSMP, but in a separate layer.

Haag, T wrote:
> To be consistent by operating parallel ATM and Ethernet in networks the 
> encapsulation should be done similar for all Types.
> 
> I think it should be investigated to run GSMP packets over bridged 
> encapsulation via ATM according RFC2684 using MAC addresses for 
> detection of Layer 2 Control sender instance, and receiver instance. 
> This would enable to run GSMP Ethernet Packet Encapsulation on Top of 
> ATM using the same sender and receiver assignment.
> 
> 
> Regards
> 
> Thomas Haag
> 
> 
> ------------------------------------------------------------------------
>