Subject: [L3sm] [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

From: "l3sm issue tracker" <[email-masked]>
Date: Mon, 02 Nov 2015 09:03:10 -0000

#9: Do we need to model transport constraints between sites ?

 In some cases, customer are requesting specific transport between their
 site (for example : low latency path between two specific sites, disjoint
 paths between pair of hub sites ...).

 Do we need to model it ?

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |      Owner:  draft-ltsd-l3sm-l3vpn-
  [email-masked]      |  [email-masked]
     Type:  enhancement              |     Status:  new
 Priority:  minor                    |  Milestone:
Component:  draft-ltsd-l3sm-l3vpn-   |    Version:
  service-model                      |   Keywords:
 Severity:  -                        |
-------------------------------------+-------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/l3sm/trac/ticket/9>
l3sm <http://tools.ietf.org/l3sm/>

---

From: "l3sm issue tracker" <[email-masked]>
Date: Mon, 02 Nov 2015 11:52:09 -0000

Comment (by [email-masked]):

 I think that would be useful input to the SDN controller realizing the
 connectivity.

 The key question is if there is a simple and abstract way to model those
 customer requirements. It is relatively simply to model constraints for
 the L3VPN as a whole (e.g., that all sites should be connected with lowest
 possible latency), but for connectivity between specific sites an abstract
 specification could be a bit more challenging.

 Michael

  service-model                      |  Resolution:
 Keywords:                           |

Ticket URL: <http://trac.tools.ietf.org/wg/l3sm/trac/ticket/9#comment:1>
l3sm <http://tools.ietf.org/l3sm/>

---

From: <[email-masked]>
Date: Mon, 2 Nov 2015 15:57:03 +0000

What is possible is to provide basic constraint (let say : latency, BW and disjointness) and let vendor augment with new constraints.

Now regarding modeling of the transport constraint, I do not see a real sexy way for now.
 Proposal #1 :
	Create a transport-constraint container within the vpn-svc to describe the constraints. Example :

rw vpn-svc
    +--rw transport-constraint
               +--rw list [id]
                      +--rw id                uint32
                      +--rw src-site     leafref
                      +--rw dst-site    leafref
                      +--rw constraint-type        identityref
                      +--rw constraint-value      ???

=> constraint-value may have a variable type depending of the constraint-type, for example, expressing latency boundary, or disjointness group ...

Proposal#2 :
	Put the constraint in the site

rw site 
  +--rw services
        +--rw transport-constraint
             +--rw  dst-site-list         [dst-site]
                      +--rw dst-site                        leafref
                      +--rw constraint-type        identityref
                      +--rw constraint-value      ???

Thoughts ?

-----Original Message-----
From: l3sm issue tracker [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 12:52
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

 I think that would be useful input to the SDN controller realizing the  connectivity.

 The key question is if there is a simple and abstract way to model those  customer requirements. It is relatively simply to model constraints for  the L3VPN as a whole (e.g., that all sites should be connected with lowest  possible latency), but for connectivity between specific sites an abstract  specification could be a bit more challenging.

 Michael

-- 
-------------------------------------+----------------------------------
-------------------------------------+---
 Reporter:                           |       Owner:  draft-ltsd-l3sm-l3vpn-
  [email-masked]      |  [email-masked]
     Type:  enhancement              |      Status:  new
 Priority:  minor                    |   Milestone:
Component:  draft-ltsd-l3sm-l3vpn-   |     Version:
  service-model                      |  Resolution:
 Severity:  -                        |
 Keywords:                           |
-------------------------------------+----------------------------------
-------------------------------------+---

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 6 Nov 2015 06:39:36 +0000

I agree that the modeling is not really "sexy".

Maybe we could keep this aspect out of the base model right now, to keep the base model simple?

For instance, I could imagine this as a potential topic for a future re-chartering.

Michael

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Monday, November 02, 2015 4:57 PM
> To: l3sm issue tracker; draft-ltsd-l3sm-l3vpn-service-
> [email-masked]; Scharf, Michael (Michael)
> Cc: [email-masked]
> Subject: RE: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we
> need to model transport constraints between sites ?
> 
> What is possible is to provide basic constraint (let say : latency, BW
> and disjointness) and let vendor augment with new constraints.
> 
> => constraint-value may have a variable type depending of the
> constraint-type, for example, expressing latency boundary, or
> disjointness group ...
> 
> 
> Proposal#2 :
> Subject: Re: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we
> need to model transport constraints between sites ?
> 
>  The key question is if there is a simple and abstract way to model
> those  customer requirements. It is relatively simply to model
> constraints for  the L3VPN as a whole (e.g., that all sites should be
> connected with lowest  possible latency), but for connectivity between
> specific sites an abstract  specification could be a bit more
> challenging.
> 
>  Michael
> 
> --
> Ticket URL:
> <http://trac.tools.ietf.org/wg/l3sm/trac/ticket/9#comment:1>
> _______________________________________________________________________
> __________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les
> messages electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Qin Wu <[email-masked]>
Date: Mon, 16 Nov 2015 08:34:07 +0000

I like these generic constraints that are applied to transport.
Two comments on the following two proposal:
1.Do we need to distinct transport constraint from src-site to dst-site from transport constraint from dst-site to src-site?
2. where does the transport start, where does the transport end? Start on CE or PE, end or CE or PE?

Regards!
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年11月2日 23:57
收件人: l3sm issue tracker; [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [L3sm] [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

rw vpn-svc

Proposal#2 :

rw site 
  +--rw services

Thoughts ?

-----Original Message-----
From: l3sm issue tracker [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 12:52
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

 Michael

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: <[email-masked]>
Date: Mon, 16 Nov 2015 10:48:02 +0000

Hi,

Inline comments.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Monday, November 16, 2015 09:34
To: LITKOWSKI Stephane SCE/OINIS; l3sm issue tracker; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

I like these generic constraints that are applied to transport.
Two comments on the following two proposal:
1.Do we need to distinct transport constraint from src-site to dst-site from transport constraint from dst-site to src-site?
[SLI] We need to decide if the relationship created is unidirectional or bi directional ... I do not see a use case for unidirectional ...

2. where does the transport start, where does the transport end? Start on CE or PE, end or CE or PE?
[SLI] I would say, up to service provider implementation.

Regards!
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年11月2日 23:57
收件人: l3sm issue tracker; [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [L3sm] [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

rw vpn-svc

Proposal#2 :

rw site 
  +--rw services

Thoughts ?

-----Original Message-----
From: l3sm issue tracker [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 12:52
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

 Michael

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Fri, 27 Nov 2015 04:21:15 +0000

Hi,all,

A little thoughts, please see inline.

Regards,

Yan

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年11月16日 18:48
收件人: Qin Wu; l3sm issue tracker; [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [L3sm] [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

Hi,

Inline comments.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]] 
Sent: Monday, November 16, 2015 09:34
To: LITKOWSKI Stephane SCE/OINIS; l3sm issue tracker; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

[YAN]: From the customer perspective, I think bidirectional is more than enough.

[YAN]: Agree.

Regards!
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年11月2日 23:57
收件人: l3sm issue tracker; [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [L3sm] [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

rw vpn-svc

Proposal#2 :

rw site 
  +--rw services

Thoughts ?

-----Original Message-----
From: l3sm issue tracker [mailto:[email-masked]] 
Sent: Monday, November 02, 2015 12:52
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [l3sm] #9 (draft-ltsd-l3sm-l3vpn-service-model): Do we need to model transport constraints between sites ?

 Michael