Subject: [L3sm] Modeling customer-specific-information => issue

From: <[email-masked]>
Date: Tue, 10 Nov 2015 13:59:52 +0000

Hi,

In the current draft with have a container which embeds some customer routing informations (AS number, LAN, cascaded LANs ...).
There was some willness of WG to merge these information in the routing-protocols container.

I tried the exercice but I'm falling into a modeling complexity issue.

Let's consider we have a setup where :

-          CE is provider managed

-          BGP routing is used between PE and CE

-          Cascaded LANs are existing on CE

In the current version of the model, Cascaded LANs are part of the customer-specific-information container, BGP is activated in the routing-protocol container.

With the proposed version, I would need to activate both static and bgp in routing-protocol because my cascaded LANs would be statically routed on CE and bgp routing is required between PE and CE. This brings IMO a lot of confusion ...
Moreover how do we handle the case of dynamic routing on LAN ?

My proposal would be to consider ip-connection in the attachment as describing the boundary between the SP and the customer.
In case of customer managed CE, it would so described the PE-CE relationship
In case of provider managed CE, it would describe the customer LAN - CE relationship. And in this case the PE to CE relationship management is up to service provider. I think parameters like site-availability ... would allow to determine if dynamic routing is required or not between PE and CE in this case.

Thoughts ?

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 11 Nov 2015 19:06:12 +0900

Hi Stephane,

In case of provider managed CE, the PE to CE relationship management may be up to the agreement between customer and service provider outside this model. But, site-availability, QoS, bandwidth between PE and CE should still be specified by customer through this model.
The current relationship between site and attachment/ip-connection is 1 to 1, but CE LAN may be multiple subnets, then multiple attachment/ip-connection should be allowed.

All the best,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 10, 2015 11:00 PM
To: [email-masked]
Subject: [L3sm] Modeling customer-specific-information => issue

Hi,

In the current draft with have a container which embeds some customer routing informations (AS number, LAN, cascaded LANs .).

-          CE is provider managed

With the proposed version, I would need to activate both static and bgp in routing-protocol because my cascaded LANs would be statically routed on CE and bgp routing is required between PE and CE. This brings IMO a lot of confusion .

In case of provider managed CE, it would describe the customer LAN - CE relationship. And in this case the PE to CE relationship management is up to service provider. I think parameters like site-availability . would allow to determine if dynamic routing is required or not between PE and CE in this case.

Thoughts ?

Orange logo <http://www.orange.com/> 

Stephane Litkowski 
Network Architect 

phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20> 
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20> 
[email-masked] <mailto:[email-masked]>

---

From: Qin Wu <[email-masked]>
Date: Thu, 12 Nov 2015 08:20:34 +0000

I agree with Kenichi, it looks this issues is also related to M to N availability support issue
http://trac.tools.ietf.org/wg/l3sm/trac/ticket/3
since the same question was asked at that issue, i.e, one site with multiple attachment. If we consider to integrate customer specific information into the attachment, 
I am wondering where the attachment is applied, CE-PE, LAN-CE or LAN-CE-PE, when we define access-type(e.g.,primary access, backup access) for site availability,
Is this also applied to LAN-CE or access type is only applied to CE-PE segment? I think we should make this clear in the draft.

-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Ogaki, Kenichi
发送时间: 2015年11月11日 18:06
收件人: [email-masked]; [email-masked]
主题: Re: [L3sm] Modeling customer-specific-information => issue

Hi Stephane,

All the best,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 10, 2015 11:00 PM
To: [email-masked]
Subject: [L3sm] Modeling customer-specific-information => issue

Hi,

-          CE is provider managed

Thoughts ?

Stephane Litkowski 
Network Architect 

 

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm