Subject: Re: [L3sm] New Liaison Statement, "Liaison on MEF YANG Service models"

From: Qin Wu <[email-masked]>
Date: Wed, 11 Nov 2015 06:05:58 +0000

FYI.
-----邮件原件-----
发件人: Liaison Statement Management Tool [mailto:[email-masked]] 
发送时间: 2015年11月10日 3:51
收件人: The IETF Chair
抄送: Nan Chen; Raghu Ranganathan; Bill Bjorkman; The IETF Chair; [email-masked]; The IESG; [email-masked]; [email-masked]; Qin Wu
主题: New Liaison Statement, "Liaison on MEF YANG Service models"

Title: Liaison on MEF YANG Service models Submission Date: 2015-11-09 URL of the IETF Web page: https://datatracker.ietf.org/liaison/1439/

From:  (Raghu Ranganathan <[email-masked]>)
To:  (The IETF Chair <[email-masked]>)
Cc: 
Response Contacts: [email-masked]
Technical Contacts: 
Purpose: For information

Body: The MEF wants to communicate that MEF has approved a re-scope of a project to develop YANG models for MEF services. A copy of that re-scope is attached.

We request that you review the re-scope, and determine any overlap with your  work. We look forward to feedback from you on this subject.

The MEF Technical Committee meets next in Scottsdale, AZ in January 25-28, 2016. 

Attachments:

    YANG Modules Project Re-scope
    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-11-09-mef-ietf-liaison-on-mef-yang-service-models-attachment-1.pdf

    Liaison
    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2015-11-09-mef-ietf-liaison-on-mef-yang-service-models-attachment-2.pdf

---

From: Benoit Claise <[email-masked]>
Date: Mon, 16 Nov 2015 15:25:53 +0100

Dear all,

Thanks for your liaison and for sharing your scope of work for the 
development of YANG models for MEF services. We are pleased to see that 
MEF is considering using YANG as its modelling language: this is 
consistent with a decision made in the IETF to base all new data models 
on that language.

At the moment, the only service modelling underway in the IETF is in the 
Layer 3 VPN Service Model (L3SM 
<https://datatracker.ietf.org/wg/l3sm/charter/>) working group where the 
work is, of course, not overlapping with the type of services that MEF 
specifies. Your liaison was presented to that working group at our 
recent meeting in Yokohama where there was interest in your overall 
architecture.

We can't access the two documents mentioned at
- 
https://wiki.mef.net/login.action;jsessionid=5800C350AD1309E11C2885969478954E?os_destination=%2Fnotpermitted.action%3Fversion%3D1%26modificationDate%3D1422472916000%26api%3Dv2
- 
https://wiki.mef.net/login.action?os_destination=%2Fpages%2Fviewpage.action%3Ftitle%3D2015Q1-Denver-TC%26spaceKey%3DTC
As a consequence, we can't really evaluate the overlap.
However, thanks to Mahesh Jethanandani's presentation in L3SM, Liaison 
from MEF to L3SM, 
<https://www.ietf.org/proceedings/94/slides/slides-94-l3sm-4.pdf> we 
understand that MEF wants to focus on:
     * EVC based services as define in MEF 6.2
     * OVC based services as defined in MEF 51

I would note that there are different L2VPN technologies within the 
IETF: VPLS, pseudo-wire, etc.
If there were common concepts across the L2VPN technologies, it might be 
advantageous to highlight those in common YANG models.

You may additionally be interested in the work of the newly formed 
Simplified Use of Policy Abstractions (SUPA) working group that is 
tasked to come up with YANG representations of policy that may be 
re-used in service and configuration models in the future.

And finally, 
http://datatracker.ietf.org/doc/draft-bogdanovic-netmod-yang-model-classification/ 
has been created with the goal to define a common terminology around 
YANG models, not only for the IETF but also for the different standard 
development organizations (SDOs) and opensource projects.
There were no objections to the call for working group adoption during 
the NETMOD meeting at IETF 94.

Regards, Benoit
> Title: Liaison on MEF YANG Service models
> Submission Date: 2015-11-09
> URL of the IETF Web page: https://datatracker.ietf.org/liaison/1439/
>
> .

---

From: "Ranganathan, Raghu" <[email-masked]>
Date: Mon, 16 Nov 2015 09:35:59 -0500

Benoit
I will send email to you separately to find out what the two links are about.

We are aware of the "yang model classification" and the technology (VPLS/vpws, E-VPN) related work.
Thanks.

--Raghu
Sent from my phone

-----Original Message-----
From: Benoit Claise [[email-masked]]
Received: Monday, 16 Nov 2015, 8:26AM
To: Liaison Statement Management Tool [[email-masked]]; The IETF Chair [[email-masked]]
CC: Nan Chen [[email-masked]]; Ranganathan, Raghu [[email-masked]]; Bill Bjorkman [[email-masked]]; The IESG [[email-masked]]; [email-masked] [[email-masked]]; [email-masked] [[email-masked]]; Benoit Claise [[email-masked]]; [email-masked] [[email-masked]]
Subject: Re: New Liaison Statement, "Liaison on MEF YANG Service models"

Dear all,

Thanks for your liaison and for sharing your scope of work for the development of YANG models for MEF services. We are pleased to see that MEF is considering using YANG as its modelling language: this is consistent with a decision made in the IETF to base all new data models on that language.

At the moment, the only service modelling underway in the IETF is in the Layer 3 VPN Service Model (L3SM<https://datatracker.ietf.org/wg/l3sm/charter/>) working group where the work is, of course, not overlapping with the type of services that MEF specifies. Your liaison was presented to that working group at our recent meeting in Yokohama where there was interest in your overall architecture.

We can't access the two documents mentioned at
- https://wiki.mef.net/login.action;jsessionid=5800C350AD1309E11C2885969478954E?os_destination=%2Fnotpermitted.action%3Fversion%3D1%26modificationDate%3D1422472916000%26api%3Dv2<https://wiki.mef.ne/login.action;jsessionid=5800C350AD1309E11C2885969478954E?os_destination=%2Fnotpermitted.action%3Fversion%3D1%26modificationDate%3D1422472916000%26api%3Dv2>
- https://wiki.mef.net/login.action?os_destination=%2Fpages%2Fviewpage.action%3Ftitle%3D2015Q1-Denver-TC%26spaceKey%3DTC
As a consequence, we can't really evaluate the overlap.
However, thanks to Mahesh Jethanandani's presentation in L3SM, Liaison from MEF to L3SM,<https://www.ietf.org/proceedings/94/slides/slides-94-l3sm-4.pdf> we understand that MEF wants to focus on:
    * EVC based services as define in MEF 6.2
    * OVC based services as defined in MEF 51

I would note that there are different L2VPN technologies within the IETF: VPLS, pseudo-wire, etc.
If there were common concepts across the L2VPN technologies, it might be advantageous to highlight those in common YANG models.

You may additionally be interested in the work of the newly formed Simplified Use of Policy Abstractions (SUPA) working group that is tasked to come up with YANG representations of policy that may be re-used in service and configuration models in the future.

And finally, http://datatracker.ietf.org/doc/draft-bogdanovic-netmod-yang-model-classification/ has been created with the goal to define a common terminology around YANG models, not only for the IETF but also for the different standard development organizations (SDOs) and opensource projects.
There were no objections to the call for working group adoption during the NETMOD meeting at IETF 94.

Regards, Benoit

From:  (Raghu Ranganathan <[email-masked]><mailto:[email-masked]>)
To:  (The IETF Chair <[email-masked]><mailto:[email-masked]>)
Cc:
Response Contacts: [email-masked]<mailto:[email-masked]>
Technical Contacts:
Purpose: For information

Attachments:

    Liaison

.