Subject: [L3sm] comments on l3sm model-01 (mostly minor editorial)

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Fri, 6 Nov 2015 01:27:01 +0000

Hi all,

A few quick comments for things I noticed while cruising the model during the L3SM meeting:

'list sites [site-id]' should probably be 'list site [site-id]'  (containers that contain lists are often plural but the name of the list object itself is typically singular).   E.g. site abc rather than sites abc.

Same singular/plural comment for 'list rules' (and probably a good idea to scan the whole model for this singular/plural naming of lists).
Having the descriptions of the various objects as the *last* item makes it a little less friendly to read.  It might be nice to have those closer to the object declaration statement (whatever the canonical YANG rules allow I suppose).

Perhaps clarify that std-qos-profile points to an object outside of this model.

There are a few qos descriptions that use the term 'marking'.  Should those say 'classification' instead ?  I realize the intention was probably to describe this as *internal* marking (metadata internal to the PE) but the term 'marking' may cause confusion (e.g. DSCP marking/remarking).  The 2nd description here also seems incorrect/incomplete.

                      description
                       "List of marking rules.";
                  }
                  description
                   "Need to express marking rules ...";

The rate-limit and guaranteed-bw-percent make reference to a term called 'svc-bw'.  Is that svc-input-bandwidth, svc-output-bandwidth or something else ?  I suppose in theory those qos-profile parms (rate-limit) could apply to ingress at the PE (i.e. ingress SLA enforcement in a queue or policer) or a egress to the PE (i.e. egress queueing/scheduling in the PE towards the CE).  Or maybe they apply to both directions ?  It would be good to clarify this (or illustrate a few qos examples and describe what they are achieving).

Some of the explanatory text up in the body of the document should be copied right into the description fields of the YANG module.  For example -> priority-level (explain that it is purely exhaustive type servicing right in the module).

Regards,
Jason

---

From: Qin Wu <[email-masked]>
Date: Thu, 12 Nov 2015 08:23:41 +0000

Thanks Jason for valuable review and good suggestions. Authors, please take care of these comments.

-Qin
发件人: L3sm [mailto:[email-masked]] 代表 Sterne, Jason (Jason)
发送时间: 2015年11月6日 9:27
收件人: [email-masked]
主题: [L3sm] comments on l3sm model-01 (mostly minor editorial)

Hi all,

‘list sites [site-id]’ should probably be ‘list site [site-id]’  (containers that contain lists are often plural but the name of the list object itself is typically singular).   E.g. site abc rather than sites abc.

Same singular/plural comment for ‘list rules’ (and probably a good idea to scan the whole model for this singular/plural naming of lists).
Having the descriptions of the various objects as the *last* item makes it a little less friendly to read.  It might be nice to have those closer to the object declaration statement (whatever the canonical YANG rules allow I suppose).

There are a few qos descriptions that use the term ‘marking’.  Should those say ‘classification’ instead ?  I realize the intention was probably to describe this as *internal* marking (metadata internal to the PE) but the term ‘marking’ may cause confusion (e.g. DSCP marking/remarking).  The 2nd description here also seems incorrect/incomplete.

                      description

The rate-limit and guaranteed-bw-percent make reference to a term called ‘svc-bw’.  Is that svc-input-bandwidth, svc-output-bandwidth or something else ?  I suppose in theory those qos-profile parms (rate-limit) could apply to ingress at the PE (i.e. ingress SLA enforcement in a queue or policer) or a egress to the PE (i.e. egress queueing/scheduling in the PE towards the CE).  Or maybe they apply to both directions ?  It would be good to clarify this (or illustrate a few qos examples and describe what they are achieving).

Regards,
Jason