Subject: Re: New work items

From: Danny McPherson <[email-masked]>
Date: Wed, 9 Sep 2009 09:04:41 -0600

Top post only..

Eric,
Apologies for taking so long to respond on this, thanks for
kicking off the thread!

Do other folks have comments on these items or other items that
should be added to the charter?  We'd like to have a new one in
front of the IESG before the .jp meeting.

Thanks!

-danny

On Aug 24, 2009, at 9:12 AM, Eric Rosen wrote:

> I read the following in the L3VPN WG minutes:
>
> Danny McPherson:
>
>    There is work.  There are things that need to be considered. We  
> should
>    revisit our milestones now that the MVPN documents have been  
> submitted
>    to the IESG, that was a gate for an official new work in the WG,  
> now we
>    can consider new work items.
>
> I am glad to see that it is finally time to consider new work  
> items.  I have
> been collecting a bunch of new work items for some time in draft- 
> rosen-
> l3vpn-mvpn-mspmsi:
>
> - S-PMSI Join extensions (for MPLS and for MVPNv6)
>
> - Wild card support in S-PMSI A-D routes and S-PMSI Joins
>
> - Finish the specification for the use of bidirectional P-tunnels
>
> - Using PIM as PE-PE control plane, but without using MI-PMSI (i.e.,
>  eliminating the use of trees that only carry control packets)
>
> - Extranet support using PIM control plane
>
> - Offering MVPN service with PIM control plane in concert with  
> unicast "Hub
>  and Spoke" VPN service and anycast-source service.
>
> I think the draft mentioned above is an excellent basis for future  
> work.
> That draft could really be turned into a half dozen or so different  
> drafts,
> each addressing a particular topic, if the WG prefers that  
> approach.  (I
> kept them all in one document primarily to make it easier for me to  
> manage
> during the period when the WG was not considering new work items.)
>
> So I would like to propose each of the above-listed items as a new  
> work
> item for the WG.
>
> I would also like to solicit feedback about the above-mentioned  
> document,
> e.g., is it acceptable as a WG draft, would it be better to split it  
> up and
> ask each this question about each part, does anyone have any technical
> comments on it?
>
> Feedback from other than the usual suspects would be especially  
> valuable ;-)
>
>
>
>
>
>

---

From: Benson Schliesser <[email-masked]>
Date: Thu, 10 Sep 2009 13:39:53 -0500

If it helps: I'd like to express support for the goals outlined by  
Eric, especially "Extranet support using PIM control plane".

Cheers,
-Benson

On 9 Sep 09, at 10:04 AM, Danny McPherson wrote:

>> e.g., is it acceptable as a WG draft, would it be better to split  
>> it up and

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 15 Sep 2009 12:05:48 -0700

Danny,

>From the L3VPN WG minutes:

 Danny McPherson:

    There is work.  There are things that need to be considered. We should
    revisit our milestones now that the MVPN documents have been submitted
    to the IESG, that was a gate for an official new work in the WG, now we
    can consider new work items.

The consideration document (draft-ietf-l3vpn-mvpn-considerations-04),
which is part of the MVPN documents, have not (yet) been submitted
to the IESG. Therefore, until this document is submitted to the IESG, 
the WG should not be considering any new work items.

Yakov.

---

From: "NAPIERALA, MARIA H, ATTLABS" <[email-masked]>
Date: Tue, 15 Sep 2009 16:56:43 -0400

Danny, et al.,

the progress of draft-ietf-l3vpn-mvpn-considerations-04 (which is an
*informational* document) should not interfere with the actual progress
of MVPN technology (i.e., with the progress of the documents that define
the technology). The new work items which were listed are required to
support MVPNs already deployed in production networks. 
The draft-ietf-l3vpn-mvpn-considerations-04 should and can progress
independently of the technical work.

Maria

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Yakov Rekhter
> Sent: Tuesday, September 15, 2009 3:06 PM
> To: Danny McPherson
> Cc: [email-masked]
> Subject: Re: New work items
> 
> Danny,
> 
> > Top post only..
> >
> > Eric,

---

From: Ross Callon <[email-masked]>
Date: Tue, 15 Sep 2009 22:20:08 -0400

At the Dublin IETF, Mark Townsley, who was AD for L3VPN at the time, gave L3VPN a six month time limit to get the currently chartered multicast work completed. The threat was that if it wasn't completed then multicast would be removed from the WG charter and the documents would need to be submitted as individual submissions via the RFC editor. Given the very many options in the two L3VPN multicast drafts that have recently been submitted for publication, and the resulting potential lack of interoperability, I don't regard the currently chartered work to be complete until the considerations draft is submitted for publication. At the Dublin IETF I fully supported Mark's deadline. As AD for the L3VPN working group I still fully support Mark's deadline but with one slight change (see next paragraph). The L3VPN working group has been working on multicast for more than 5 years. For example, the minutes from IETF 60 (August 2004) state "A new working group charter has been approved. In particular the new charter adds the following items (which are heavily involved in this meetings agenda): l3vpn support for multicast and l3vpn support for IPv6". If the group can't get its currently chartered multicast work completed in more than five years then why should we charter additional multicast work?

Clearly more than six months have passed since the Dublin IETF. However, very considerable work has been completed since then and my inclination is to not drop the "six months is over" axe on the group as long as it appears that the group is about to complete its originally charted multicast work. 

Also, the chairs have informed me that the considerations draft appears to be quite close to being complete. My reading of the draft suggests the same thing. After this is complete, then it makes sense to re-charter the WG to take on additional work. I fully expect that the additional work will be mostly (or perhaps entirely) multicast related. I also think that it is perfect reasonable to want useful work to continue in the L3VPN WG without a hiccup caused by rechartering, and recent emails suggest that achieving consensus on rechartering might be non-trivial. This implies that we should think now about what additional work is needed. I would expect that as soon as possible (hopefully immediately?) after completion of the considerations draft then the group will be rechartered and the additional work will begin. Hopefully this implies that the additional work can begin at the Hiroshima IETF meeting. 

However, don't expect the updated charter to be approved until the current work is completed. Given the large number of options available in the two multicast specifications that have already been submitted, don't expect the IESG to approve these without some guidance regarding what subset of the many available options we expect in interoperable implementations. 

Ross (speaking as AD for L3VPN)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of NAPIERALA, MARIA H, ATTLABS
Sent: 15 September 2009 16:57
To: Yakov Rekhter; Danny McPherson
Cc: [email-masked]
Subject: RE: New work items 

Danny, et al.,

Maria

---

From: Eric Rosen <[email-masked]>
Date: Wed, 16 Sep 2009 00:50:34 -0400

> If the group can't get its currently chartered multicast work completed in
> more than five years then why should we charter additional multicast work?

Could you point to the particular sentences in the charter that distinguish
what you call the "currently chartered multicast work" from the "additional
chartered work"?

If you cannot do so, then one might conclude that the new work items that
have been suggested fall under the existing charter and no rechartering is
necessary.  One might also conclude that the WG is nowhere near completing
its chartered work.

> Clearly more than six months have passed since the Dublin IETF. However,
> very considerable work has been completed since then

This isn't really accurate.  The work that was recently submitted to the
IESG was substantially completed before that time.  Since then, there was
some review during WG LC, but that was substantially completed early in
2009.

> don't expect the IESG to approve these without some guidance regarding
> what subset of the many available options we expect in interoperable
> implementations.

My practical advice would be that you shouldn't base your expectations about
this too heavily on the guidance provided in any particular document.

---

From: Ross Callon <[email-masked]>
Date: Wed, 16 Sep 2009 11:29:03 -0400

> > If the group can't get its currently chartered multicast work
> > completed in more than five years then why should we charter
> > additional multicast work?
>
> Could you point to the particular sentences in the charter that 
> distinguish what you call the "currently chartered multicast work"
> from the "additional chartered work"?

The current 5+ year old charter is indeed rather vague regarding what multicast work is needed (or was anticipated as needed 5 years ago). This is something that would have been nice to have fixed long ago. Given that the future work of L3VPN is likely to be largely on multicast, it would be desirable to figure out what future work we can currently anticipate is wanted and get the charter updated. Of course we are not likely to be perfect in terms of anticipating what we are going to want to do in the future, and will most likely need to recharter again some day. 

> If you cannot do so, then one might conclude that the new work items
> that have been suggested fall under the existing charter and no 
> rechartering is necessary.  One might also conclude that the WG is
> nowhere near completing its chartered work.

I suppose that the IDR charter could be re-written to say a very simple "work on BGP enhancements forever". This would be a pretty accurate top-level description of what IDR does, and might not be all that different from the L3VPN WG's charter's current description of multicast work. However we generally try to be more specific that that.

> > Clearly more than six months have passed since the Dublin IETF.
> > However, very considerable work has been completed since then
>
> This isn't really accurate.  The work that was recently submitted
> to the IESG was substantially completed before that time.  Since
> then, there was some review during WG LC, but that was substantially 
> completed early in 2009.

I agree that the recently submitted work was mostly completed by you and others many years ago. The main thing that has been accomplished since Dublin on the two recently submitted documents was to get WG consensus to go ahead and publish them (with some additional review). The agreement to publish the documents is a big deal. 

Ross

---

From: ycai <[email-masked]>
Date: Wed, 16 Sep 2009 11:01:17 -0700

On 9/15/09 7:20 PM, "Ross Callon" <[email-masked]> wrote:

> 
> At the Dublin IETF, Mark Townsley, who was AD for L3VPN at the time, gave
> L3VPN a six month time limit to get the currently chartered multicast work
> completed. The threat was that if it wasn't completed then multicast would be
> removed from the WG charter and the documents would need to be submitted as
> individual submissions via the RFC editor. Given the very many options in the
> two L3VPN multicast drafts that have recently been submitted for publication,
> and the resulting potential lack of interoperability, I don't regard the
> currently chartered work to be complete until the considerations draft is
> submitted for publication. At the Dublin IETF I fully supported Mark's
> deadline. As AD for the L3VPN working group I still fully support Mark's
> deadline but with one slight change (see next paragraph).

Ross,

Would you mind sharing with us the reasons why you accommodated this change
then,  but not before or after?

> The L3VPN working
> group has been working on multicast for more than 5 years. For example, the
> minutes from IETF 60 (August 2004) state "A new working group charter has been
> approved. In particular the new charter adds the following items (which are
> heavily involved in this meetings agenda): l3vpn support for multicast and
> l3vpn support for IPv6". If the group can't get its currently chartered
> multicast work completed in more than five years then why should we charter
> Clearly more than six months have passed since the Dublin IETF. However, very
> considerable work has been completed since then and my inclination is to not
> drop the "six months is over" axe on the group as long as it appears that the
> group is about to complete its originally charted multicast work.
> 
> Also, the chairs have informed me that the considerations draft appears to be
> quite close to being complete. My reading of the draft suggests the same
> thing. After this is complete, then it makes sense to re-charter the WG to
> take on additional work. I fully expect that the additional work will be
> mostly (or perhaps entirely) multicast related. I also think that it is
> perfect reasonable to want useful work to continue in the L3VPN WG without a
> hiccup caused by rechartering, and recent emails suggest that achieving
> consensus on rechartering might be non-trivial.

Between Eric's email sent on 8/24 and yours, there has been exactly 4 emails
following this thread, from Danny, Benson, Yakov and Maria, with only
Yakov's email expressing desire for the WG to consider new work items until
after the consideration draft was submitted to IESG.

So I can hardly see anything substantial that is contentious.

The considerations draft does not contain technical work.  And I don't see
it contradicts/precludes anything with the new work items being proposed.
So there is no reason why technical work should be held up awaiting its
submission to the IESG.

Thanks.

-- 
Yiqun

> This implies that we should
> think now about what additional work is needed. I would expect that as soon as
> possible (hopefully immediately?) after completion of the considerations draft
> then the group will be rechartered and the additional work will begin.
> Hopefully this implies that the additional work can begin at the Hiroshima
> IETF meeting. 
> 
> However, don't expect the updated charter to be approved until the current
> work is completed. Given the large number of options available in the two
> multicast specifications that have already been submitted, don't expect the
> IESG to approve these without some guidance regarding what subset of the many
> available options we expect in interoperable implementations.
>

---

From: Eric Rosen <[email-masked]>
Date: Mon, 21 Sep 2009 11:49:16 -0400

Ross> The current 5+ year old charter is indeed rather vague regarding what
Ross> multicast work is needed (or was anticipated as needed 5 years
Ross> ago). This is something that would have been nice to have fixed long
Ross> ago. Given that the future work of L3VPN is likely to be largely on
Ross> multicast, it would be desirable to figure out what future work we can
Ross> currently anticipate is wanted and get the charter updated.

I don't think there is any need to change the rules in the middle of the
game.  The charter is fine the way it is.  In any event, until it is
changed, I see no justification for failing to accept "new" work items.

Ross> I suppose that the IDR charter could be re-written to say a very
Ross> simple "work on BGP enhancements forever". This would be a pretty
Ross> accurate top-level description of what IDR does, and might not be all
Ross> that different from the L3VPN WG's charter's current description of
Ross> multicast work

I think that's a fairly good model, as it allows for relatively quick
response to customer demands.  In many cases features are going to get
implemented anyway, and the IETF should encourage, not discourage, the
creation of public specifications for IETF review.  If the IESG had to
pre-approve the addition of every new BGP feature to the IDR charter, the
IDR WG would be a lot less useful.

---

From: <[email-masked]>
Date: Mon, 28 Sep 2009 18:35:21 +0100

Eric, Colleagues

> IDR WG would be a lot less useful.

My understanding (which of course could be wrong) was the purpose of
re-chartering was not to artificially restrict what L3VPN related things
could be worked on but rather to say "these are some specific work items we
think we will likely focus on as we see a demand for them now or in the near
future"

Ben

---

From: Ross Callon <[email-masked]>
Date: Mon, 28 Sep 2009 13:56:52 -0400

> My understanding (which of course could be wrong) was the purpose
> of re-chartering was not to artificially restrict what L3VPN
> related things could be worked on but rather to say "these are
> some specific work items we think we will likely focus on as we
> see a demand for them now or in the near future"
>
> Ben

This is correct. This is also the normal process for IETF WGs. 

thanks, Ross

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 28 Sep 2009 20:02:00 +0200

Hi Benjamin,

Is there anything in the current L3VPN charter which would prohibit to 
focus on any specific topics which we would see a demand for in this 
particular WG ?

If you could provide some examples it would be really helpful.

Many thx,
R.

---

From: <[email-masked]>
Date: Mon, 28 Sep 2009 22:22:31 +0100

Robert,

> focus on any specific topics which we would see a demand for in this

I think you may misunderstand me, I am not suggesting the current charter
prohibits anything just that calling out specific items in the charter that
the WG knows there to be a need for or interest in would be useful.

> If you could provide some examples it would be really helpful.

Eric previously provided a list of work items that provide examples of the
sort of work items/topics that it may be valuable to list explicitly.

Ben