Subject: Re: Poll to adopt initial milestones for the new L3VPN charter

From: Eric Rosen <[email-masked]>
Date: Mon, 04 Oct 2010 10:41:29 -0400

Yakov> The current specs makes it very clear that mp2mp LSPs with PE
Yakov> Distinguisher Labels are applicable only when supporting C-Bidir.

Eric> The current specs place no restrictions on the applicability of PE
Eric> Distinguisher Labels.

Yakov> The architecture spec describes the use of PE Distinguisher Labels
Yakov> in section 11.2.2. 11.2.2 is part of section 11. And the title
Yakov> of section 11 is "11. Support for PIM-BIDIR C-Groups".

That is the only use of them that is fully specified in the architecture
spec.  However, nothing in the architecture spec restricts their use to this
case.  Quite the contrary.  The architecture spec has Several places where
it mentions PE Distinguisher Labels, and refers to section 6.4.4:

6.4.4. mLDP MP2MP LSPs

   Specification of the procedures for assigning C-flows to mLDP MP2MP
   LSPs that serve as P-tunnels is outside the scope of this document.

Quite clearly the use of PE Distinguisher Labels in S-PMSI A-D routes that
specify mLDP MP2MP LSPs is anticipated, but the full specification is left
to another document.

> The current specs does address the details of PE Distinguisher Labels
> usage in sufficient level of details.

The "current specs" do not even ask IANA to assign a code point for the PE
Distinguisher labels attribute ;-)

Eric> If you are trying to support C-bidir using a single MP2MP LSP with PE
Eric> Distinguisher Labels, the root of the LSP must assign a label to each
Eric> PE that can be selected by any other PE (in the VPN) as the upstream
Eric> PE for some C-RPA.  I don't think there is any way for the PE at the
Eric> root to know which of the other PEs fall into this subset.

Yakov> There is a way for that PE to know this - just look at the (unicast)
Yakov> VPN-IP routes to C-RPA. Only the PEs that advertise such routes
Yakov> need to have Distinguisher Labels.

Okay, I will add some text describing this as an option.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 29 Oct 2010 18:01:55 +0100

Colleagues,

My co-chairs and I agree that there is sufficient consensus to adopt the five proposed milestones listed in my original e-mail below.

I will now work with the ADs on progressing the new charter with these milestones.

As we took some time to debate the milestones and judge the consensus, the milestones do not quite reflect our current state in time, i.e.

- We have already submitted MVPNv6 using PIM & S-PMSIs to IESG. I will seek AD guidance on what to do here (either submit as Done already or just drop from the list).
- The dates for iBGP and MVPN infrastructure address milestones look tight (or already passed) so I will change those to Jan-11 to give us time to finish them off and submit to IESG.

Thanks
Ben

On 31 Aug 2010, at 07:44, Benjamin Niven-Jenkins wrote:

> Colleagues,
> 
> Due to it being the holiday season we will extend the poll on the milestones until 6th September.
> 
> Please send your opinions to the list or the chairs if you haven't already done so.
> 
> Thanks
> Ben
> 
> On 16 Aug 2010, at 18:27, Ben Niven-Jenkins wrote:
> 
>> Colleagues,
>> 
>> This e-mail starts a 2 week poll on adopting the milestones listed below as part of the new L3VPN charter.
>> 
>> Can you please respond with
>> 
>> a) "accept all" or "do not accept all" indicating you are either happy(/unhappy) with all the milestones.
>> b) yes/accept or no/do not accept on a per milestone basis if you feel we should adopt some but not all of the milestones.
>> 
>> This poll will close at the end of Monday 23rd August.
>> 
>> The proposed milestones are:
>> Oct-10	Submit MVPNv6 using PIM & S-PMSIs specification to IESG as PS.
>> Oct-10	Submit specification for using Internal BGP as PE-CE protocol to IESG as PS
>> Nov-10	Submit MVPN infrastructure address encoding document to IESG for publication as PS.
>> May-11	Submit S-PMSI A-D route Wildcard selection specification to IESG as PS.
>> Nov-11	Submit MVPN Extranet specification to IESG as PS.
>> 
>> The new L3VPN charter text can be found at:
>> http://www.niven-jenkins.co.uk/L3VPN/New-L3VPN-Charter-01.txt
>> 
>> 
>> Thanks
>> Ben
>> 
>