Subject: [ldapext] UUIDs should be case-insensitive

From: Hallvard B Furuseth <[email-masked]>
Date: Sat, 28 Jun 2003 20:08:45 +0200

draft-zeilenga-ldap-uuid-00.txt says

  2.2 'uuidMatch' Matching Rule

  The 'uuidMatch' matching rule compares an asserted UUID with a stored
  UUID for equality.  Its semantics are same as octetStringMatch

However, http://www.opengroup.org/onlinepubs/9629399/apdxa.htm says

  String Representation of UUIDs

  The hexadecimal values a to f (...) are case insensitive on input.

So it seems to me the UUID matching rule should be caseIgnoreIA5Match,
and thus the the syntax should be IA5 String.

-- 
Hallvard

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 28 Jun 2003 11:14:41 -0700

>and thus the the syntax should be IA5 String.

Note that comparison is between UUIDs, not the string representations
of the UUIDs, hence octetStringMatch is the correct rule.

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Sat, 28 Jun 2003 20:38:27 +0200

> of the UUIDs, hence octetStringMatch is the correct rule.

Whoops.  Good point.

-- 
Hallvard