Subject: [ldapext] I-D ACTION:draft-zeilenga-ldap-readentry-00.txt

From: [email-masked]
Date: Tue, 24 Jun 2003 06:42:21 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: LDAP Read Entry Controls
	Author(s)	: K. Zeilenga
	Filename	: draft-zeilenga-ldap-readentry-00.txt
	Pages		: 8
	Date		: 2003-6-23
	
This specification describes controls which can be attached to a
Lightweight Directory Access Protocol (LDAP) update request to obtain
copies of the target entry before and/or after the requested update is
applied.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-zeilenga-ldap-readentry-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-zeilenga-ldap-readentry-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-zeilenga-ldap-readentry-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 24 Jun 2003 10:25:09 -0700

In this I-D, I've detailed controls that a client can use to
read the target entry of an update operation before and/or after
the update is applied.

In my last minute rush to submit this, I made a cut-n-paste from
the pre-read to the post-read section and failed to make all of
the appropriate edits to the pasted text.  The post-read request
control is appropriate for add not delete and returns the entry
after the update not before it.

That is, the text should be updated as indicated by this
unified diffs of the post-read section:

-This control is appropriate for the modifyRequest,
-delRequest, and modDNRequest LDAP messages.
+This control is appropriate for the addRequest,
+modifyRequest, and modDNRequest LDAP messages.

and:
 When the request control is attached to an appropriate update LDAP
 request, the control requests the return of a copy of target entry
-prior to the application of the update.
+after the application of the update.

These errors will be corrected in the next revision (to be
submitted immediately after IETF#57).

Kurt

PS: Thanks to Andrew for pointing this error out to me.

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext