Subject: [ledbat] First version of related work survey available

From: Michael Welzl <[email-masked]>
Date: Fri, 27 Feb 2009 11:20:29 +1100

Hi all,

I just submitted the first version of draft-ietf-ledbat-survey-00.txt,
"A Survey of Lower-than-Best Effort Transport Protocols", which is
intended to be a starting point for the new transport protocol
that LEDBAT should develop.

It's quite short and incomplete, but I think (hope) that it should
already be quite useful as a starting point. To give you access
until it's available from the usual draft sources, I put it here:
http://www.welzl.at/research/publications/draft-ietf-ledbat-survey-00.txt

Sadly I can't make it to SF to present it. However, this being just
a survey, I don't see a big problem with someone else presenting it.
Questions / discussions should probably not be about the draft
itself but rather about the meaning of the text for LEDBAT - about
the direction to take...

Cheers,
Michael

---

From: Michael Welzl <[email-masked]>
Date: Fri, 27 Feb 2009 11:41:42 +1100

Sorry,

> that LEDBAT should develop.

I know that it's not the plan to do a whole new protocol -
just a congestion control algorithm. As a matter of fact,
having written the survey and read the references that I
included, one of the questions I'd ask is: could this
algorithm even be run at the application level, by simply
tuning the rwnd of transport protocols that we want to use?

Actually I think so.

Cheers,
Michael

---

From: Murari Sridharan <[email-masked]>
Date: Thu, 26 Feb 2009 23:59:32 -0800

Yes very much so. In fact one of our solutiosn for low priority already does something like this. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Welzl
Sent: Thursday, February 26, 2009 4:42 PM
To: [email-masked]
Subject: Re: [ledbat] First version of related work survey available

Sorry,

Actually I think so.

Cheers,
Michael

_______________________________________________
ledbat mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ledbat

---

From: Murari Sridharan <[email-masked]>
Date: Fri, 27 Feb 2009 00:03:48 -0800

Thanks much for submitting this. I'll read through it and get back to you with comments. We'll find somebody to present it on your behalf, yes we will use this as a starting point for possible LEDBAT solutions. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Welzl
Sent: Thursday, February 26, 2009 4:20 PM
To: [email-masked]
Subject: [ledbat] First version of related work survey available

Hi all,

Cheers,
Michael

---

From: Enrico Marocco <[email-masked]>
Date: Fri, 27 Feb 2009 10:16:13 +0100

> I just submitted the first version of draft-ietf-ledbat-survey-00.txt,

draft-ietf-ledbat? I don't recall neither can find traces of any
discussions about adopting such a draft as WG item. Just messing with
names, or am I missing something?

-- 
Ciao,
Enrico