Subject: Re: [Lwip] New Version Notification for draft-ma-lwip-stack-analysis-00

From: Zhen Cao <[email-masked]>
Date: Tue, 26 Oct 2010 23:49:46 +0800

Hi

I have some questions regarding section 2.2, I do not quite understand
the following statements:

" The fragmentation of IP packets used in blip provides several
problems, in particular when using multi-hop".

What's the fragmentation issues for the Blip in a multihop
environment?  Thank you

2010/10/18 MA, YUAN CHEN -HCHBJ <[email-masked]>:
> Dear all
>
> Please check the 00 draft for the BOF.
> Comments are welcomed.
>
> Thank you.
> Regards
> Yuanchen
> A new version of I-D, draft-ma-lwip-stack-analysis-00.txt has been
> successfully submitted by Yuanchen Ma and posted to the IETF repository.
>
> Filename:        draft-ma-lwip-stack-analysis
> Revision:        00
> Title:           Stack Analysis for Lightweight IP Implementation
> Creation_date:   2010-10-17
> WG ID:           Independent Submission
> Number_of_pages: 12
>
> Abstract:
> This document analyzes the main implementation of lightweight IP
> stack over constrained platform, including Contiki, TinyOS, and Atmel
> RUM approach.  The consideration for lightweight IP stack
> implementation is summarized.  The target of this document is to
> facilitate the ongoing/future developers on lightweight IP stack and
> provide guideline for lightweight IP stack implementation by
> documenting the related techniques.
>
>
>
> The IETF Secretariat.
>
>
>
> ________________________________
> Disclaimer: The contents of this e-mail, and its attachments, if any, are
> confidential and may be protected by law against any unauthorized use. If
> you have received this e-mail by mistake or have reason to believe that you
> are not the intended recipient, please notify the sender by reply e-mail as
> soon as possible and delete it from your computer system immediately
> thereafter. If you are not the intended recipient, you must not copy this
> e-mail or attachment or disclose the contents to any other person. While we
> have made every effort to keep our network virus free, we take no
> responsibility for any computer virus which might be transferred by way of
> this e-mail.
> ________________________________
>
>
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>
>

-- 
Best regards,
Zhen

---

From: Xuan He <[email-masked]>
Date: Thu, 28 Oct 2010 12:00:12 +0800

Hi

This is accroding to the explanation of blip 2.0 developer:

[There seems to be an issue with the serial port on the meraki.  The
effect is that packets are dropped when you send too quickly.  This
mostly effects fragmentation.  As a stopgap, I've inserted a timeout
between fragments, but this means the performance is somewhat worse
then on a PC and a micaz.

by author Stephen Dawson-Haggerty stevedh at eecs.berkeley.edu
<https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-2-commits>]

In my understanding, in multi-hop network, packets are dropped in
every hop, which hurts the data integrality badly.

Regards
Hex

---------- Forwarded message ----------
From: Zhen Cao <[email-masked]>
Date: 2010/10/26
Subject: Re: [Lwip] New Version Notification for
draft-ma-lwip-stack-analysis-00
To: "MA, YUAN CHEN -HCHBJ" <[email-masked]>
抄送： [email-masked]

Hi

2010/10/18 MA, YUAN CHEN -HCHBJ <[email-masked]>:
> https://www.ietf.org/mailman/listinfo/lwip</exchweb/bin/redir.asp?URL=https://www.ietf.org/mailman/listinfo/lwip>
>
>

--
Best regards,
Zhen
_______________________________________________
Lwip mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lwip</exchweb/bin/redir.asp?URL=https://www.ietf.org/mailman/listinfo/lwip>