Subject: [Lwip] Comments on draft-chen-lwip-implementataion-00.txt

From: Hui Deng <[email-masked]>
Date: Fri, 29 Oct 2010 22:54:14 +0800

Dear authors,

thanks for writing this document, I have 2 clarifications.
Section 1: What's the relationship between callback function and physical
memory?

Section 3: are you saying all socket options are not needed?

maybe this draft has close relationship with stack analysis draft,

Best regards,

-Hui

---

From: ma yc <[email-masked]>
Date: Sun, 31 Oct 2010 19:21:34 +0800

Dear authors

Thanks for the interesting draft. I think it a good point to eliminate
some part of the
TCP function in the TCP implementation. However i have some questions on your
implementation detail.

Section 5, you mentioned ARP, does it imply IPv4 is used in your stack?

Also in section 5, it is said "ICMP can merely implement echo request
and echo reply."
However for IPv6 address autoconfiguration, etc., NDP is necessary. Is
NDP implemented
in your stack?

Your clarification is appreciated.

Thank you.
Regards

2010/10/29 Hui Deng <[email-masked]>:
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>
>