Subject: [Lwip] FW: bed TLS Numbers for draft-ietf-lwig-tls-minimal

From: "Simpson, Robby (GE Energy Management)" <[email-masked]>
Date: Tue, 1 Sep 2015 14:20:04 +0000

Hi Hannes,

I see that your activities in lwip are gathering momentum – that's great!

I did not hear back from you on the following, but please feel free to let me know if there is anything that I can do to help or if any numbers would be interesting.  Some details on my blog: http://robbysimpson.com/2015/05/14/implementing-http2-with-mbed-tls/

Thanks,
Robby

From: Charles Simpson <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 8, 2015 at 1:58 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: bed TLS Numbers for draft-ietf-lwig-tls-minimal

Hi Hannes,

I've been playing with mbed TLS for a little while now, in particular trying to implement the HTTP/2 MTI ciphersuite (TLS-ECDHE-RSA-WITH-AES-128-GCM-SHA256) for an SoC with a Cortex-M4 core.

I thoroughly enjoyed your "Performance Investigations" presentation at IETF and was wondering if there is anything that I could help with.

I'm guessing, being with ARM, you have plenty of access to mbed TLS, but if any numbers would help from me, please let me know.

Thanks,
Robby

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 1 Sep 2015 17:41:06 +0200

Hi Robby,

sorry that I missed your message and thanks for the pointer to your blog
post.

There are definitely a number of things you could help with, namely
* Verification of the existing results.
* More data from other crypto libraries (or even DTLS/TLS stacks).
* Tests run on other hardware platforms (such as the Cortex M7).
* Tests beyond performance, such as RAM usage, flash size, etc.
* Tests that focus on other cryptographic algorithms.
* Data for the entire TLS/DTLS protocol (or anything that can be found
in the DTLS/TLS profile document).

Ciao
Hannes

On 09/01/2015 04:20 PM, Simpson, Robby (GE Energy Management) wrote:
> I did not hear back from you on the following, but please feel free
> to let me know if there is anything that I can do to help or if any
> numbers would be interesting.  Some details on my blog:
> http://robbysimpson.com/2015/05/14/implementing-http2-with-mbed-tls/
>
> Thanks, Robby
>
> From: Charles Simpson
> <[email-masked]<mailto:[email-masked]>> Date: Wednesday,
> April 8, 2015 at 1:58 PM To:
> "[email-masked]<mailto:[email-masked]>"
> <[email-masked]<mailto:[email-masked]>>
> I've been playing with mbed TLS for a little while now, in particular
> trying to implement the HTTP/2 MTI ciphersuite
> (TLS-ECDHE-RSA-WITH-AES-128-GCM-SHA256) for an SoC with a Cortex-M4
> core.
>
> I thoroughly enjoyed your "Performance Investigations" presentation
> at IETF and was wondering if there is anything that I could help
> with.
>
> I'm guessing, being with ARM, you have plenty of access to mbed TLS,
> but if any numbers would help from me, please let me know.
>
> Thanks, Robby
>