Subject: [Lwip] Magnus Westerlund's Discuss on draft-ietf-lwig-curve-representations-19: (with DISCUSS)

From: Magnus Westerlund via Datatracker <[email-masked]>
Date: Mon, 15 Feb 2021 06:12:05 -0800

Magnus Westerlund has entered the following ballot position for
draft-ietf-lwig-curve-representations-19: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lwig-curve-representations/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

So this is process violation discuss. This document is up for approval as
standards track. However, there are no evidence that it was ever IETF last
called for standards track. I only find evidence for a IETF last call intended
for informational on 2020-08-25.

I have not reviewed the content of document yet. I would propose that the
responsible AD pulls this document from this telechat and then performs the
IETF last call before it gets scheduled again.

---

From: Erik Kline <[email-masked]>
Date: Mon, 15 Feb 2021 16:43:59 -0800

> https://datatracker.ietf.org/doc/draft-ietf-lwig-curve-representations/

Argh, I completely missed that the intended status had been changed on
draft 14 from the LC (draft 12).

    2020-11-18 14 Mohit Sethi Changing to proposed standard as
requested by the COSE experts.
    2020-11-18 14 Mohit Sethi Intended Status changed to Proposed
Standard from Informational

---

From: Erik Kline <[email-masked]>
Date: Mon, 15 Feb 2021 17:06:45 -0800

Rene and Mohit have the full history (starting from 2018), but as I
understand it, the work grew out of the 6lo-ap-nd doc (now RFC 8928;
see all the "CURVE-REPR" references sprinkled throughout).  It was in
support of these IPv6 ND extensions for IoT devices that this draft
was started.

Section 7 of this draft is about Implementation Status.  It contains a
pointer to a software implementation and a web page discussing a
hardware implementation of mapping to a Weierstrass form that is
described in this doc (AIUI), though the 2nd paragraph states some
important caveats.  I'll have to leave it to others to discuss any
further implementation experiences not documented in section 7.

---

From: Mohit Sethi M <[email-masked]>
Date: Tue, 16 Feb 2021 09:17:11 +0000

Argh, I find this email very misleading. I did change the status of the draft but the ADs were well aware of this change. Erik Kline in his email on 14th Jan wrote:

Rene,

I'm trying to catch up on all the changes between -12 and -19.  At a minimum, since this has been changed from Informational to Standards Track I think we should have another IETF Last Call.  I'll have a read through the full diff tomorrow afternoon and see if I can figure out what's next.

In my email response I did state that running another last call may not necessarily bring in more reviews as the draft is rather crypto-heavy (and the contents have remained the same). But I left the final decision to the ADs. I had written:

I feel that another last call may not necessarily result in more meaningful reviews. Obviously, as ADs, you have much more experience and I trust your judgement call on this.

My original shepherd writeup noted the conflict between the requested values and the intended status:

The values requested require "Standards Action With Expert Review" however the requested RFC type is Informational. However, Jim Schaad who is one of the experts for the IANA registries has stated in a private email thread that the IANA section of this draft looks correct.

Obviously, ADs can forget in the deluge of drafts. But to hint in anyway that this was changed and no one noticed would be grossly incorrect.

--Mohit

On 2/16/21 2:43 AM, Erik Kline wrote:

On Mon, Feb 15, 2021 at 6:12 AM Magnus Westerlund via Datatracker
<[email-masked]><mailto:[email-masked]> wrote:

_______________________________________________
Lwip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lwip

---

From: Erik Kline <[email-masked]>
Date: Wed, 17 Feb 2021 15:07:22 -0800

Mohit,

I most definitely apologize if I appeared to make any accusations!  I
do seem to have not kept adequate notes on all my handling of this
document.

I meant rather to bemoan the fact that I have repeated an error that I
have made with at least one other document, an error that resulted in
these very same "change in document status" points being raised.

My apologies,
-Erik

On Tue, Feb 16, 2021 at 1:17 AM Mohit Sethi M
<[email-masked]> wrote:
> [email-masked]